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Introduction 
 

Target Audience and Purpose 
"Caution Notes and Trouble Shooting Reference Guide" is targeted to system administrators who operate 
DeploymentManager (hereafter, DPM) and explains DPM operations on the screen, tools, maintenance-related 
information, and troubleshooting. 
 

Document Structure 
・ 1 Maintenance: Explains the maintenance information of DPM. 
・ 2 Precautions: Explains precautions about DPM. 
・ 3 Troubleshooting: Explains the method to handle error information of DPM. 
 
Appendix 
Appendix A Service List 
Appendix B Event Log 
Appendix C Error Information 
Appendix D Network Port and Protocol List 
Appendix E Log Files Output by DPM 
Appendix F Procedure to Check the Version of Each Component 
Appendix G Glossary 
Appendix H Revision History 
 
 

Documentation Guidelines for DeploymentManager 
Manuals 
See "Documentation Guidelines for DeploymentManager Manuals" in First Step Guide. 
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1. Maintenance 
This chapter explains the information about the maintenance of DPM. 
 

1.1. Procedure to Change the IP Address of the 
Management Server 

Explains the procedure to change the IP address of the Management Server where DPM Server is installed 
while operating DPM. 
 

Note: 
 DPM Server does not work properly, if you do not follow the procedure. 

When changing the IP address and network configuration at the same time, see Section 3.5.1, 
"Edit Machine Group" in Web Console Reference Guide and modify Network Setting of each 
group. 

 
(1) Log on to the Management Server by a user with administrator authority. 

 
(2) Check that all operations of DPM (the following) are completed or ended. 

・ Operations for managed machines (scenario execution, automatic update, file distribution, file 
execution, file deletion and obtaining the information in File/Folder List screen) are completed. 

・ Web Console and various tools of DPM are ended. 
 

(3) Change IP address of the Management Server. 
 

(4) Restart the Management Server. 
 

(5) When ANY is selected on IP address on Management view -> DPM Server -> Detail Setting -> 
General tab on the Web Console, select again the IP address for DPM Server and click OK. 
 

(6) Restart the managed machines. 
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1.2. Procedure to Change the IP Address of the 
Database Server 

Explains the procedure to change the IP address of the Database Server while operating DPM. 
 

(1) Log on to the Management Server by a user with administrator authority. 
 

(2) Check that all operations of DPM (the following) are completed or ended. 
・ Operations for managed machines (scenario execution, automatic update, file distribution, file 

execution, file deletion and obtaining the information in File/Folder List screen) are completed. 
・ Web Console and various tools of DPM are ended. 

 
(3) Stop all services whose names begin with "DeploymentManager" from Start menu -> Management 

Tools -> Services on the Management Server.  
 

(4) Change the IP address on the Database Server. 
 

(5) Change the value in the Name of the following registry to the changed IP address for the Database 
Server on the registry editor on the Management Server. 
・ Key: 

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NEC\DeploymentManager 
・ Name: DBSrvIPAddress 

 
(6) Start ODBC Data Source Administrator screen following the procedure below. 

Execute the following command from the command prompt. 
%WINDIR%\SysWOW64\odbcad32.exe 
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(7) ODBC Data Source Administrator screen appears. After selecting System DSN tab, select DPM 

from the list of System Data Source and click Configure. 
 
 When using SQL Server 
 

 
 
 When using PostgreSQL 
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(8) Set the changed IP address for the database server 

 
 When using SQL Server 

The following screen appears. Change Server of Which SQL Server do you want to connect to? 
to IP address,port\Instance name of the Database Server and click Finish. 
 

 
 

 When using PostgreSQL 
The following screen appears. Change Server to IP address of the Database Server and click 
Save. 
 

 
 

(9) Start all services, which were stopped at Step (3) on the Management Server. 
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1.3. Procedure to Change the IP Address of the 
Managed Machine 

If IP address of the managed machine is changed, the Management Server is notified automatically. It is not 
necessary to do further action. 
However, when changing IP address of the Management Server and IP address of managed machine at the 
same time, the Management Server is not notified automatically. In this case, see "Upgrading DPM Client by 
installation media" in Section 3.3.2, "Manual Upgrading for DPM Client" in Installation Guide to reconfigure the 
IP address of the Management Server in DPM Client. 
In addition, when DPM Client is not installed in the managed machine, the Management Server is not notified. 
In this case, see Section 3.7.2, "Edit Managed Machine" in Web Console Reference Guide to reconfigure IP 
address information of the managed machine. 
It is recommended that you execute the backup scenario after changing IP address of the managed machine. If 
you restore the backup image before changing the IP address, the content of the disk is return to the original 
when executing the backup and IP address will be one before changing it. 
 

1.4. Data Backup Plan 
1.4.1. Data Backup Procedure 
Explains the procedure to backup the data while operating DPM. 
 
(1) Log on to the Management Server by a user with administrator authority. 

 
(2) When you changed detailed settings of DPM Server after installing DPM Server, select Management view 

-> DPM Server icon -> Detailed Setting on the Web Console and note the displayed setting values. 
 

(3) Check that all operations of DPM (the following) are completed or ended. 
・ Operations for managed machines(scenario execution, automatic update, file distribution, file execution, 

file deletion and obtaining the information in File/Folder List screen) are completed. 
・ Web Console and various tools of DPM are ended. 

 
(4) From Start menu, select Administrative Tools -> Services and stop all services whose names begin with 

"DeploymentManager". 
 

(5) Backup the data. 
Backup the following data. 
・ All files under <DPM Server installation folder>\DataFile 
・ All files under <DPM Server installation folder>\Linux 
・ All files under <DPM Server installation folder>\Log  
・ <DPM Server installation folder>\WebServer\App_Data\Data 

- Encypted.dat 
- DpmProfile.xml 

 
Note: 

 The default installation folder of DPM Server is: 
"C:\Program Files (x86)\NEC\DeploymentManager". 

 
・ All files under Folder for Image 

 
Note: 

 Select Management view -> DPM Server -> Detail Setting -> General tab on the Web 
Console and check Folder for Image of Image Setting. The default of Folder for Image is 
"C:\Deploy". 
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・ All files under Folder for Backup Image 

 
Note: 

 Select Management view -> DPM Server -> Detail Setting -> General tab on the Web 
Console and check Folder for Backup Image of Image Setting. The default of Folder for 
Backup Image is "C:\DeployBackup". 

 
・ The following folders and files under TFTP root folder 

- backup 
- BehaviorOnError 
- DOSFD 
- EFI64 
- EFIBC 
- EFIIA32 
- gpxelinux 
- HW 
- HW64 
- hwinfo 
- kernel 
- NBP 
- probe 
- pxelinux 
- pxelinux.cfg 
- uefipxelinux 
- nbprestvar.ini 
- Port.ini 

 
Note: 

 When you configure the cooperation of TFTP service between DPM Server and 
MasterScope Network Manager, see Appendix F, "Configuring DPM Server and 
MasterScope Network Manager on the Same Machine" in Installation Guide, TFTP root 
folder is <TFTP root folder of MasterScope Network Manager>. 

 The default of TFTP root folder is 
"C:\Program Files (x86)\NEC\DeploymentManager\PXE\Images". 

 
・ Others 

Files or registries when you changed them manually 
 
(6) Backup the database. 

Enter the following backup command on the command prompt, and then extract the backup file 
(DPM.bak). 
When you configure the Database Server, log on by the user other than Administrator, execute the 
command prompt as administrator. 
 

 When using SQL Server 
sqlcmd.exe -E -S localhost\Instance name 
BACKUP DATABASE DPM 
TO DISK='DPM.bak' 
WITH INIT 
GO 

 
Example) 

sqlcmd.exe -E -S localhost\DPMDBI 
BACKUP DATABASE DPM 
TO DISK='DPM.bak' 
WITH INIT 
GO 
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Note: 
 The database name is "DPM".(Fixed)  
 A backup file (DPM.bak) is created in the following folder: 

<Microsoft SQL Server installation folder>\Backup 
The default of <Microsoft SQL Server installation folder> is 
C:\Program Files\Microsoft SQL Server\MSSQL13.Instance name\MSSQL 

 
 When using PostgreSQL 

(1) Start the command prompt and move to the PostgreSQL installation folder(*)\bin. 
cd /d PostgreSQL installation folder(*)\bin 
 
Example) 

cd /d C:\Program Files\PostgreSQL\9.5\bin 
 

(2) Execute the following command on the command prompt. 
pg_dump.exe -h 127.0.0.1 -U User Name -p Port -F c -b -v -f "DPM.bak" Database Name 
 
Example) 

pg_dump.exe -h 127.0.0.1 -U dpmuser -p 5432 -F c -b -v -f "DPM.bak" dpm 
 
Note: 

 The backup file(DPM.bak) is created in the following folder. 
< PostgreSQL installation folder(*)>\bin 
*The default of <PostgreSQL installation folder> is "C:\Program Files\PostgreSQL\9.5". 

 
(7) Backup the registry data. 

・ DPM Server 
By executing the following command on the command prompt, extract the backup file 
(RegExportDPM.reg). 
(The following command is described in two or more lines. Enter it by one line in the actual screen.) 
 
regedit /e RegExportDPM.reg 
"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NEC\DeploymentManager" 

 
・ Database 

By executing the following command on the command prompt, extract the backup file 
(RegExportDPMDB.reg). 
When you configure the Database Server, log on by the user who configured the database on the 
Database Server and execute the following. 
(The following command is described in two or more lines. Enter it by one line in the actual screen.) 
 
- When OS is x64 

regedit /e RegExportDPMDB.reg 
"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NEC\DeploymentManager_DB" 

- When OS is x86 
regedit /e RegExportDPMDB.reg 
"HKEY_LOCAL_MACHINE\SOFTWARE\NEC\DeploymentManager_DB" 

 
Note: 

 When using PostgreSQL, backup for the registry data of the database is not required. 
 Backup files(RegExportDPM.reg and RegExportDPMDB.reg) will be created in the folder 

where the command is executed. 
 

(8) Start all services that were stopped at Step (4). 
 

The backup of data updated while operating DPM is completed. 
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1.4.2. Data Recover Procedure 
Recover the DPM environment by the data which were backed up in Section 1.4.1, "Data Backup Procedure", 
following the procedure below. 
 
(1) Log on to the Management Server by a user with administrator authority. 
 

Note: 
 When you configure the database on the same machine with DPM Server, it is recommended 

that you log on by Administrator and install DPM Server. When you installed DPM Server by a 
user with administrator authority except Administrator, you need to launch Image Builder, 
which is installed on the same machine with DPM Server, as an administrator. 

 
(2) Install DPM Server and configure the detailed setting. 

・ When you install DPM Server and recover 
Install DPM Server(and configure the detailed setting), following the description below. 
- Installation Guide 
- Setting items that you noted when you installed DPM Server 

If there are setting values that you noted at Step (2) of Section 1.4.1, "Data Backup Procedure" about 
the setting in Detailed Setting screen displayed when installing DPM Server, enter the values. 

・ When you only recover the data (DPM Server is already installed.) 
Specify the setting values that you noted at Step (2) of Section 1.4.1, "Data Backup Procedure", in 
Management view -> DPM Server icon -> Detailed Setting on the Web Console. 
If you have not changed the detailed setting after installing DPM Server, configure the setting that you 
noted when installing DPM Server. 

 
(3) From Start menu, select Administrative Tools -> Services and stop all services whose names begin with 

"DeploymentManager". 
 
(4) Overwrite the same folder or file path as when you backed up by the backup data that were collected at 

Step (5) of Section 1.4.1, "Data Backup Procedure". 
Also, configure the noted setting when there are the setting that you noted at Step (5) "Others" of Section 
1.4.1, "Data Backup Procedure" 

 
(5) Copy the backup file of database, which has been obtained at Step (6) in Section 1.4.1, "Data Backup 

Procedure" onto the same folder path when you performed back up. 
When you configure the Database Server, log on by the user who configured the database on the 
Database Server to execute. 
 

(6) Confirm the configuration of the database.(When using SQL Server) 
When you configure the Database Server, log on by the user who configured the database on the 
Database Server and execute the following. 
1) From Explorer and others, display the property of DPM.bak and confirm whether the user whose name 

that start with "MSSQL$Instance name" on Security tab exists or not. 
2) Click Detailed Setting tab, and if there is a user whose name starts with "MSSQL$Instance name" in 

1), confirm whether the Include inheritable permissions from this object's parent checkbox is 
checked or not. 
If there is no user whose name starts with "MSSQL$Instance name" in 1), check the Include 
inheritable permissions from this object's parent checkbox. (If this checkbox is selected, a user 
whose name begins with " MSSQL$Instance name" will be added to the Security tab.) 
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(7) Start the command prompt, and then execute the following command. 

When you log on by the user other than Administrator, execute command prompt as administrator. 
 
 When using SQL Server 

sqlcmd.exe -E -S localhost\Instance name 
RESTORE DATABASE DPM 
FROM DISK = 'DPM.bak' 
WITH REPLACE 
GO 

Example) 
sqlcmd.exe -E -S localhost\DPMDBI 
RESTORE DATABASE DPM 
FROM DISK = 'DPM.bak' 
WITH REPLACE 
GO 

 When using PostgreSQL 
(1) Start the command prompt and move to the PostgreSQL installation folder(*)\bin. 

cd /d PostgreSQL installation folder(*)\bin 
 

*The default is C:\Program Files\PostgreSQL\9.5 
 
Example) 

cd /d C:\Program Files\PostgreSQL\9.5\bin 
 

(2) Execute the following command on the command prompt. 
pg_restore.exe -h 127.0.0.1 -U User Name -p Port -d Database Name -v "DPM.bak" 

 
Example) 

pg_restore.exe -h 127.0.0.1 -U dpmuser -p 5432 -d dpm -v "DPM.bak" 
 

(8) Apply the backup file of the registry data extracted at Step (7) of Section 1.4.1, "Data Backup Procedure" 
on the machine that you backed up. (Double-click from Explorer.) 
 

(9) Start all services that were stopped at Step (3). 
 

(10) Start the command prompt and execute the following command. 
iisreset /restart 

 
Recovering DPM data is completed. 
 

1.5. Scenario Migration Procedure 
This chapter explains the procedure to migrate the scenario to the different Management Server with scenario 
migration tool. 
 

 Scenario migration tool is stored in the following folder in DPM installation media. 
<Installation media>:\DPM\TOOLS\ScenarioMigration 
The file name is as follows 
・ ScenarioMigration.exe 
・ ScenarioMigration50-63.exe(used for export on DPM6.3x or earlier) 

 Scenario migration procedure supports the following scenario type. 
・ Backup scenario 
・ Restore scenario 
・ Disk configuration check scenario 

 Migrate the image files and the parameter files specified on scenario manually. 
 You can use the export function on DPM 5.0 or later. 
 You can use the import function on DPM 6.6 or later. 
 When you execute ScenarioMigration50-63, prepare the runtime for Visual C++ 2008 beforehand. 
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 Scenario export procedure 
 
Execute the following on the Management Server to export scenario. 
 
(1) Start the command prompt 

 
(2) Execute the following command  

For DPM 6.4 or later 
ScenarioMigration.exe /E "export destination folder" 

 
For DPM 5.0-DPM 6.3x 

ScenarioMigration50-63.exe /E "export destination folder" 
You can execute the tool from <Installation media>. 
 
Note: 

 There is no restriction for the user account. 
 

 Scenario import procedure 
 

Execute the following on the Management Server to import scenario. 
 

(1) Start the command prompt. 
 

(2) Execute the following command. 
ScenarioMigration.exe /I "Import source folder" 
You can execute the tool from <Installation media>. 
 

(3) Restart the Management Server. 
 

1.6. Port Change Procedure on DPM 
The chapter explains the procedure to change the port used by DPM. 
 

When you do not follow the procedure, there is a possibility the Management Server/managed machine 
might not work properly. 

 
 If you do not follow the procedure, the Management Server and managed machines do not work 

properly. 
 When you change the port used by ftsvc.exe (TCP:26508), specify the same port in the Setting 

Connection screen of Image Builder (Remote Console). 
 The default values of the ports to be used differ in the version earlier than DPM Ver6.1. For details of 

the port number, see Appendix D, "Network Port and Protocol List." 
 When you install DPM Server newly, DPM Client of the version earlier than DPM Ver6.1 cannot be 

upgraded automatically. 
Execute the either of the following. 
・ Before you install DPM Server newly, set the port, which was used before upgrading, in Port.ini by 

following the procedure in this section. 
・ After you installed DPM Server newly, upgrade DPM Client by a scenario, see Section 3.3.2, 

"Manual Upgrading for DPM Client" in Installation Guide. (It takes about 20 minutes until the 
scenario is completed.) 

 The master image for OS installation by disk duplication, created in the version earlier than DPM 
Ver6.1, cannot be used in the environment that DPM Server is installed newly.  
Re-create a master image in this version, or set the port, which was used before upgrading, in Port.ini 
following the procedure in this section, before you install DPM Server newly. 

 
 The procedure to change the port before installing DPM Server newly. 
 
(1) Log on to the Management Server by a user with administrator authority. 

 
(2) Copy the following file to %SystemDrive%(Default C:)\DPMPort\. 
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<Installation media>:\DPM\Setup\DPM\Port.ini 
 

(3) Specify the port to use in the copied file and save the file. 
 

(4) Install DPM Server newly. 
 

Note: 
 When you upgrade DPM Server, the ports, which were used before upgrading, are taken over. 

 
 The procedure to change the port after installing DPM Server. 

Execute the following procedure on the Management Server. 
 
(1) Log on to the Management Server by a user with administrator authority. 

 
(2) Check that all following DPM operations are completed. 

・ Operations which are being executed for managed machine(scenario execution, automatic update, file 
distribution, file execution, file deletion, and obtaining the information in File/Folder List screen) are 
completed. 

・ Web Console and each tool of DPM are ended. 
 
(3) Edit <TFTP root folder>\Port.ini. 
 
 The default of TFTP root folder is  

"C:\Program Files (x86)\NEC\DeploymentManager\PXE\Images". 
 When you change the port for Web Service (Default:26500), modify the following line in <TFTP root 

folder>\WebServer\App_Data\Config\MgrServerList.xml. 
<Port>The port to change</Port> 

 
(4) Restart the Management Server. 

 
(5) Restart managed machines. 

 

1.7. Database Transfer Procedure 
This chapter explains the procedure to transfer database. 
 

 This procedure supports Microsoft SQL Server 2012 or later. Also, PostgreSQL is not supported. 
 If you do not follow the procedure, the Management Server does not work properly. 
 Setting should be the same between install path/architecture/instance name and so on of SQL Server 

for the transfer destination and that of transfer source. 
 When specifying "SQL Authentication", select "Mixed Mode" for SQL instance authentication mode. 
 When you configure the database transfer destination on the different machine from the Management 

Server and specifying "Windows Authentication", both the Management Server and the Database 
Server should participate in the domain, 

 When Microsoft SQL Server 2012 Native Client is already installed, installation SQL Server might fail. 
In that case, uninstall Microsoft SQL Server 2012 Native Client and install again. 

 
(1) Log on to the Management Server by a user with administrator authority. 

 
(2) Check that all operations of DPM (the following) are completed or ended. 

・ Operations for managed machines(scenario execution, automatic update, file distribution, file execution, 
file deletion and obtaining the information in File/Folder List screen) are completed. 

・ Web Console and various tools of DPM are ended. 
 

(3) Configure SQL Server instance on the machine of the database transfer destination. 
When specifying "SQL Authentication" for the database authentication, see "Configure the database." in 
Appendix D "Configuring the Database for SQL Server on the Database Server" in Installation Guide. 
When specifying "Windows Authentication" for the database authentication, see (1) to (6) and (8) to (13) 
from "Configure the database." in Appendix D "Configuring the Database for SQL Server on the Database 
Server" in Installation Guide. 
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(4) Transfer DB data from the database transfer source to the database transfer destination. 

See (6) from Section 1.4.1, "Data Backup Procedure" and (6)(7) from Section 1.4.2, "Data Recover 
Procedure" for the procedure. 
 

(5) Create the domain user to access on the database transfer destination. 
When the database transfer destination and the Management Server participate in the domain, start the 
command prompt and execute the following. 
In any other case, skip to Step (8). 
 
(The following command is described in two or more lines. Enter it by one line in the actual screen.) 
 

C:\>sqlcmd -E -S .\Instance name 
1> CREATE LOGIN [domain name\DPM Server user name] FROM WINDOWS  

WITH DEFAULT_DATABASE=DPM 
2> go 
1> EXEC master..sp_addsrvrolemember @loginame = N' domain name\DPM Server user name', 

@rolename = N'sysadmin' 
2> go 
1> CREATE LOGIN [domain name\computer name for DPM Server$] FROM WINDOWS 

WITH DEFAULT_DATABASE=DPM 
2> go 
1> EXEC master..sp_addsrvrolemember @loginame = N' domain name\computer name for DPM 

Server$',  
@rolename = N'sysadmin' 

2> go 
1> exit 

 
Example) 

C:\>sqlcmd -E -S .\DPMDBI 
1> CREATE LOGIN [MCIPT\test2] FROM WINDOWS WITH DEFAULT_DATABASE=DPM 
2> go 
1> EXEC master..sp_addsrvrolemember @loginame = N'MCIPT\test2', @rolename = N'sysadmin' 
2> go 
1> CREATE LOGIN [MCIPT\computer2$] FROM WINDOWS WITH DEFAULT_DATABASE=DPM 
2> go 
1> EXEC master..sp_addsrvrolemember @loginame = N'MCIPT\computer2$', @rolename = 
N'sysadmin' 
2> go 
1> exit 
 

(6) Start the service after changing "Startup Type" to "Auto" for "SQL Server Browser" of the database 
transfer destination. 
 

(7) Set Windows Firewall on the database transfer destination and permit the communication of the 
following program.  
- Program: sqlbrowser.exe 

 
Note: 

 The default of the install path for sqlbrowser.exe is as follows. 
C:\Program Files (x86)\Microsoft SQL Server\90\Shared 
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(8) Move to the folder on which DPM Server is installed on the Management Server and execute 

the database setting tool (DPMDBIConfig.exe). 
 
Note: 

 The default of the install folder on DPM Server is as follows. 
C:\Program Files (x86)\NEC\DeploymentManager 

 

 
Set each item after appearing the screen and click Confirm. 
Click OK after "Database connection has succeeded" is appeared. 
"Database settings have been completed" is displayed. 
Click Cancel to close tools. 
 

 Set the same value for the instance name, the account name and the password on the screen 
as those of created at Step (3) the setting value of the database transfer destination. 

 When you configure the database transfer destination on the different machine from the 
Management Server, select "Configure the database on the other machine" and enter the 
host name or the IP address of the database transfer destination. 
・ When you execute database connection by using the host name, enable "Network 

Discovery(NB-name-In)" from the Inbound Rules on Windows Firewall for the database 
transfer destination. 

・ When you execute database by using the IP address, to allow DNS reverse resolution. 
When you do not set, there might be a case that database connection and processing might 
take time and fail in DPM Service start-up. 

 
(9) Start the command prompt of the Management Server and start the followings. 

 
(The following command is described in two or more lines. Enter it by one line in the actual screen.) 
C:\> "<DPM Server Install Folder>\svcctrl.exe" -remove -c "apiserv.exe" "apiserv"  

"DeploymentManager API Service" 
C:\> "<DPM Server Install Folder>\svcctrl.exe" -remove -c "schwatch.exe" "schwatch" 

 "DeploymentManager Schedule Management" 
C:\> "<DPM Server Install Folder>\apiserv.exe" /service 
C:\> "<DPM Server Install Folder>\schwatch.exe" /install 
 

(10) Start the following service. 
・ DeploymentManager API Service 

DeploymentManager Schedule Management will be started automatically. 
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(11) Uninstall SQL Server instance on the database transfer source 

See "Uninstall the database." in Appendix D "Configuring the Database for SQL Server on the 
Database Server" in Installation Guide for the procedure. 
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2. Precautions 
This chapter explains precautions for DPM. 
 

2.1. Notes for Device and Storage 
2.1.1. The Module for the Machine Model 
The module for the machine model is the update module enables the machine model not supported by 
Deploy-OS which is included as standard to the managed machine. 
For notes about the module for the machine model, contact your sales or support representative. 
  

2.2. Notes when You Change the Computer Name 
(the Host Name) of the Management Server 
and the Managed Machine 
 

You can change the computer name (the host name) on the OS of the Management Server and the managed 
machine at any timing. 
When you use the host name in the URL on the Web Console, change it to match with the computer name of 
the Management Server. 
When you changed the computer name (the host name) of the managed machine, if you restore the backup 
image before changing the computer name (the host name), the content of the disk is returned to the original 
status when executing the backup and the computer name (the host name) will be one before changing it. It is 
recommended that you execute the backup after changing the name. 
 

2.3. Notes when You Change the User Name/the 
Password on the OS of the Management 
Server and the Managed Machine 

When you change the user name/the password on the OS of the Management Server and the managed 
machine, it does not affect the operation later. 
However, if you restore the backup image before changing the user name/the password on the OS of the 
managed machine, the content of the disk is returned to the original status when executing the backup and the 
user name/the password will be one before changing it. It is recommended that you execute the backup after 
changing the user name/the password. 
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2.4. Notes for OS Clear Installation 
When you cannot set up NFS server, you can execute OS clear installation of Red Hat Enterprise Linux 6 by 
setting up FTP/HTTP server on the Management Server. 
This chapter explains notes about the case. In addition ,explains as the folder for image has the following 
configuration. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
・ See Section 3.5.1, "Creating and Registering an Image" in Operation Guide, create and register an image. 

Replace as the following about Section 3.5.1.1, "Setting up NFS Service". 
 

Seeing manuals of FTP/HTTP server and so on, set "exports" folder under Folder for Image set on the Web 
Console as the virtual directory of FTP/HTTP server after configuring FTP/HTTP server,  

 
・ Perform the following before the procedure of Section 3.5.2, "Creating a Scenario" in Operation Guide. 

- Open the boot parameter file by text editor and so on and modify the description of the file 
server(underlined) following the environment, seeing the following example. 

 
Example) 

Before modification: 
append initrd= RHEL6/initrd.img ks=nfs:192.168.0.1:/exports/ks/ks.cfg ksdevice=eth0 

After modification: 
- For FTP server 

append initrd= RHEL6/initrd.img ks=ftp://192.168.0.1/exports/ks/ks.cfg ksdevice=eth0 
- For HTTP server 

append initrd= RHEL6/initrd.img ks=http://192.168.0.1/exports/ks/ks.cfg ksdevice=eth0 
- Open the installation parameter file by text editor and so on, modify the description of the file 

server(underlined) following the environment, seeing the following example. 
 

Example) 
Before modification: 

... 
nfs --server 192.168.0.1 --dir /exports/RHEL6 
... 
#Mount /mnt/exports 
mkdir /mnt 
mkdir /mnt/exports 
/bin/mount -o nolock -t nfs $NFSSERVER:/exports /mnt/exports 
... 

After modification: 
- For FTP server 

Management Server(IP address:192.168.0.1) 

Folder for image 

AnsFile\ 
 

Boot parameter file 

exports\ 

ks\ 

Install parameter file 

Boot directory (Boot directory name: RHEL6) 

Install image 

Linux\ 

daemon\ 
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... 
url -url ftp://192.168.0.1/exports/RHEL6 
... 
#Mount /mnt/exports 
mkdir -p /mnt/exports/daemon/redhatall/ia32/ 
cd /mnt/exports/daemon/redhatall/ia32/ 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depagt 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depagtd 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depagtd.res 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depcancel 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depinst 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depinst.res 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depinst.sh 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/dpmversion.inf 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/GetBootServerIP 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/getinfo.sh 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/server.inf 
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/xdpmmsg 
... 

 
- For HTTP server 

... 
url -url http://192.168.0.1/exports/RHEL6 
... 
#Mount /mnt/exports 
mkdir -p /mnt/exports/daemon/redhatall/ia32/ 
cd /mnt/exports/daemon/redhatall/ia32/ 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depagt 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depagtd 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depagtd.res 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depcancel 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depinst 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depinst.res 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depinst.sh 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/dpmversion.inf 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/GetBootServerIP 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/getinfo.sh 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/server.inf 
wget http://192.168.0.1/exports/daemon/redhatall/ia32/xdpmmsg 
... 

- Mount ISO file for installation of Red Hat Enterprise Linux 6 and copy all the contents in ISO to 
the boot directory.  
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3. Troubleshooting 
This chapter explains how to handle when the problem occurs on DPM. 
 

3.1. Web Console 
 

Q1 
When you click Detail under HotFix/Application on the Machine Detail screen, the HotFix/Application 
List screen items are not displayed. 

 
A1-1 

To manage the managed machine, DPM Client with the same version as DPM Server is need to be 
installed. 
If it is already installed, reinstall. For the installation procedure, see Section 2.2, "Installing DPM Client" 
in Installation Guide. 

 
A1-2 

From Start menu on the managed machine, select Administrative Tools -> Services, and confirm 
that DeploymentManager Agent Service and DeploymentManager Remote Update Service Client 
are running. 

 
 
 

Q2 
The screen Socket error has occurred. is displayed when you update information.  
Or, the following message is displayed as detailed information: 
No connection could be made because the target machine actively refused it. 
Management Server IP address:26500 
 

A2 
The Management Server may be shut down. From Start menu, select Administrative Tools -> 
Services and confirm that all of the services listed in " DPM Server" in Appendix A, "Service List" are 
running. 
If the service is stopped, start all of the services that are not running. 
Furthermore, try to reconnect to Management Server after services started. 

 
 
 

Q3 
When you start the Web Console from the Web browser, error The Page cannot be displayed appears. 
One of the following is possible: 

 
A3 
・ The URL to start the Web Console may be incorrect. Confirm that the URL is correct. 
・ The Web Site might not be running. From Start menu, select Administrative Tools -> Internet 

Information Services (IIS) Manager, and confirm that Default Web Site is running. 
 
 
 

Q4 
The following screen appears when you start Web Console and unable to use. 
HTTP error 500.19 This configuration section cannot be used at this path. 

 
A4 

There is a possibility "IsapiModule" or "IsapiFilterModule" to operate in classic mode when installing 
ASP.NET might not be installed. 
Above modules are necessary because the communication with Web Server on DeploymentManager 
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is executed in classic mode. 
To check whether "IsapiModule" and "IsapiFilterModule" are installed, follow the below procedure. 
[Confirmation Procedure] 

1.Start IIS manager. 
2.Select the in-use server. 
3.Open Module -> IIS on the displayed screen. 
4.Check if "IsapiModule" and "IsapiFilterModule" exists or not. 

 
When "IsapiModule" and "IsapiFilterModule" do not exist, add the module by the following procedure. 

[Adding procedure] 
1.Start IIS manager 
2.Select the in-use server. 
3.Open Module -> IIS on the displayed screen. 
4.Select Native module configuration...on the right side of the menu. 
5.Check "IsapiModule" or "IsapiFilterModule" from the displayed dialog and click OK. 
6.Restart IIS. 

 
 
 

Q5 
When you access the Web Console from two or more windows or tabs, the following occurs due to the 
session sharing function of Internet Explorer. 

・ The user authority of the Web Console will be the same with the authority of the user who logged 
last. 

・ An error occurs when you switch the page in window or tab that you opened first, or change the 
number of lines to be displayed. 

 
A5 

When you open two or more Web Consoles, separate sessions in the following procedure. 
Launch Internet Explorer as new session and open the Web Console. To launch Internet Explorer as 
new session, select File -> New Session in Internet Explorer which is already launched. 

 
 
 

Q6 
Error message display error. 

 
A6 

When you use an HTML tag (<xx>) for a computer name or group name and so on, the entered text is 
interpreted as HTML syntax and may not be properly displayed in the error message. 
However, operations are not affected. 

 
 
 

Q7 
Even if you start the Web Console from the Web browser, nothing is displayed on the Web browser. 

 
A7 

From Tools menu -> Internet Options in Internet Explorer, select Trusted Sites on the Security tab. 
After clicking Sites, add a URL which connects to the Management Server. 
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Example) When the Management Server IP address is 192.168.2.41 

 
 
 
 

Q8 
When you start the Web Console on Windows Server 2003/Windows Server 2003 R2, the following 
message is displayed: 

 
 
A8 

Confirm that the URL is not wrong, and then click Add and add the Web site to the Trusted Sites zone. 
 
 
 

Q9 
You performed one of the following operations, however the File Download screen is not displayed, and 
you could not download CSV files. 
・ On the Monitor view -> Scenario Execution Result List -> Scenario Execution Result List screen, 

click Save In CSV in Operation menu. 
・ On the Monitor view -> Automatic Update Result List -> Automatic Update Result List screen, 

click Save In CSV in Operation menu. 
・ On the Operations view -> Group List screen, click Export Machine Data in Configuration menu. 

 
A9 

Check security setting on Internet Explorer. 
Select the Internet Explorer Tools menu -> Internet Options, then click Security tab -> Security 
level for this zone on Trusted Site -> Custom level, and configure as follows: 
・ Set Enable from Downloads - File download. 
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Q10 

The Web Console cannot be started. In the screen, "Internet Explorer cannot display the webpage" is 
displayed. 

 
A10-1 

Web Server may not be running. From Start menu, select Administrative Tools -> Internet 
Information Services (IIS) Manager and confirm whether Default Web Site is launched. 

 
A10-2 

Anonymous access of IIS may be disabled. Change the setting as following. 
(1) From Start menu, select Administrative Tools -> Internet Information Services (IIS) Manager. 
(2) Internet Information Services (IIS) Manager screen appears. Click DPM directly under Default 

Web Site in the left side of the screen. 
(3) Select Authentication in IIS in the center of the screen and click Open Feature in Actions in the 

right of the screen. 
(4) Select Anonymous Authentication in Authentication screen in the center of the screen and click 

Edit... in Actions in the right of the screen. 
(5) Edit anonymous authentication qualification information appears. Confirm whether Specific 

User is selected and the user name is "IUSR". If it is not "IUSR", click Setting and set "IUSR" in the 
user name. 

(6) Close the screen by clicking OK in Anonymous authentication qualification information. 
(7) Select Anonymous Authentication in Authentication screen and click Enabled in Actions in the 

right of the screen. 
 
 
 

Q11 
The following phenomenon occurs when operating Web Console. 
・ Screen transition takes time.(several minutes to several tens of minutes) 
・ "Unable to get property 'src' of undefined or null reference."is displayed when screen transition and 

the screen is not displayed. 
・ Button and menu are not displayed. 

 
A11 

Compatibility view on Internet Explorer might be disable. 
Click "Compatibility View" displayed on the address bar to enable. 
On Internet Explorer 11, Internet Explorer 8 compatible mode is automatically set when starting Web 
Console. Therefore, setting compatible mode explicitly is not necessary. 

 
 
 

Q12 
When you open the Web Console screen (such as Add Machine screen or Add Scenario screen) the 
characters displayed on the screen are garbled. 

 
A12 

This may be avoided by turning off Auto-Select of Encoding on Internet Explorer. 
You can set OFF by clearing View menu -> Encoding -> Auto-Select. 
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Q13 

On the Backup/Restore tab of the scenario, you click Browse on the Image File and a network drive or 
USB hard disk is not displayed. 

 
A13 

Only local disk is displayed as a drive. When you specify a network drive or USB hard disk, enter the 
image file path on Image File text box directly. 
See Section 3.13.4, "Backup/Restore Tab" in Web Console Reference Guide for details. 

 
 
 

Q14 
The MAC address of the managed machine is not displayed on the Web Console. 

 
A14-1 

The MAC address may not be displayed temporarily because of replacing LAN board to other 
machines and so on. 
If such a phenomenon occurs, manually reboot the managed machine. 
If the phenomenon occurs after reboot, delete the corresponding managed machine from the Web 
Console and then reregister. 
*When the MAC address of the managed machine is not displayed, you cannot perform the following 

operations: 
・ Set the Automatic Update Time for the managed machine 
・ Obtain the power status 
・ Obtain the managed machine information 
・ Execute Scenario 
・ Power ON 
・ Shutdown 

 
A14-2 

The MAC address for a managed machine running on Linux OS and mounted with two or more LAN 
boards may not be displayed during operation. 
In such a case, the corresponding managed machine may be registered to a New Machine group. 
Delete the corresponding managed machine from the New Machine group, and then reboot DPM 
Client on the managed machine. If the phenomenon occurs after reboot, delete the corresponding 
managed machine from the Web Console and then reregister. 

 
 
 

Q15 
After a certain amount of time passes without any operation, the display of the Web Console is returned 
to Deployment Manager Login screen at the next operation. 

 
A15 

If session timeout occurs on the Web Console, the display is returned to Deployment Manager 
Login screen. Login again. 
You can change the setting of timeout by the following procedure. 
(1) From Start menu, select Administrative Tools -> Internet Information Services (IIS) Manager. 
(2) Internet Information Services (IIS) Manager screen appears. Click Application Pools in the 

left side of the screen. 
(3) Select ASP.NET v4.0 DeploymentManagerPool in Application Pools in the center of the 

screen and click Stop in Application Pool Task in the right side of the screen. 
For Windows Server 2012 or later, select DeploymentManagerPool. 

(4) Click Default Web Site in the left side of the screen and click Stop in Manage Web Site in the 
right of the screen. 
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(5) Click DPM directly under Default Web Site in the left side of the screen and select Session State 

in ASP.NET in the center of the screen. Click Open Feature in Actions in the right side of the 
screen. 

(6) Specify the value of timeout in Cookie Settings -> Time-out (in minutes)(O)(The default is 20 
minutes) in Session State screen in the center of the screen. Click Apply in Actions in the right 
side of the screen. 

(7) Click DPM directly under Default Web Site in the left side of the screen. Select Authentication of 
IIS in the center of the screen. Click Open Feature in Actions in the right side of the screen. 

(8) Select Forms Authentication in Authentication screen in the center of the screen. Click Edit... 
in Actions in the right side of the screen. 

(9) Edit Forms Authentication Settings screen appears. Specify the value of timeout in 
Authentication cookie time-out (in minutes)(O)(The default is 30 minutes). Click OK. 

(10) Click Application Pools in the left side of the screen. Select ASP.NET v4.0 
DeploymentManagerPool in Application Pools in the center of the screen.  
Click Advanced Setting in Edit Application Pools in the right side of the screen. 
For Windows Server 2012 or later, select DeploymentManagerPool. 

(11) Advanced Settings screen appears. Specify the value of timeout in the following 2 items. Click 
OK. 
・ Process Model - Timeout in idle status(minute) (The default is 20 minutes) 
・ Recycle - Periodic Interval (minute) (The default is 1740 minutes) 

(12) Click Start in Application Pool Task in the right side of the screen. 
(13) Click Default Web Site in the left side of the screen and click Start in Manage Web Site in the right 

side of the screen. 
 
 
 

Q16 
The following message appears when you start the Web Console. The managed machine cannot be 
deleted from the Web Console. 

 
The trial period has been passed. 

 
A16 

When there is a shortage in the number of the license, add the license or delete the managed machine. 
When you delete the managed machine, delete with cliremove command on DPM Command Line 
because the registration information is not displayed on the Web Console. 
Restart the Web Console, after deleting the managed machine. 
See Section 4.1.11. "Delete Managed Machine" in Tool Reference Guide for details of the use of the 
DPM Command Line. 
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3.2. Management Server 
 

Q1 
When you set different machines as DHCP server and the Management Server, you cannot obtain the 
MAC address for the managed machine. 
 
A1-1 

The DHCP service on the Management Server may still be running. On the Management Server, from 
Start menu, select Administrative Tools -> Services, and confirm that Status under DHCP Server is 
not Started. If it is Started, open the Properties screen, disable Startup type, and stop the service. 

 
A1-2 

In Detail Setting, the DHCP server is installed on an another machine checkbox may not be 
checked. Select Management view -> DPM Server -> Detail Setting on the Web Console, click the 
DHCP Server tab, and confirm that the DHCP server is installed on an another machine checkbox 
is checked. If the checkbox is not checked, check it and click OK, and then reboot the Management 
Server. (If the Management Server cannot be rebooted, stop all services listed in Appendix A, "Service 
List" by selecting Administrative Tools -> Services from Start menu, and then start all of the stopped 
services.) 

 
 
 

Q2 
DPM Server services are not running. 

 
A2-1 

A service may terminate if an error occurs during scenario execution. 
If a scenario is executing, wait until it completes and then perform the following operations. 
From Start menu, select Administrative Tools -> Services on the Management Server, and then 
restart the following services. 

(Start if the service is stopped.) 
DeploymentManager API Service 
DeploymentManager Backup/Restore Management 
DeploymentManager Get Client Information 
DeploymentManager PXE Management 
DeploymentManager PXE Mtftp (Restart is not needed when startup type is disabled.) 
DeploymentManager Remote Update Service 
DeploymentManager Schedule Management 
DeploymentManager Transfer Management 

 
A2-2 

By performing an overwrite installation of DPM Server, it will be recovered. 
 
 
 

Q3 
You cannot start the DeploymentManager API Service. 

 
A3 

Port (TCP:56050/26500) may be in use by other applications and so on. 
When Port(TCP:56050/26500) is used by other application, change the setting for the port number of 
either DPM or other application.  
If you change the port number of DPM, see Section 1.6, "Port Change Procedure on DPM". 
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Q4 

You cannot start the DeploymentManager Remote Update Service. 
Furthermore, the following error log is listed in <DPM Server installation 
folder>\Log\rupdssvc.csv :"RUPDSSVC: FUNCTION: CreateSocket(): bind Failed, error code=10048"  

 
A4 

Port (TCP:56024/26506, TCP:56028/26507) may be in use by other applications and so on. 
When Port(TCP:56024/26506, TCP:56028/26507) is used by other application, change the setting for 
port number of either DPM or other application. If you change the port number of DPM, see Section 1.6, 
"Port Change Procedure on DPM". 

 
 
 

Q5 
When you uninstall and then install DPM Server, scenarios and groups existing before the uninstall still 
remain. 

 
A5 

The uninstallation may not be performed properly. Follow the procedure below to reinstall: 
(1) Perform uninstall again. 
(2) Reboot the machine installed with DPM Server. 
(3) Delete the contents under the folder installed with DPM Server and the Folder for Image 

(the defaults are C:\Program Files (x86)\NEC\DeploymentManager and C:\Deploy). 
(4) Install again. 

 
 
 

Q6 
When you perform an overwrite installation after interrupting uninstall, an error message appears and 
you cannot overwrite. 

 
A6 

Install DPM Server newly after uninstalling completely. 
 
 
 

Q7 
There is no response even if you execute DPM Server silent installation. 

 
A7 

The network connection may not be detected. 
After confirming the network environment, install DPM Server again. 

 
 
 

Q8 
Following message is displayed when DPM Server installation, and fail in installation. 
"Failed to install DPM Server(DB)." 

 
A8 

When Microsoft SQL Server2012 Native Client is already installed, there is a possibility installation of 
DPM Server might fail in. 
Uninstall Microsoft SQL Server 2012 Client and reinstall DPM Server. 
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Q9 

When "`" is included in the folder path where DPM Server is installed, "It failed to set DSN." is 
displayed and fail in overwriting. 

 
A9 

Overwrite installation DPM Server again after installing Microsoft SQL Server 2012 Native Client by 
following steps. 
1)Copy below file to arbitrary (C:\). 

<Installation media>:\DPM\Setup\SQLNCLI\sqlncli_x64.msi 
2) Rename the copied file to "sqlncli.msi ". 
3) Execute "sqlncli.msi". 
4) Delete copied file after execution. 
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3.3. Managed Machine 
 

Q1 
The standby function did not appear when you terminate the managed machine. 

 
A1 

Check the following: 
・ If the Terminal Service is enabled, you cannot use the standby function. 

From the control panel, disable the Terminal Service. 
・ Unless the device driver and so on are properly installed, the standby function cannot be used. 
 

 
 

Q2 
When you used Remote Desktop to perform installation, upgrading, or uninstallation of DPM Client, the 
following message was displayed: 

 
The following error occurred on the file, xxxxx\DepAgent.dll. 
Access is denied. 
(0x5) 
* xxxxx stands for a file path (variable). 

 
A2 

If installation, upgrading, or uninstallation is performed while Event viewer on the managed machine is 
open, the above message may be displayed. 
To Install/Upgrade Install/Uninstall, after selecting the Ignore and closing the above message, reboot 
the managed machine and re-execute. 
For Uninstall, the DepAgent.dll file is automatically deleted after the machine restarts, so it is not 
necessary to re-execute. 

 
 
 

Q3 
You cannot start DeploymentManager Remote Update Service Client service. 
Furthermore, the following error log is listed in rupdsvc.log. 
RUPDSVC: bind() failed, code = 10048  
*rupdsvc.log is located in the following folder: 

・ For x64: C:\Program Files (x86)\NEC\DeploymentManager_Client\ 
・ For x86: C:\Program Files\NEC\DeploymentManager_Client\ 

 
A3 

Port (TCP:56000/26510, TCP:56025/26511) may be in use by other applications and so on. 
When Port(TCP:56000/26510, TCP:56025/26511) is used by other application, change the setting for 
port number of either DPM or other application.  
If you change the port number of DPM, see Section 1.6, "Port Change Procedure on DPM". 

 
 
 

Q4 
You cannot start DeploymentManager Update Service Client service. 
Furthermore, the following error log is listed in rupdsvc.log. 

"Multicast receive socket create error, code = 10048" 
* rupdsvc.log is located in the following folder: 

・ For x64: C:\Program Files (x86)\NEC\DeploymentManager_Client\ 
・ For x86: C:\Program Files\NEC\DeploymentManager Client\ 
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A4 
Port (UDP:56001/26529) may be in use by other applications and so on. 
When Port(TCP:56001/26529) is used by other application, change the setting for port number of 
either DPM or other application.  
If you change the port number of DPM, please refer 1.6 "Port Change Procedure on DPM". 

 
 
 

Q5 
Joining a managed machine of Windows Server 2008/Windows Vista or later to the domain will initialize 
the setting of Firewall and enable it. 

 
A5 

This happens when the domain security policy is undefined in the domain server. 
Define the domain security policy before joining to the domain. 

 
 
 

Q6 
You cannot WOL (Wake On LAN) remotely the managed machine. 

 
A6 

Confirm followings. 
・ Refer the manual for the hardware and enable the setting of WOL and network boot to the 

managed machine. 
・ WOL with on-board LAN is correspond to DPM. 

When you use the managed machine by connecting the expanded LAN board, WOL is not 
supported. 

・ There is a possibility when turning off the power forcibly by press and hold button,WOL might fail 
in due to the specification of the hardware. 
In that case, turn on the power manually and shut down after starting OS enables WOL next 
time. 

・ When Link Speed and Duplex of the switch port connected to the managed machine are not set 
as Auto, WOL might not be performed. 
Check whether LAN is linked up or not while the power of the managed machine is turned on. 
There is a possibility that LAN is not linked up, WOL might not be performed from DPM.  
Check the setting of the switch port and the driver and set Link Speed and Duplex as Auto. 
Turn on the power manually if necessary.  
When the Management Server and the managed machine exist in the different segment, 
following settings are necessary. 

- Group setting for DPM  
Confirm the setting of the group by referring Section 3.3.1, "Add Machine Group" in Web 
Console Reference Guide. 

- Setting router/switch Management Server 
There is a possibility that the communication of power ON send from the Management Server 
might not be reached to the managed machine.  
See Section 2.2.1, "Network Environment" in First Step Guide and check the network setting. 

・ When Teaming for LAN port for the management machine, set the same value of MAC address 
registered to DPM Server for the physical LAN and MAC address of virtual LAN which has been 
performed. 
When MAC address of the virtual LAN and MAC address of the physical LAN are different,WOL 
might not be performed by DPM. 

・ There is a possibility that the managed machine might not WOL in some machines if you turn off 
the power when registering machine to DPM by network boot. 
In that case, turn on the power manually. 
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Confirm the specification of the hardware if the phenomenon is not improved despite performing 
above steps, because WOL by DPM depends on the specification of the hardware. 

 
 
 

Q7 
How to display again Automatic update status display on the task tray? 

 
A7 

See Section 3.3.1, "Client Setting Tool" in Tool Reference Guide. 
 
 

3.4. Scenario 
 

Q1 
You cannot assign a scenario to the managed machine. 

 
A1 

A scenario cannot be assigned to a machine in the following statuses: Scenario Executing, Scenario 
Execution Stop, Scenario Execution Error or Remote Power ON Error. Assign a scenario either after 
scenario execution completes, or clear the machine status. 

 
 
 
Q2 

You want to change the scenario file name. 
 

A2 
The scenario name cannot be changed. Please create a new scenario. 



 

34 

 

3.5. Execute Scenario 
3.5.1. General 
 

Q1 
You executed a scenario, however the managed machine Status is not Scenario Executing. 

 
A1 

When you click Refresh from Operation menu, or refresh the screen by pressing F5 key, the status 
changes to Scenario Executing. Until the machine icon displays Running, do not edit, delete or 
remove scenario assignment for any running scenario. 
The scenario may not execute properly. 

 
 
 

Q2 
You checked the Forced Execution Of A Reboot Is Performed Before Execution checkbox on the 
scenario Option tab, however the machine does not reboot. 

 
A2 

When installing service packs, hotfixes, and applications, the machine does not reboot before 
executing a scenario. 

 
 
 

Q3 
An error occurred while a scenario was running. 

 
A3 

Use the following methods to remove the error. 
Next, check the error contents in the Event Viewer, confirm that the machine is in the correct status on 
the Web Console, and then re-execute the scenario. 
Example 1) Error Removal Method 

(1) Click the machine in error status on the Machine List, and a machine detail screen 
appears. 

(2) Click Remove Error under Operation menu on the machine detail screen. 
Example 2) Error Removal Method 

(1) Click Monitor view - Scenario Execution List. 
(2) In the tree view, click Scenario Execution List. 
(3) In the Operation menu, click Batch Clear Status. 
(4) On the Status Clear screen, select Scenario Execution Error. 
(5) Click OK. 

 
 
 

Q4 
A Running Scenario does not complete. 

 
A4 

Confirm the following: 
・ Confirm that DPM Client is installed. 

If DPM Client is not installed, interrupt the scenario, install DPM Client, and re-execute the 
scenario. 

・ Confirm that the IP address of the Management Server set when DPM Client was installed on 
the managed machine is correct. 
If it is incorrect, either change the following registry, or reinstall DPM Client and set the correct IP 
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address. 
<Windows> 

Key: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\depagent\Parameters 

Key name: ServerIpAddress  
<Linux> 

Correct the following files in the /opt/dpmclient/agent/etc/ folder. 
File Name: server.inf  
Key name: dpmserverip= 

・ On completion of scenario, the setting is that DPM Client can communicate with the 
Management Server. 

・ When the scenarios is running, if you change the configuration of Management view -> DPM 
Server -> Detail Setting -> DHCP Server tab on the Web Console, PXE boot fails in the 
managed machine and the completion of the scenario cannot be detected. After stopping the 
scenario, re-execute the scenario after setting the items in DHCP Server tab matching the 
proper environment. 

 
 
 

Q5 
A scenario execution error occurred immediately after you executed a scenario. 

 
A5-1 

The location of installation or settings of DHCP might be wrong, or DHCP Server might not be able to 
lease IP address or the DHCP server might not operate properly. Check the current situation from the 
following: 
・ Select Management view -> DPM Server -> Detail Setting -> DHCP Server tab on the Web 

Console, and confirm that the settings are correct. 
・ Confirm that the lease IP address in the DHCP scope is not inactive. 
・ Confirm that the DHCP Server is approved by Active Directory when DHCP Server joins a 

domain, and The IP address can be leased. 
・ Confirm that the DHCP address pool has not run out. If the pool has run out, please secure a 

sufficient pool of addresses. 
・ If using a DHCP server except Windows, confirm that fixed addresses are configured. 

 
A5-2 

A remote update scenario may have been executed on a machine that exceeded the Distribution 
Condition Setting - Maximum Targets configured in the scenario. 
Reduce the number of machines to execute, or increase the value of Maximum Targets. 

 
A5-3 

HW configuration, OS installation, disk configuration check, or Backup/Restore scenario may have 
been executed for turned ON machine. 
When you turned OFF the machine and execute again or execute turned ON machine forcibly, check 
the checkbox of Forced Execution Of A Reboot Is Performed Before Execution on Option tab of 
scenario. 
 

A5-4 
The command (execute file path + execute file name + setup parameter) of executed package for a 
remote update scenario may exceed 259 characters. Correct so that the length is 259 character or 
less by Image Builder and PackageDescriber. 
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Q6 

An error occurred while running the scenario. 
In the Event Viewer, error log information is registered. 

 
A6 

Check the log information registered in the Event Viewer, and perform the processes for each item. 
A problem that still occurs after re-executing may cause incorrect behavior in related services. If a 
scenario is executing, wait until it completes and then perform the following operations from the 
Management Server. From Start menu, select Administrative Tools -> Services on the 
Management Server, and then restart the following services. (Start if the service is stopped.) 

DeploymentManager API Service 
DeploymentManager Backup/Restore Management 
DeploymentManager Get Client Information 
DeploymentManager PXE Management 
DeploymentManager PXE Mtftp (Restart is not needed when startup type is disabled.) 
DeploymentManager Remote Update Service 
DeploymentManager Schedule Management 
DeploymentManager Transfer Management 

 Log Information 1 
・ Error: Timeout error and stop run scenario. No response from target: 
Explanation 

The scenario execution timed out because there was no response from the machine within 
a given time. The machine may have stopped due to an awaiting input status, error display, 
or other reason. After checking the machine, scenario content, setup parameter files and 
other information, remove the error from the machine. Next, turn the machine power OFF 
and then re-execute the scenario. 

 Log Information 2 
・ Error cannot create thread (xxxxxxxxxxx) 
・ Error cannot allocate xxxxxxxxxxxxxxxx 
Explanation 

Failed to create the thread which processes machine requests and to allocate buffer 
memory. There is the possibility that there are insufficient resources due to factors such as 
the high load state of Management Server. 
After checking the Management Server status, remove the error from the machine. Next, 
turn the machine power OFF and then re-execute the scenario. 

 Log Information 3 
・ Error cannot read CLF 
・ Error cannot change CLF 
Explanation 

Failed to read/write managing machine information. 
Remove the error from the machine, and then turn the machine power OFF. 
After waiting a while, re-execute the scenario. 

 Log Information 4 
・ Error cannot get xxxxxx path 
・ Error cannot read xxxxxx 
・ Error cannot open xxxxxx 
Explanation 

Failed to obtain the path for, open, and read file xxxxxx. 
There may be insufficient resources or registry information may be damaged due to 
factors such as the high load state of Management Server. After checking the 
Management Server status, remove the error from the machine. Next, turn the machine 
power OFF and then re-execute the scenario. 

 Log Information 5 
・ Starting process of the computer failed MAC = XX-XX-XX-XX-XX-XX 
Explanation 

Failed to power on the machine remotely. 
The network cable is not connected, or remote power ON is not configured. 
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If the machine is forcibly shut down while the POST screen is displayed, remote power ON 
may not function the next time the machine boots up. 
Confirm HW settings and try again. 

 Log Information 6 
Starting process of the computer failed when execute scenario MAC = 
XX-XX-XX-XX-XX-XX 

Explanation 
Failed to power on the machine remotely. 
The network cable is not connected, or remote power ON is not configured.  
If the machine is forcibly shut down while the POST screen is displayed, remote power ON 
may not function the next time the machine boots up. 
Confirm HW settings and try again. 

 Log Information 7 
・ scenario start write shared memory MAC : error = XX-XX-XX-XX-XX-XX : 

XXX 
Explanation 

The service may have abnormally terminated. 
(1) From Start menu, select Administrative Tools -> Services on the Management 

Server, and then stop the following services: 
DeploymentManager API Service 
DeploymentManager Backup/Restore Management 
DeploymentManager Get Client Information 
DeploymentManager PXE Management 
DeploymentManager PXE Mtftp (Stop is not necessary when startup type is 
disabled.)  
DeploymentManager Remote Update Service 
DeploymentManager Schedule Management 
DeploymentManager Transfer Management 

(2) Start the services you stopped at Step (1). 
(3) Execute the scenario again. 

 Log Information 8 
・ scenario start write shared memory MAC : error = XX-XX-XX-XX-XX-XX :112 
Explanation: 

WOL has not been executed on the target machine for scenario execution or failed in PXE 
boot might be the cause. 
When executing scenario for the machine whose power is turned off, DPM monitors 
operation of PXE boot. 
When PXE boot is not executed and WOL is not executed and scenario execution error is 
occurred. 
Set WOL and network boot with BIOS setting for the target machine. 
See the manual attached to the hard ware for details of BIOS setting. 

 
 
 

Q7 
The managed machine does not turn on when the power is turned on or a scenario is executed. 

 
A7 

If the power is forced turned off during POST, the system may fail in Wake On LAN when restarted. 
Turn off the power after completion of POST or start the operating system and perform the shutdown 
process. 
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Q8 

The power was turned off during scenario execution by mistake. 
 

A8 
On the Web Console, click Operations in the title bar to switch to the Operations view. In the tree view, 
click Machines icon, and then select the group to which the machine which power was turned off is 
registered. Select the specified machine, and then select Scenario Execution Stop to interrupt the 
scenario. After the status returns to normal, execute the scenario again. 

 
 
 

Q9 
The managed machine is not booted through the network, and the executed scenario becomes time out 
error. 

 
A9-1 

The network boot priority in the BIOS settings may be lower than the hard disk boot priority. Make the 
network boot priority higher than the hard disk boot priority, and re-execute the scenario. 

 
A9-2 

There is a possibility that network device has MAC address different from the MAC address registered 
to Management Server might be set to execute PXE boot. 
Execute again after checking if the network device has MAC address registered to Management Server 
is set to execute PXE boot. 
For the confirmation and checking method of PXE boot, contact your sales or support representative. 

 
A9-3 

When you manage a machine of UEFI mode, and if you start Windows OS after scenario completion of 
disk duplication OS installation or after changing UEFI boot option, two or more "Windows Boot 
Manager" are displayed in UEFI boot option and the boot order of network boot may be changed. 
Set the boot order of the network boot higher than "Windows Boot Manager" and execute the scenario 
again. 

 
A9-4 

There is a possibility that DPM Client might not receive request form DPM Server. 
Confirm whether the port number DPM Client uses is not used for other application. 
When the port number is used for other application which DPM Client used, change one port number 
enable DPM Client to communicate.  
See Section 1.6, "Port Change Procedure on DPM" for the port number of DPM. 

 
 
 

Q10 
When you execute DPM Command Line, the specified command does not run. 
In addition, an error does not appear at the command prompt. 

 
A10 

You may be using DPM Command Line of the previous version (Command Line for DPM). If you are 
using DPM Command Line (Command Line for DPM) of the previous version, perform the upgrade 
installation, see Section 3.5, "Upgrading DPM Command Line" in Installation Guide. 

 
 
 

Q11 
When you executed a scenario to two or more managed machines simultaneously, a Remote Power On 
error occurred. 
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A11 
When executing a scenario to two or more managed machines simultaneously, the default timeout 
value of the Remote Power On, which is specified in the Management view -> DPM Server -> Detail 
Setting - Network tab, may cause a timeout error. 
As a guide, set the Remote Power On Timeout to the following value: 
(Remote Power On Interval) multiplied by (the number of scenario executing machines) plus 
(managed machine startup time). 

 
 
 

Q12 
When a scenario finishes or the running scenario is stopped, the following message appears on the 
managed machine and the machine cannot be turned off: 
ERROR: Failed to power down by calling APM BIOS. The system has halted. 

 
A12 

A machine that does not support Advanced Power Management (APM) may not be automatically 
turned off at shutdown. In this case, turn off the managed machine manually. 

 
 
 

Q13 
When you execute DPM Command Line, the following message appears, and you cannot execute the 
command: 
The system cannot execute the specified program. 

 
A13 

This message appears when runtime modules required for running DPM Command Line are not 
properly installed. 
Execute the following file to install the run-time modules: 
<Installation media>:\DPM\Setup\VCRTL\vcredist_x86_2013.exe 

 
 
 

Q14 
When you execute DPM Command Line, the following log is output to "System" in the [Event viewer]. 
Source: SideBySide  
Event ID:32 
Explanation: The dependent assembly Microsoft.VC120.CRT could not be detected. 
Error: The referenced assembly is not installed to the system. 

 
A14 

This message appears when runtime modules required for running DPM Command Line are not 
installed properly. 
Execute the following file to install the run-time modules: 
<Installation media>:\DPM\Setup\VCRTL\vcredist_x86_2013.exe 
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Q15 

Following DPM Service does not start. 
Message "Error 1067: The process terminated unexpectedly."has been displayed. 

DeploymentManager API Service 
DeploymentManager PXE Management 
DeploymentManager Backup/Restore Management 

 
A15 

When IP address for the Management Server has been changed without following regular procedure, 
this error is occurred. 
See Section 1.1, "Procedure to Change the IP Address of the Management Server" to change IP 
address after returning to previous IP address for the Management Server. 

 
 
 

Q16 
"Starting kswapd","NTFS driver v1.1.2.2[Flags:R/O]" is displayed when executing scenario. 

 
A16 

Invalid "USB legacy system" on the keyboard setting for BIOS can avoid this error. 
 
 
 

Q17 
"The arguments is invalid."is displayed when executing DPM Command Line. 

 
A17 

Error is occurred either blank or ">" is included in the argument. 
In this case, enclose relevant argument within double quotation marks. 

 
 
 

Q18 
Following errors are displayed when executing DPM Command Line, and does not operate properly. 

ERROR:xxxx 
ERROR CODE:7304 
ERROR MSG:xxxx 

 
A18 

Proxy server is set to the machine on which DPM Command Line executes. 
Following error might be displayed during DPM Command Line execution when access to DPM 
Server via proxy server is not necessary. 

 
------------------------------------------------------------------ 
ERROR: Failed to set the DPM Server. 
xxx cannot be operated. 
ERROR CODE:7304 
ERROR MSG:Session: DPM Server returned the ending code which is not successful. 
(HTTP Status is not 200) 
------------------------------------------------------------------ 
*xxx varies depending on the execution details. 
 
HTTP is used for communication between DPM Command Line and DPM Server. 
HTTP error occurs because access is performed via proxy server for the local server(internal network 
server). 
Set bypass for the proxy setting of WinHTTP. 
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Set bypass setting on WinHTTP proxy setting. 
・ Windows Server 2008 or later 

Start command prompt and execute following command. 
 

- For x64OS: 
%SystemRoot%\SysWOW64\netsh winhttp set proxy proxy-server="proxy server address" 
bypass-list="DPM Server address" 

- For x86OS: 
netsh winhttp set proxy proxy-server="address of the proxy server "bypass-list="address of 
DPM Server" 

 
Example are below. 
Command 

\Windows\SysWOW64\netsh winhttp set proxy proxy-server="testproxy.co.jp:8080" 
bypass-list="192.168.1.1" 

Execution result 
Current WinHTTP proxy setting.  
Proxy server: testproxy.co.jp:8080 
Bypass list: 192.168.1.1 

 
・ Windows Server 2003 or earlier 

Start command prompt and execute followings. 
 

proxycfg-p proxy server address DPM Server address 
 

Example are below 
Command 

proxycfg -p testproxy.co.jp:8080 192.168.1.1 
Updated WinHTTP proxy setting 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\InternetSetting
s\Connections\WinHttpSettings : 
Proxy server: testproxy.nec.co.jp:8080 
Bypass list: 192.168.1.1 

 
 
 
Q19 

Following messages are displayed on the event log and cannot start DPM. 
・ "The DeploymentManager API Service terminated unexpectedly." has been displayed and 

DeploymentManager API Service ends soon after starting. 
・ "Cannot create a file when that file already exists." is displayed and cannot start 

DeploymentManager Schedule Management. 
 

A19 
The DPM service accesses to SQL Server (DPMDBI) or postgresql-x64-9.5 - PostgreSQL Server 9.5 
when starting. 
When SQL Server (DPMDBI) or postgresql-x64-9.5 - PostgreSQL Server 9.5 service is stopped or 
cannot access to the database from any cause, the DPM service fails in starting. 
Restart SQL Server (DPMDBI) or postgresql-x64-9.5 - PostgreSQL Server 9.5 service and start the 
DPM service again. 

 
 
 

Q20 
"Unknown" is displayed on the "Disk Information (Disk Viewer)" screen on the Web Console. 

 
A20 

There is a possibility that the file system and the disk type which are not corresponded to DPM might 
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be included in the disk of the managed machine. 
Confirm whether the state of the disk of the managed machine is formatted with the file system or 
the disk type which DPM is corresponded. 
See Appendix A, "Function Tables" in First Step Guide for details of the file system and disk format 
corresponded to DPM. 

 
 
 

Q21 
Error is displayed when "Disk Information (Disk Viewer)" on the Web Console is displayed and disk 
configuration is not displayed. 

 
A21 

There is a possibility that disk information is damaged or does not exist. 
Execute disk configuration check scenario again. 
Followings might be the cause. 
・ Disk configuration check scenario has never been succeeded. 
・ Disk configuration check scenario has not been succeeded after changing FC-LUN 

configuration for the managed machine. 
・ Disk information obtained by executing disk configuration check scenario is damaged. 

 
 

3.5.2. Creating a Linux Install Parameter File 
 

Q1 
When you select Open under File menu from the installation parameter setting tools and when reading 
the existing Linux installation parameter file, the following message appears: 

 
A candidate host file cannot be read. 

 
A1-1 

About the selected Linux installation parameter file, OS may not be supported. For details, see 
Section 3.9.1, "System Requirements" or Appendix A, "Function Tables" in First Step Guide. 

 
A1-2 

The Linux installation parameter file may be damaged. 
Check the contents of the Linux setup parameter file and Linux boot parameter file. 

 
 
 

Q2 
When you select Open under File menu from the installation parameter setting tools and when reading 
the existing Linux installation parameter file, the following message appears: 

 
The Linux OS installation parameter file cannot be read. 

 
A2-1 

About the selected Linux installation parameter file, OS may not be supported. See Section 3.9.1, 
"System Requirements" or Appendix A, "Function Tables" in First Step Guide for details. 
 

A2-2 
The Linux installation parameter file may be damaged. 
Check the contents of the Linux setup parameter file and Linux boot parameter file. 
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[SYSPREP] 
Timeout=300000 
 

[SYSPREP] 
Timeout=60000 
 

 

3.5.3. OS Installation by Disk Duplication 
 

Q1 
While you set up the OS by OS installation by disk duplication, the following message appeared on the 
machine screen and processing stopped. 
"The parameter file for this system is not prepared, or failed to be copied. Follow 
the wizard to setup displayed after reboot. Press any key to reboot." 

 
A1 

The number of machines trying to access the Management Server may exceed the maximum number 
of machines concurrently accessible. Reduce the number of machines concurrently accessing the 
Management Server concurrently. 

 
 
 

Q2 
During the Windows OS setup by OS installation by disk duplication, the process stopped under the 
condition of being logged onto the machine. 
Furthermore, machine names and so on that were specified by parameters are not set correctly. 

 
A2 

It may have failed to reflect the specific information because it took time to initialize the setting of 
Windows OS. 
Open <Folder for Image>\Sysprep\Windows\DepConfig.ini by Text Editor and so on, and change the 
following Timeout value (milliseconds). (Use numeric characters.) DepConfig.ini can be edited after 
Copy-ExpressSysprep.vbs script is executed on the master machine when the master image is 
created. 

 
 
 

Example) 
 
 
 
 
 
 
 
Q3 

Following message is displayed and processing has been stopped during OS set up by disk duplication 
installation. 
linftc: ERROR: ioctl - SIOCGIFADDR<iLocalSocket>(99 - Cannot assign requested address). 

 
A3 

Disk duplication module could not obtain the IP address to communicate with the Management 
Server. 
Confirm whether LAN board of the managed machine is ready to communicate or not. 
Confirm whether the IP address is assigned to the LAN board to communicate with the managed 
server when LAN board of the managed machine is in the state of communication. 

 
 
 

Q4 
During the OS setup by OS installation by disk duplication of Windows Server 2008/Windows Vista or later, 
either of the following messages appeared and the process stopped. 

- "Windows could not parse or process the unattended answer file for pass 
[specialize]. The settings specified in the answer file cannot be applied. The 
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error was detected while processing settings for component 
[Microsoft-Windows-Shell-Setup]." 

- "The computer restarted unexpectedly or encountered an unexpected error. Windows 
installation cannot proceed. To install Windows, click "OK" to restart the 
computer and then restart the installation." 

 
A4 

The OS type in the disk duplication data file for the duplication destination machine may differ from 
the OS type of the master machine. Also, Product Key may not be specified in the disk duplication 
data file correctly. 
Change the OS type in the disk duplication data file so that it matches that of the master machine and 
specify Product Key correctly. Then, distribute the disk image again. 

 
 
 

Q5 
While you setup the OS by OS installation by disk duplication, the following message appeared on the 
machine screen and processing stopped. 
"The system registry contains invalid file paths. Installation cannot proceed. 
This system image was applied without guaranteeing that drive-letter assignments 
would match across computers." 

 
A5 

This error may be displayed if the system configuration of the master image is multiboot. 
Confirm that the master image is not a system configuration of multiboot.  
OS installation by disk duplication in the multiboot environment cannot be executed. (Be sure to 
construct the master image from the master machine which is configured as a single system.) 

 
 
 

Q6 
After you set up the OS by OS installation by disk duplication, the characters of the connection name 
registered in Network and Dial-up Connections were garbled. 
 
A6 

If this occurs, change the connection name manually. 
 
 
 

Q7 
When you execute Sysprep command on the master machine in setting up OS by OS installation by disk 
duplication, Windows Security Alert dialog appears and the message that "Do you want to keep 
blocking this program? Name: Microsoft Remote Desktop Help Session Manager" is displayed. 

 
A7 

For Windows Server 2003 R2, this may be displayed. The processing continues automatically after a 
while and there is no problem. Wait for a while. 

 
 
 

Q8 
The screen requires IMJPZP.DI_file or others is displayed while disk duplication OS installation. 

 
A8 

When IMJPZP.DI_ is required, copy IMJPZP.DI_ file from the following to \SYSPREP\I386\LANG 
folder of the master machine (for OS of Windows Server 2003 R2/ Windows XP or earlier: 
\SYSPREP\I386\LANG\JPN) which has been created in the procedure of "Executing the tool in the 
installation media manually" in 3.3.1.3, "Preparing for Creating the Master Image" in Operation Guide. 
Create LANG folder when there is no LANG folder under I386. 
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- For Windows Server 2003 R2(x64):(CD-ROM)drive:\AMD64\LANG\IMJPZP.DI_ 
- For Windows XP/Windows Server 2003/Windows Server 2003 R2 (x86): 

(CD-ROM)drive:\I386\LANG\IMJPZP.DI_ 
After copying above file,refer to "Executing the tool in the installation media manually" in 3.3.1.3, 
"Preparing for Creating the Master Image" in Operation Guide and execute disk duplication OS 
installation again. 
When the other file is required, add the file to the master machine by the same procedure and 
execute disk duplication OS installation again. 

 
 
 
Q9 

After OS installation by disk duplication, messages such as the following appear at Linux OS startup. Or, 
X-Window does not start. 
"Could not look up internet address for "Hostname"(*) This prevents GNOME from 
operating correctly. It may be possible to correct the problem by adding 
"hostname"* to the file /etc/hosts." 
* "Hostname" is the host name of each machine after OS installation by disk duplication. 

 
A9 

An error may occur at X-Windows startup because a host name is not registered to the file /etc/hosts. 
Register the hostname in the /etc/hosts file. If the environment uses a static IP address, register the 
line as the following. 
Example) 192.168.0.1 servername 
If the computer obtains an IP address from DHCP, register the hostname with a loopback address as 
follows: 
Example) 127.0.0.1 localdomain.localhost localhost servername 

 
 
 
Q10 

IP address conflict occurred after OS installation by disk duplication. 
 

A10 
If an alias interface is configured in the master machine, IP address conflict occurs after OS 
installation by disk duplication. Use the following procedure to delete the alias interface configuration 
file, and then restart the machine. 

 
# cd /etc/sysconfig/network-scripts 
# rm -f ifcfg-eth*:* 
# rm -f ifcfg-bond*:* 

 
 
 

Q11 
When you execute backup of OS installation by disk duplication of a Linux-installed VMware ESXi virtual 
machine as a master machine, the following error appears and the machine has been shut down during 
OS start-up after completion of backup and restarting. 
"Determining IP information for ethX ...failed; no link present. Check cable?" 

 
A11 

Configuration described in "Executing the tool in the installation media manually" of Section 3.4.1.3, 
"Preparing for Creating the Master Image" in Operation Guide may not have been done correctly in 
the preparation for OS installation by disk duplication on the master machine. 
Confirm the procedure and configuration, and then execute OS installation by disk duplication again. 
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Q12 

When you execute OS installation by disk duplication for a VMware ESXi virtual machine, the following 
error appears and network adaptor has not been recognized during OS start-up after restarting the 
machine by reflecting the specific information and restarted. 
"Determining IP information for ethX ...failed; no link present. Check cable?" 

 
A12 

When the disk duplication data file was created, the script data listed in Section 1.4.3, "Creating a 
Disk Duplication Data File (Linux)" in Tool Reference Guide. may not have been properly configured. 
Confirm the procedure and configuration, and then execute OS installation by disk duplication again. 

 
 
 

Q13 
Though execution of scenarios for setting up of a master machine. 
(System_LinuxMasterSetup/System_WindowsMasterSetup/System_WindowsMasterSetupVM) 
succeeded OS installation by disk duplication fails. 

 
A13 

DPM Client earlier than DPM Ver6.12 may be used. After upgrading DPM Client, execute OS 
installation by disk duplication again. 

 
 
 

Q14 
When I make mistake the turn of procedure to create the master image of disk duplication installation, is 
it possible to make another try from the wrong step? 

 
A14 

Follow the step of the Operation Guide from the beginning again after restoration of the backup image 
of the master you created before. 
If you retry from the wrong step, there is a possibility that the master image of the disk duplication 
installation might not be created properly. 

 
 
 

Q15 
Parameter file does not exist on disk duplication installation. 

 
A15 

There is a possibility that connection to the Management Server might be failed because the 
managed machine obtains the disk duplication data file from the Management Server. In that case, 
there is a possibility that the domain which belongs to the Management Server might not allow the 
user authorization for "Access to the computer via network" 
->This user authority to connect with the managed server is necessary. 

 
 
 

Q16 
There are some items setup parameter is not applied after disk duplication installation. 

 
A16 

There is a possibility that some items are not reflected when installing disk duplication. 
In that case, set manually after completion of the disk duplication. 
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Q17 

During disk duplication installation, stops at the login screen. (Password error has been occurred). 
 

A17 
Password has been set when you prepare for disk duplication installation on the master machine. Set 
as "no password" of the master machine and execute backup again. 
Execute disk duplication OS installation again by using the backup image you set as above. 
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3.5.4. OS Clear Installation 
 

Q1 
After Distribution of floppy disk image for BIOS/firmware and an OS clear installation scenario was 
executed, a scenario execution error occurs before you reboot the machine. 

 
A1 

Is there a check-in on the Forced Execution Of A Reboot Is Performed Before Execution checkbox 
on the scenario Options tab? If not, a scenario will not be executed for any machine that has been 
turned ON. Modify the scenario or turn the machine OFF and execute the scenario again. 

 
 
 

Q2 
Scenario execution has stopped and the following message appears on the screen of machine while 
execution of OS clear installation scenario. 
"Cannot connect data server. Please stop running scenario on management server 
and press any key to reboot" 
 
A2 

The maximum number of machines that accessing the Management Server simultaneously may have 
been exceeded. Reduce the number of machines which accesses Management Server simultaneously 
and execute again. 

 
 
 

Q3 
The OS installation has stopped due to an error. 

 
A3 

OS installation will stop with error if you specify unusable character in the machine name. For a list of 
unusable characters, see the manual of OS and others you are using. 

 
 
 

Q4 
During Linux installation, the following message appears, and the installation unable to be completed. 
Could not allocate requested partitions; Partitioning failed: 
Could not allocate partitions as primary partitions 
 
A4 

The partition settings may be wrong. (For example, if the number of primary partitions on one basic disk 
exceeds the upper limit (4))  
While creating the Linux installation parameter file, select Disk Information Settings - Partition 
Settings - Delete All Existing Partitions and execute the Linux installation again. 
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Q5 
During Linux installation, the following message appears, and the installation unable to be completed. 
+------------ Kickstart Error ------------+ 

Error opening: kickstart file 
/tmp/ks.cfg: No such file or 
directory 

[OK] 
+-----------------------------------------+ 

 
A5-1 

Confirm if NFS shared folder is configured correctly. 
See Appendix C, "Configuring NFS Server" in Installation Guide to configure the folder correctly, and 
then install Linux. 

 
A5-2 

If you uninstall DPM Server with the exports folder as an NFS shared folder as previously mentioned in 
Setting Up the NFS Service, and then reinstall DPM Server, the NFS shared property is configured in 
Explorer, however the above error may occur when you actually perform the installation. In this 
situation, release and then reconfigure the NFS shared property again. 

 
A5-3 

Confirm that the install device you are using is configured to Installation Device of Linux installation 
parameters. 
See Section 1.4.5, "Creating a Parameter File for OS Clear Installation (Linux)" in Tool Reference 
Guide to configure Installation Device correctly, and then install Linux again. 

 
 
 

Q6 
Network device exist as unknown device after OS installation. 

 
A6 

Register appropriate device driver on DPM and specify as scenario to install device driver. 
For details, contact your sales or support representative. 

 
 

3.5.5. Installing Service Packs / HotFixes / Linux Patch Files / 
Application 

Q1 
Perform the following operations if scenario execution errors continue to occur in remote update. 

 
A1 

Restart the Management Server. (If the Management Server cannot be rebooted, stop all services 
described in Appendix A, "Service List" by selecting Management Tools -> Services from Start menu, 
and then start all of the services you stopped.) 

 
 
 

Q2 
When you executed the scenario of installing service packs, hotfixes, Linux patch files, and applications, 
however the machine in the Status column of the Monitor view -> Scenario Execution List remains in 
Scenario Executing, and the scenario execution does not complete. 
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A2 

If the setup parameter is not configured correctly, a confirmation dialog box appears on the machine 
and the scenario execution does not complete. You can check the setup parameter by running the 
service pack or the hotfix with the option /h or -? , or see the web site of the distributor and others. Make 
sure to specify the setup parameter to execute silent installation and not to restart after installation. 
 
 
 

Q3 
Failed to create an image file during the registration of Installing service packs, hotfixes, Linux patch files, 
and applications by Image Builder. 

 
A3 

In installing service packs, hotfixes, Linux patch files, and applications, image file is saved in ZIP file. If 
these ZIP files size exceed 2GByte, creation of the image file fails. 

 
 
 

Q4 
When you modified a package by Image Builder, the message "Failed to compress the file." or 
"Failed to register in the Management Server." is displayed and package modification fails. 

 
A4 

If the modification date is earlier than the package creation date, package modification fails. There may 
be some reasons, such as, the date-time of the machine was changed after creating the package, or 
that date-time of the Management Server is different from one of Image Builder (Remote Console) 
machine. After the date that the package was created, modify the package, or delete the package and 
create the package again. 

 
The packages are stored in the either Folder for Image\HotFix folder or Image \PP for the Management 
Server. 
(The default of the Folder for Image is  
C:\Deploy, and the package file name is "ServerID"-"PackageID".zip.) 

 
 
 

Q5 
Even if applying a service pack/hotfix/Linux patch file fails, the Web Console displays that scenario 
execution completed successfully. 

 
A5 

When the execution of a service pack or hotfix fails, the failure may not be detected. In such case, fix 
the cause of the execution failure, and then execute the scenario again. 

 
 
 
Q6 

A scenario execution error occurs if you execute a scenario Distribution of floppy disk image for 
BIOS/firmware or apply Installing service packs, hotfixes, Linux patch files, and applications install. 

 
A6 

Confirm that the execution interruption processing is completed properly. If interruption is cancelled 
before execution and then the scenario is executed, the scenario execution error may occur. 
Furthermore, if you execute the same scenario simultaneously on two or more machines, set the 
maximum target number of multicast distribution conditions to the number of machines you want to 
interruption process is completed, and then execute the scenario. 
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Q7 

A scenario execution error occurs if you try to execute two or more service pack/hotfix/Linux patch 
file/application install scenarios at the same time. 

 
A7 

See the Scenario Details screen and check whether the same multicast IP address is specified. If the 
same multicast IP address is not being used, reduce the maximum transfer rate, or execute the 
scenarios one by one. (If the scenario is the same, you may also execute the scenario on two or more 
machines.) 

 
 
 

Q8 
A scenario of installation service packs, hotfixes, Linux patch files, and applications does not start. 

 
A8 

If the maximum target is not configured, or is greater than the machine attempting to execute, the 
scenario executes after the maximum wait time passes. (The default setting of the maximum wait time 
is 10 minutes.) 

 
 
 

Q9 
The maximum transmission rate has been set higher, however the scenario execution time does not 
decrease. 

 
A9 

Maximum transmission rate varies depending on the network environment of the customers. 
Transmission rate cannot be higher than the perfomance of the network environment. 

 
 
 

Q10 
When you register an application or service pack/hotfix by Image Builder (Remote Console), the error 
Failed to register to Management Server is displayed. 

 
A10 

This error may occur when the size of the file to register is extremely large. 
To prevent this error, edit the timeout value (number of seconds) that is specified by the following 
registry: 

Hive : HKEY_LOCAL_MACHINE 
KEY : SOFTWARE\Wow6432Node\NEC\DeploymentManager 
NAME : DIBReqTimeOut 
Type : REG_DWORD 
Value : 120 
-> The default is 120 seconds. Set the timeout value. 

Even if an error is displayed, registration is succeeded. Re-registration is unnecessary. 
When you exit Image Builder, perform the following operations: 

(1) Select Yes (Register) at batch registration. 
(2) Select No (Delete) at the confirmation of overwriting. 
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Q11 

When you register a service pack/hotfix/Linux patch file by Image Builder (Remote Console), the data 
creation has succeeded. However, the registration to the Management Server fails. 

 
A11 

This may occur if the path for the setup command name is extremely long. 
If registering to the Management Server from the Remote Console, the upload process checks the full 
path, including the Folder for Image path on the Management Server side as the maximum path length. 
If the full path exceeds upper limit, registration is not be completed properly. Register shorter full path 
by moving files to be registered to location close to the drive root on the Remote Console, and register 
the files again. 

 
 
 
Q12 

When you interrupt the execution of the scenario of installing service packs, hotfixes, Linux patch files, 
and applications, and then cancel the interruption and execute the scenario again, a scenario execution 
error occurs. 

 
A12 

If the interruption occurs when communications with the managed machine is disrupted for some 
reason, the interruption process cannot be completed, and the machine remains in an interrupt status. 
In this status, even if a scenario is executed after the interruption is cancelled, a scenario execution 
error occurs. 
In this case, wait for a while (approximately 10 minutes) and before executing the scenario again. 
If scenario execution errors continues, perform the following operations. 

 
On the managed machine, select Management Tools ->Services from Start menu, and restart 
DeploymentManager Remote Update Service Client. (Start if the service is stopped.) 

 
 
 
Q13 

After executing DPM Client automatic upgrade scenario for a Linux managed machine, and then execute 
another remote update scenario, which does not start. 

 
A13 

When another remote update is executed within two minutes of executing DPM Client automatic 
upgrade scenario and DPM Client service does not start properly. Restart DPM Client service or 
restart the OS. To restart DPM Client service, start the Console and execute the following:  
- For Red Hat Enterprise Linux 7 or later. 

>systemctl stop depagt.service 
>systemctl start depagt.service 

- For Red Hat Enterprise Linux 6 or earlier/SUSE Linux Enterprise 
>service depagt stop 
>service depagt start 
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Q14 

If remote update is executed for a Linux managed machine, a scenario execution error occurs. 
 

A14 
When installing service packs, hotfixes, Linux patch files, and applications in Image Builder, an option 
that outputs to the console may be specified to Setup Parameters on the Execution Configuration 
screen. The option may be specified. 
See Section 1.5.3, "Create Linux Package" in Tool Reference Guide and confirm that relevant options 
are not specified. 
If the relevant options are specified, delete scenarios including that packages, correct the packages 
from which relevant options were removed. Recreate the scenario file with the corrected packages, 
and then execute the scenario again. 

 
 
 

Q15 
If a remote update is executed by multicast for the x64 Linux managed machine, a scenario execution 
error occurs. 

 
A15 

The necessary libraries may not be installed. Confirm that /lib/libgcc_s.so.1 exists. 
If /lib/libgcc_s.so.1 does not exist, install the following rpm package: 
libgcc-3.4.5-2.i386.rpm 
After the installation, restart DPM Client service or restart the OS. 
To start DPM Client service, start the Console and execute the following: 

- For Red Hat Enterprise Linux 7 or later 
>systemctl start depagt.service 

- For Red Hat Enterprise Linux 6 or earlier/SUSE Linux Enterprise  
>service depagt start 

 
 
 

Q16 
When remote update scenario is distributed by multicast, scenario execution error is occurred on some 
of the managed machines. 

 
A16 

If all of the following is applied and remote update scenario is distributed by multicast, scenario 
execution error occurs. 
If managed machines are connected to two or more LAN boards on the Management Server, create 
and execute different scenarios for each LAN board. 
- ANY is selected on the Web Console screen under Management View -> DPM Server icon -> Detail 

Setting screen -> General tab -> IP Address. 
- The managed machines are connecting with two or more LAN boards on the Management Server. 

 
 
 

Q17 
Fail in the automatic installation for Service pack/HotFix. 

 
A17 

Specify "/passive /norestart" to the command option when registering Windows Server 2003 Service 
Pack 1/2. 
Specify as is the case with HotFix by checking the command option. 
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Q18 
Fail in Linux patch application. 

 
A18 

The followings might be the cause. 
1. Dependency for other rpm packages. 

->Distribute package which has dependencies and deliver the patch. 
2. Same patch has been already applied. 
3. The rpm package has not been signed. 

->Set the appropriate command option. 
See Section 1.5.3, "Create Linux Package" in Tool Reference Guide for details. 
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3.5.6. Backup/Restore/Disk Configuration Check 
 

Q1 
Partition number displayed on the machine is different from the partition number specified when creating 
scenario. 

 
A1 

A hidden partition may exist in the target hard disk. The hidden partition will not be included in the total 
count if the checkbox was checked for Hidden Partition Is Disregarded in partition specification 
Backup/Restore. Clear the checkbox, or enter the corresponding partition number correctly. 

 
 
 

Q2 
Only several tens of MBs are transferred per minute during Backup/Restore operations. 

 
A2 

The maximum transmission rate may be specified too low, such as 1-10MByte/minute. Confirm the 
Maximum transmission Rate column on the Multicast Condition Setting panel in Backup/Restore tab on 
the Scenario Edit screen. If you save time, clear the checkbox. To reduce network workload, check the 
checkbox and specify the appropriate values. 
Data may not be transferred smoothly due to a high network workload. Minimize use of the network as 
much as possible during the scenario execution. 

 
 
 

Q3 
Scenario execution error has been occurred suddenly while backup data transfer. 

 
A3 

Data transmission may not be possible due to sufficient free space on the Management Server. Make 
sure there is insufficient free space on Management Server where the backup data is to be saved. 
Backup will not operate properly if there is not enough free space. Reconsider the backup file 
destination, or reserve sufficient free space. 

 
 
 

Q4 
Restoration with specified backup image file has been executed, however, unintended OS has started. 

 
A4 

The image files that you backed up may have been overwritten with the backup image of another 
machine. When executing backup, make sure that you do not use a redundant image file name. 
Otherwise, the previous data will be overwritten. 
Furthermore, if the same scenario is assigned to two or more machines and execute backup 
simultaneously, check whether machine name, MAC address, or UUID under the textbox on the 
scenario file Backup/Restore tab is selected. 

 
 
 

Q5 
Even if restore is executed simultaneously, several of the managed machines do not execute scenarios, 
and Waiting for Restore Execution is displayed on the Backup/Restore Execution List screen. 

 
A5 

The Maximum Targets set for the scenario file may be less than the actual machine number you are 
trying to execute. In this case, after completing the execution of preceding scenario, and then the 
scenarios for the rest machines start. 
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Q6 

The restore operation has been in waiting for restore execution status and does not start. 
 

A6 
The setting of the Maximum Waiting Time under the Distribution Condition Setting group box on 
the Backup/Restore tab for the scenario file can not to be configured. If the column is blank, the 
scenario will not execute until the number of machines ready to execute scenarios reaches the 
Maximum Target value. Click Run Now on the Backup/Restore Execute List screen, or interrupt the 
execution and specify an appropriate value for Maximum Wait Time of the scenario file. 

 
 
 

Q7 
Even if you the maximum target number as 10 in the restore scenario, and then execute the scenario on 
10 machines simultaneously, the scenario executes on only 5 machines at once. 

 
A7 

If the Management view -> DPM Server -> Detail Setting -> Network tab ->Machines For 
Simultaneous Execution value is 5, the scenario executes on only 5 machines at once, although the 
maximum target value is specified as 10. If you want to execute on 10 machines simultaneously, 
change the value of Machines For Simultaneous Execution under Detail Setting to 10. 

 
 

 
Q8 

Although maximum transmission rate has been set higher, the scenario execution time is not shortened. 
 

A8 
Maximum transmission rate depends on network environment of each customer. 
Transmission rate cannot be higher than the performance of the network environment. 

 
 
 

Q9 
Even through the execution of a backup scenario, a unicast restore scenario, or disk configuration check 
scenario completed, the status of Scenario Execution List status remains Preparing. 

 
A9 

If you executed a backup scenario, a unicast restore scenario, or disk configuration check scenario on 
another machine before the same scenario execution has completed, the status of Scenario 
Execution List on the Web Console may display Preparing from the time the backup, restore, disk 
configuration check completes to the time that the execution of the scenario completes. However, it 
does not affect the operation. 

 
 
 

Q10 
When checking scenario execution status on Backup/Restore Execution List while a multicast restore 
scenario is executing, the scenario status is displayed as already complete although execution was still 
in progress, or it may not be displayed. 

 
A10 

Backup/Restore Execution List cannot be updated immediately, after executing scenarios. The 
status is updated at the timing of start of reading or writing to the Backup/Restore disk. 
Until then, the status before execution is displayed. 
When displaying the screen before update, open the screen again after a while or click Refresh. 
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Q11 
During backup, a scenario execution error occurs, however no error message is displayed. 

 
A11 

If the OS did not shut down properly when the machine was power off, the delayed write to disk 
process may not have been completed during shutdown, and the file system may be damaged. 
Furthermore, if the machine was power off and shutdown was not performed while the disk was 
accessing, physical damage on the disk may have occurred. 
If backup was executed on such a disk, a scenario execution error may occur. 
In such case, reinstall the OS, or use a file system fix tool, and so on to fix the file system, and then 
execute backup again. 
Furthermore, if there is a physical damage on the disk (bad sector), you cannot backup/restore using 
a fix tool and so on. If there are bad sectors, change a new HDD and recover it by physically 
formatting and then execute a restore from a previous backup image. 

 
 
 

Q12 
When two or more restore scenarios are executed simultaneously, a scenario starts on the first machine 
booted up, however after getting Backup System image is displayed on the other machines, a scenario 
execution error has occurred, and the error is displayed on the Scenario Execution List screen. On the 
machine screen, the following error message was displayed: 
"ERROR: Received the error from the PXE server. 
Please contact your system administrator or support group." 

 
A12 

The same multicast IP address is specified when the scenario was created may be specified in all 
scenario files. Open the Edit Scenario screen, and check the value of multicast IP address on the 
Distribution Condition Setting group box in the Backup/Restore tab. If the specified IP address is 
the same to another restore scenario, one of two scenarios may not start properly. Enter a 
non-redundant IP address again on the Modify Scenario screen. If Remove Scenario Execute 
Error is selected for the machine on which an error was occurred, error display disappears, and the 
scenario can be executed again. 

 
 
 

Q13 
When you execute a restore scenario by specifying a partition, either of the following error messages is 
displayed and the scenario execution error occurs. 
Cannot restore the data to a partition of a different size than the size you backed 
up. 
Specify a partition with the following size. 
(required size of a partition to restore) 
(size of the specified partition) 
(XXXXX bytes) 
(XXXXX bytes) 
 
Cannot restore the data to a partition of a different type than the type 
you backed up.  
Specify a partition with the type same as you backed up. 
(ID of the backed-up partition) 
(ID of the specified partition) 
(0xXX) 
(0xXX) 

 
A13-1 

Confirm the partition size and the type of file system are matched between the original disk and the 
destination disk. Open the Edit Scenario screen, set the applicable partition, and then execute the 
scenario again. 
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A13-2 
You may have specified a partition which is different from one that you backed up. Restore the image 
file to the same partition when it was backed up. Open the Edit Scenario screen, set the applicable 
partition and then execute the scenario again. 

 
A13-3 

When the Hidden Partition Is Disregarded checkbox was selected and hidden partitions exist on the 
managed machine, you may specify a partition that is different from when backup. In this case, clear 
the Hidden Partition Is Disregarded checkbox, and then execute the scenario again. 

 
 
 
Q14 

Without ending processing, while executing a backup/restore scenario, and the following messages are 
displayed on the managed machine: 
FS: Cannot open root device "" or xx:xx 
Please append a correct "root=" boot option 
Kernel panic: VFS: Unable to mount root fs on xx:xx 

 
A14 

There may be a problem in the LAN connection between the Management Server and the managed 
machine, or the workload on the Management Server may be high. Check the LAN connection and 
the Management Server workload, and then turn off the machine and execute the scenario again. 

 
 
 
Q15 

While executing a restore scenario, the following message is displayed on the managed machine, and a 
scenario execution error occurs. 
The size of the backup data to be restored is larger than that of the destination 
storage device. It cannot be restored. Specify a destination device whose size 
is larger than or equal to the following size. 
(minimum required size of a destination device) 
(the specified device: its size) 
(XXXXX bytes) 
(DeviceName: XXXXX bytes). 

 
A15 

Check HDD size of the backup source and the restore destination. 
When the HDD size of the restore destination is smaller, above message may be displayed. 
Use HDD with the same or larger size than the backup source. 

 
 
 

Q16 
When you execute a backup scenario, the following message is displayed on the managed machine and 
the scenario execution error occurs. 
Failed to backup. 
There is something wrong with the management information of the GPT disk. 
Check and repair the disk by CHKDSK or other tools,  
and re-execute the scenario. 

 
A16 

There is an error on the GPT disk management information for the backup source.  
Re-execute the scenario after checking/restoring the disk on OS. 
If you cannot check/restore or the problem cannot be resolved by checking/restoring, specify 
full-sector on the scenario and re-execute backup scenario. 
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Q17 

When you execute a restore scenario, the following message is displayed on the managed machine and 
the scenario execution error occurs. 
Failed to restore. 
The data is not written to the destination storage device. 
Invalid data in the backup image. 
For this error, contact your sales or support representative. 

 
A17 

When original Hyper-V virtual disk is GPT style, above message may be displayed if you restore the 
backup image file created in the version earlier than DPM Ver6.2. 
You cannot restore it because the backup image file includes invalid data. 
In this case, recreate a backup image file by selecting Full Sector Option on Backup/Restore tab 
when creating a scenario, and executing the backup scenario. 

 
 
 

Q18 
When the following error occurs and a process ends with error for some reason, you cannot execute a 
shutdown or re-boot even if you press p or r (Key input cannot be recognized). 
ERROR: <error message> 
Press the p key to power off, and the r key to reboot:  
 
A18 

Key input may not function on certain kinds of machines using a USB keyboard/mouse which cannot 
be recognized. 
Press (and hold down) the power button to turn off the power. 

 
 
 

Q19 
When you interrupted the execution of a restore scenario, the following message is displayed on the 
managed machine: 
Failed to read or write the data in the managed machine. 
For this error, contact your sales or support representative. 

 
A19-1 

This message is displayed when a scenario execution is interrupted. This message displays because 
the data of the intended size could not be obtained due to disconnected communication between 
Management Server and the managed machine. 
This is not problematic to the scenario execution interruption process. 

 
A19-2 

While executing a restore scenario, the restore data cannot be read. 
Confirm that the backup image is not damaged and there is no trouble on the network. 

 
 
 

Q20 
Following message is displayed when executing backup and becomes scenario execution error. 
Failed to backup. 
The basic disks with non-512-byte sector is not supported. 
(sector size of the specified device) 
----- 
(xxxxx) 

 
A20 

There is a possibility that above message might be output when you backup from the hard disk also, it 
is the basic MBR disk of 4K sector. 
Execute full sector backup. 
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Execute scenario again by checking "Full Sector" checkbox on "Backup/Restore" tab in the screen of 
"Scenario Editing". 

 
 
 

Q21 
Following message is displayed when executing backup and becomes scenario execution error. 
Failed to backup. 
The dynamic disks with non-512-byte sector is not supported. 
(sector size of the specified device)  
----- 
(xxxxx) 

 
A21 

There is a possibility that above message might be output when you backup from the hard disk also, it 
is the dynamic disk of 4k sector. 
Execute Full Sector backup. 
Execute scenario again by checking "Full Sector" checkbox on "Backup/Restore" tab in the screen of 
"Scnenario Editing". 

 
 
 
Q22 

Following message is displayed when restoring and becomes scenario execution error. 
Failed to restore. 
The data is not written to the destination storage device. 
The dynamic disks with non-512-byte sector is not supported. 
(sector size of the specified device) 
----- 
(xxxxx) 

 
A22 

When you restore by assigning partition, there is a possibility that above message might be displayed 
in case the desitination hard disk is a dynamic disk with 4K sector. 
Execute scenario again by assigning 512 sector basic disk (MBR). 

 
 
 

Q23 
Following message is displayed when restoring and becomes scenario execution error. 
Failed to restore. 
The data is not written to the destination storage device. 
The basic disks with non-512-byte sector is not supported. 
(sector size of the specified device)  
----- 
(xxxxx) 

 
A23 

When you restore by assigning partition, there is a possibility that above message might be displayed 
in case the destination hard disk is a basic MBR disk with 4K sector. 
Execute scenario again by assigning 512 sector basic disk (MBR). 
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Q24 

Following message is displayed when restoring and becomes scenario execution error. 
Failed to restore. 
The data is not written to the destination storage device. 
Cannot restore the data of a different sector size. 
Please specify the appropriate device, and check  
if the specified Deploy-OS is correct.  
(required sector size of a destination device) 
(the specified device: its sector size) 
----- 
(xxxxx bytes) 
(DeviceName: xxxxx bytes)  

 
A24 

There is a possibility that above message is displayed when the sector size which you backup and 
that of restoration destination are different. 
Confirm the sector size of the disk of restoration destination and select disk which matches the sector 
size which you back up. 
If there is no problem with the size, confirm designated Deploy-OS. 
For details of correspondence depending on the model, contact your sales or support representative. 

 
 
 

Q25 
When a restore scenario is multicast distributed, the restore does not executed, and scenario execution 
is interrupted. 
Furthermore, the following message was displayed on the managed machine, and then the machine 
restarted. 
(After restarting, scenario execution error was displayed on the status of the managed machine on the 
Web Console.) 
Failed to read or write the data in the managed machine. 
For this error, contact your sales or support representative. 
This System is reboot after XX seconds. 
gzip: stdin: Unexpected end of file. 

 
A25-1 

This phenomenon may occur when both ANY is specified for the IP address used by Management 
Server and the restore scenario is distributed by multicast. Configure except ANY for the IP Address 
used by Management Server (the IP address configured by the using LAN board). See Section 
2.7.1.1, "General Tab" in Web Console Reference Guide for details. 

 
A25-2 

Confirm whether the switching hub and router in use are set to send multicast or not. 
 
 
 

Q26 
When scenario is running, "boot:" or "login:" is displayed on the managed machine, and the processing 
does not proceed. 

 
A26 

You may have entered the key to stop processing such as "Ctrl" + "C". Do not enter a key on the 
managed machine when backup or restore scenario is running. 
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Q27 
PXE boot fails on the managed machine. 

 
A27 

Is the Management view -> DPM Server -> Detail Setting -> DHP Server tab set to Do Not Use a 
DHCP Server?  
If Do Not Use a DHCP Server is selected, a PXE boot cannot be executed on the managed machine. 
If PXE boot is necessary, configure a DHCP server, and select Use a DHCP server. 
Furthermore, restart the Management Server after changing it since the configurations are enabled 
after Management Server restarts. 

 
 
 

Q28 
When you execute backup/restore scenario, the following message is displayed on the screen of the 
managed machine and a scenario execution error occurs. 
ERROR: FC storage configuration is different from the result of the disk 
configuration check scenario. 
Please retry the disk configuration check scenario. 

 
A28-1 

When the configuration includes FC LUN, an error occurs because the information is different from 
that obtained by disk configuration check. When you change either of the following configuration, the 
error may occur. 
・ Adding, changing, or deleting LUN 
・ Changing the redundancy configuration of the path 
・ Change the configuration including FC LUN to other configuration (internal RAID configuration and 

so on.) and vice versa. 
Execute disk configuration check to obtain new configuration information and re-execute a scenario.  
Recheck the disk number as necessary. 

 
A28-2 

When the configuration includes FC LUN(LUN configuration, redundancy configuration), an error 
occurs because the information is different from that obtained by disk configuration check. When the 
part of paths cannot be connected due to physical problem and so on, the above message may be 
displayed. 
Recheck the connection status of the path or the redundancy configuration, or execute disk 
configuration check to obtain new configuration information and re-execute a scenario. 
Recheck the disk number as necessary. 

 
 
 

Q29 
Restoration requires more time than backup. 

 
A29 

Because writing speed to storage device for the client is slower than writing speed to the storage 
device for the server.  
Following might be the cause. 
・ RAID setting 
・ NTFS compression on the file system is valid. 
・ Fragmentation has been occurred on the hard disk. 

If fragmentation is the cause, defragmentation might improve the speed. 
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Q30 
When you execute restore scenario, the following message is displayed on the screen of the managed 
machine and a scenario execution error occurs. 
Failed to restore.  
The data is not written to the destination storage device.  
Cannot restore the data to a disk of a different type  
than you backed up.  
(Type of the backed-up disk) 
(Type of the specified disk) 
(X) 
(X) 
 
A30 

When the management form of the partition for the backup source is not matched with the form of the 
restoration destination, this message might be displayed. 
Execute scenario again after changing scenario according to the result of the disk configuration 
check. 
Specify GPT style for the restoration destination when the backup source is in GPT style. 
Specify MBR style for the restoration destination when the backup source is in GPT style. 

 
 
 
Q31 

When you execute backup scenario, the following message is displayed on the screen of the managed 
machine and a scenario execution error occurs. 
Failed to backup. 
The specified disk size is smaller than the calculated 
minimum disk size to restore.Check and repair the disk by fsck or other tools,  
then re-execute the scenario.  
Or execute the scenario with full sector option specified.  
(Disk Size) 
(Minimum Disk Size) 
(XXXXXXXXXX)  
(XXXXXXXXXX) 
 
A31 

When the disk capacity calculated by the managed data is larger than the actual capacity, this 
message might be displayed. 
Execute scenario again after executing disk check/recover on OS. 
If you cannot improve even after executing disk check/recover, set the full sector option for the 
scenario and execute scenario again. 

 
 
 

Q32 
"Cannot find the corresponding disk(2)" is displayed while backup/restoration.  

 
A32 

There might be mistake in specification of the disk number when you execute scenario creation. 
Specify the disk number after checking the followings. 
・ Check whether the disk number is correspond to the disk to backup or to restore. 
・ The storage device which is recognized to the destination machine for backup/restoration is 

connected. 
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Q33 

"Cannot find the corresponding partition (Disk:XX, Partition:XX)" is displayed while backup/restoration. 
 

A33 
The partition you set as the scenario might not exist. 
Execute scenario again after changing scenario according to the result of the disk configuration 
check. 

 
 
 

Q34 
Scenario execution error occurs while backup due to capacity shortage of the Management Server side. 

 
A34 

Size up the free area of HDD of backup destination for the Management Server. 
Create backup image file as temporary and overwrite on the previous file at the timing of completion 
of backup. 
Therefore, the free space is necessary for this step temporarily. 

 
 
 

Q35 
Following error is displayed, without starting backup/restore.  
"Could not find IP address and NetworkDeviceName." 

 
A35 

There is a possibility that LAN board mounted on the Managed Machine might not be corresponded to 
DPM. Check and follow the step as below. 
For details of the corresponding model list, contact your sales or support representative. 

 
 
 

Q36 
Time is required on scenario execution by CD boot until the actual process begins. 

 
A36 

Scenario execution by CD boot makes an attempt to the Management Server by using NIC in order 
which is detected on the managed machine. 
To identify NIC connected to the Management Server needs several tens of minutes on the managed 
machine mounted multiple NIC. 
Add "ClientEth:x" on "DPMIP.conf" to specify eth number to save time when eth number of NIC which 
is connected to the Management Server is clear. 
See "Executing Backup, Restore, or Disk Configuration Check" in Appendix A "Operating DPM 
without Using the DHCP Server" in Operation Guide for details of setting. 

 
 
 

Q37 
Either of the error messages listed below is displayed on the screen of the managed machine and the 
event log of the Management Server when executing backup/restore/disk configuration check scenario. 

 
On the screen of the managed machine 

・ AddDrv.sh: ERROR: <driver file name>: Cannot get driver file. 
 
Event log of the Management Server 

・ ft: ERROR: Failed to search folder, Path =..\<driver file name> ftsvc.cpp:xxx:xxx xx xxxx 
・ File Download Failed.File Name:<driver file storage folder>\scsi\<driver file name>, 

ClientMac:xx-xx-xx-xx-xx-xx 
*<driver file name>: The name of the driver which problem has been occurred 
*<driver file storage folder>:Differs depending on the environment 
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A37 

There is a possibility that the driver file (xxxx.o/xxxx.ko) which is included in the error message output 
to the screen of the managed machine and the event log of the Management Server might not be 
installed to the Management Server. 
Check whether the driver file is installed or not with either of the following steps. 

 
Countermeasure 1: Confirm the event log "File Download Failed" of the Management Server. 

 
Check whether the driver file specified by the message "File Name:" exist or not when 
above error message is output. 
・ File Download Failed. File Name:<driver file storage folder>\scsi\xxxx, 

ClientMac:xx-xx-xx-xx-xx-xx. 
 

Example: Output event log: 
File Download Failed.  
File Name:C:\Deploy\FD-Linux\drivers\ia32_121228_26\scsi\megasr.ko,  
Client Mac: 12-34-56-78-9a-bc . 

->Check whether C:\Deploy\FD-Linux\drivers\ia32_121228_26\scsi\megasr.ko 
exists or not. 

 
Countermeasure2: Confirm "AddDrv.sh: ERROR: xxxxx" on the screen of the managed 

machine or the event log of the Management Server "ft: ERROR: Failed 
to search folder xxxxx". 

 
1. Confirm the path of the driver file storage folder from below table by checking type of 

"Deploy-OS" which is assigned to the managed machine on the Web Console. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

*Default for Image storage folder is C:\Deploy. 
*For the bootable CD, driver file storage folder should be the same of Deploy-OS for the 

Management Server. 

Value set to Deploy-OS Path of the Driver file Storage Folder* 
Use the default value <Image storage folder>\FD-Linux\drivers\<default value> 

 
<default value>is the name displayed in "Detail Setting" ->"General" on 
the DPM Server. 
Default is "ia32_110331_26". 

NEC Express5800 001 < Image storage folder >\FD-Linux\drivers\ia32_080331_24 
NEC Express5800 002 < Image storage folder >\FD-Linux\drivers\ia32_110331_26 
VMware ESX Virtual 
Machine 001 
Microsoft Hyper-V 
Virtual Machine 001 
NEC Express5800 006 < Image storage folder >\FD-Linux\drivers\ia32_121228_26 
VMware ESXi Virtual 
Machine 002 
Microsoft Hyper-V 
Virtual Machine 002 
VMware ESXi Virtual 
Machine 003 

< Image storage folder >\FD-Linux\drivers\ia32_150413_26 

Others < Image storage folder >\FD-Linux\drivers\<ia32_xxxxxx_xx> 
 
Refer to the manual of the module for the machine model for 
<ia32_xxxxxx_xx>. 
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2. Confirm whether the driver file (xxxx.o/xxxx.ko) is included in the error message exists under 

the driver storage folder path. 
 

Example: 
Output event log: 

ft: ERROR: Failed to search folder, Path = ..\megasr.ko, ftsvc.cpp:874:Dec 22 2014 
Deploy-OS of the managed machine 
NEC Express5800 002 
->Confirm whether C:\Deploy\FD-Linux\drivers\ia32_110331_26 

megasr.ko exists in C:\Deploy\FD-Linux\drivers\ia32_110331_26\scsi or not. 
 

For details of driver pack installation, contact your sales or support representative. 
Re-execute the scenario after above procedures. 

 
 
 

Q38 
Following error message is displayed on the managed machine when executing backup/restore/disk 
configuration. 

 
BUG: soft lockup - CPU#0 Stuck for 67s! 
*CPU number differs depending on the operation environment. 

 
A38 
There is a possibility that operation delay is occurred on Deploy-OS and soft lockup error is detected 
when managed machine is the virtual machine of VMware ESXi 5.1 or later and configurated with one 
and more CPUs. 
Applicable condition/source of supply for the patch module to avoid this phenomenon is decribed as 
follows. 
[Applicable condition] 

・ The managed machine is the virtual machine for VMware ESXi 5.1 or later. 
 

[Source of supply of the patch module to avoid this phenomenon] 
・ <Installation media>\DPM\TOOLS\PreventSoftLockup_Module 
* Refer to the manual for details of application procedure under the folder. 

Applying patch module might inhibit soft lockup error and improve this phenomenon. 
 
 
 

Q39 
Is the backup image file enable to output to the storage device which is connected to the network such 
as NAS and so on? 
 

A39 
Depends on the specification of the storage device whether it is possible to output the backup image 
file on the storage device which is connected to the network directly. 
 
Possible when there is authority to create files on the storage device for the Management Server in 
case embedded drive is recognized like D drive or E drive for the Management Server. (Validate 
beforehand) 
See "When specifying the path of the image file in another computer connected to the network 
(hereafter referred to as file server), perform the following." in Section 3.13.4, "Backup/Restore Tab" 
in Web Console Reference Guide for details. 
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3.5.7. Distribution of Floppy Disk Image for BIOS/Firmware 
 
Q1 

The managed machine does not boot by the network boot after scenario that Distribution of floppy disk 
image for BIOS/firmware is executed. 

 
A1 

If BIOS is upgraded, the BIOS configuration may return to the default settings. 
Check whether the priority order of the network boot is not changed. 
If the priority order is changed, set network boot to the top priority. 

 
 
 

Q2 
A scenario execution error occurs when you execute a Distribution of floppy disk image for 
BIOS/firmware, Installing service packs, hotfixes, Linux patch files, and applications install scenario. 

 
A2-1 

Confirm that the execution interruption processing is completed properly. 
If interruption is cancelled before the process of the interruption completes and then the scenario is 
executed, a scenario execution error may occur. 

 
A2-2 

Are you trying to execute the same scenario which is being executed on another machine? If you 
want to execute the same scenario on two or more machines simultaneously, specify the maximum 
target number under Multicast Condition to the number of machines that you want to execute, and 
then execute the scenario. 

 
 
 

Q3 
A scenario execution error occurs before the machine restarts after a scenario of Distribution of floppy 
disk image for BIOS/firmware and a scenario of OS clear installation is executed. 

 
A3 

Did you specify the Forced Execution Of A Reboot Is Performed Before Execution on the scenario 
Options tab before execution? If not, a scenario is not executed for any machine that is power on. 
Modify the scenario, or turn off the machine and execute the scenario again. 
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3.6. Registering a Managed Machine 
 

Q1 
Even if you turn on a managed machine, a new registration is not performed. 

 
A1-1 

The DHCP configuration may be wrong, or the DHCP server may not operate properly. Check the 
following items: 
- Select Management view -> DPM Server -> Detail Setting -> DHCP Server tab on the Web 

Console, and confirm that the Use A DHCP Server configurations are correct. 
- Confirm that the lease IP address in the DHCP scope is not inactive. 
- Confirm that the DHCP server is approved and the IP address can be leased. 
- Confirm that the DHCP address pool has not run out. If the pool has run out, please secure a 

sufficient amount of addresses. 
- If using a DHCP server except Windows, confirm that fixed addresses are configured. 

 
A1-2 

The managed machine may be a model that does not support PXE boot, or the network startup order 
may be set lower than the HDD. 
Check the network startup order in BIOS/UEFI settings. For details to check BIOS/UEFI, contact your 
sales or support representative. 
If you operate without using the DHCP Server, and the setting is changed to Do Not Use A DHCP 
Server in the Management view -> DPM Server -> Detail Setting -> DHCP Server tab, it is necessary 
to restart the Management Server to enable the setting. Restart the Management Server, and then 
restart the managed machine. 
If two or more LAN boards are mounted on the managed machine, confirm that the LAN board used for 
DPM communications is registered on DPM Server. 
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3.7. Automatic Update 
 

Q1 
Open Monitor view -> Automatic Update Result List screen, and check the detailed information of the 
corresponding machine and date/time, then registration of error log information can be confirmed. 

 
A1 

Check the detailed information, and fix each problem. 
If you execute automatic update after fixing the problem, reboot the managed machine. 

 
<Detailed Information 1> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update begins 
・ An error occurred while preparing for the automatic update. 
・ ...... 

Explanation: Management Server resource may be insufficient. Restart the Management Server. 
 

<Detailed Information 2> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update begins 
・ A socket error occurred. 
・ ...... 

Explanation: WinSock initialization failed. 
Check the network configuration of the Management Server (if TCP/IP protocol is 
installed). If there is no problem, restart the Management Server. 

 
<Detailed Information 3> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update begins 
・ The connection to the client failed. 
・ ...... 

Explanation: The Management Server could not connect to the managed machine. 
(1)Use the following procedures to execute ping for the machine. 

Enter ping IP address or ping hostname on the command prompt and press Enter. 
(Enter a space between ping and the IP address/host name.) 
If there is no response, check whether there is a problem in the network configuration. 

(2)If there is no problem in the network, restart the following services on the machine side. 
(If the service is stopped, start again.) 
DeploymentManager Agent Service 
DeploymentManager Remote Update Service Client 

 
<Detailed Information 4> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update begins 
・ Search for the packages that are applicable to the client failed. 
・ ...... 
Explanation: Automatic update function may not be supported on the OS of the machine on which the 

error occurred. Check the OS of the machine and language. The following is the list of 
OS that automatic update function is supported. The supported language of the machine 
is English only. 
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OS Name 
Windows XP Professional 
Windows Server 2003 Standard Edition 
Windows Server 2003 Enterprise Edition 
Windows Server 2003 Standard x64 Edition 
Windows Server 2003 Enterprise x64 Edition 
Windows Server 2003 R2 Standard Edition 
Windows Server 2003 R2 Enterprise Edition 
Windows Server 2003 R2 Standard x64 Edition 
Windows Server 2003 R2 Enterprise x64 Edition 
Windows Vista Business 
Windows Vista Enterprise 
Windows Vista Ultimate 
Windows Server 2008 Standard 
Windows Server 2008 Enterprise 
Windows Server 2008 Standard x64 
Windows Server 2008 Enterprise x64 
Windows Server 2008 R2 Standard 
Windows Server 2008 R2 Enterprise 
Windows Server 2008 R2 Datacenter 
Windows 7 Professional 
Windows 7 Ultimate 
Windows 7 Enterprise 
Windows 7 Professional x64 
Windows 7 Ultimate x64 
Windows 7 Enterprise x64 
Windows Server 2012 Standard 
Windows Server 2012 Datacenter 
Windows 8 Pro 
Windows 8 Enterprise 
Windows 8 Pro x64 
Windows 8 Enterprise x64 
Windows Server 2012 R2 Standard 
Windows Server 2012 R2 Datacenter 
Windows 8.1 Pro 
Windows 8.1 Enterprise 
Windows 8.1 Pro x64 
Windows 8.1 Enterprise x64 
Windows 10 Pro 
Windows 10 Enterprise 
Windows 10 Pro x64 
Windows 10 Enterprise x64 
Windows Server 2016 Standard 
Windows Server 2016 Datacenter 

 
<Detailed Information 5> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update begins 
・ Reconfirmation of the connection to the client failed. 
・ ...... 
Explanation: A communication error occurred with the machine. 

(1) Use the following procedures to execute ping for the machine. 
Enter ping IP address or ping host name and click Enter on the command prompt. 
(Enter a space between ping and the IP address/host name.) 
If there is no response, check whether there is a problem in the network 
configuration. 

http://www.microsoft.com/products/info/product.aspx?view=22&pcid=2abf99cd-a5e4-469c-802e-55ca8ec542d5


 

71 

(2) If there is no problem in the network, restart the following services on the machine 
side.(Start if the service is stopped.) 
DeploymentManager Agent Service 
DeploymentManager Remote Update Service Client 

 
<Detailed Information 6> 
・ Computer: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ Creating file in the client failed. 
・ ...... 
Explanation: The disk space of the machine may be insufficient. 

Check the machine disk free space. Normally, it required free disk space that at least 
three times the size of the package to send. 
Example) 

To apply a 100MByte package, it is necessary that the free space of the managed 
machine system drive should be at least 300MByte. 

 
<Detailed Information 7> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ An error occurred while preparing for the file transfer. 
・ ...... 
Explanation: An error occurred in the process before the file is transferred. 

The Management Server may have insufficient resources. Restart the Management 
Server. 

 
<Detailed Information 8> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ Creating file transfer thread failed. 
・ ...... 
Explanation: Failed to call WindowsAPI (CreateThread()). 

The resource on the Management Server may be insufficient. Restart the Management 
Server. 

 
<Detailed Information 9> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ Creating file transfer control thread failed. 
・ ...... 
Explanation: Failed to call WindowsAPI (CreateThread()). 

The resource on the Management Server may be insufficient. Restart the Management 
Server. 
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<Detailed Information 10> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ An error occurred during the transfer of xxxxxxxx. 
・ ...... 
Explanation: A communications error occurred when sending a file. 

(1) Use the following procedures to execute ping for the machine. 
Enter ping IP address or ping hostname and press Enter on the command 
prompt.(Enter a space between ping and the IP address/host name.) 
If there is no response, check whether there is a problem in the network 
configuration. 

(2) If there is no problem in the network, restart the following services on the machine 
side.( Start if the service is stopped.) 
DeploymentManager Agent Service 
DeploymentManager Remote Update Service Client 

 
<Detailed Information 11> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ File transfer to the client failed. 
・ ...... 
Explanation: A communications error occurred when sending a file. 

(1) Use the following procedures to execute ping for the machine. 
Enter ping IP address or ping host name and click Enter on the command prompt. 
(Enter a space between ping and the IP address/host name.) 
If there is no response, check whether there is a problem in the network 
configuration. 

(2) If there is no problem in the network, restart the following services on the managed 
machine side. 
(Start if the service is stopped.) 
DeploymentManager Agent Service 
DeploymentManager Remote Update Service Client 

(3) A file in transit may be in use by another process on the machine. 
If virus scan or other such software is running on the machine, a file in transit may be 
locked by the virus scan software, and transmission may fail. In such a case, when 
the next automatic update is executed, the file is sent again and applied. 

 
<Detailed Information 12> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ During the execution of xxxxxxxx package, an error occurred. 
・ ...... 
Explanation: The package was sent to the machine, however an error occurred during execution. 

(1) Use the following procedures to execute ping for the machine. 
Enter ping IP address or ping host name and click Enter on the command prompt. 
(Enter a space between ping and the IP address/host name.) 
If there is no response, check whether there is a problem in the network 
configuration. 

(2) The disk space may be insufficient. 
This error occurs when the machine disk space is insufficient. Check the machine 
disk free space. Normally, it requires free disk capacity that at least three times the 
size of the package to send. 

Example)  
To apply a 100MByte package, it is necessary that the free space of the managed 
machine system drive should be at least 300MByte. 

(3) Uncompressing failed. 
Check whether there is a problem in the package sent to the machine. Confirm 
whether the package can be uncompressed on the machine. 



 

73 

 
<Detailed Information 13> 
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update Begins 
・ "Automatic update completed" response could not be received from the client. 
・ ...... 

Explanation: 
(1) Use the following procedures to execute ping for the machine. 

Enter ping IP address or ping host name and click Enter on the command prompt. 
(Enter a space between ping and the IP address/host name.) 
If there is no response, check whether there is a problem in the network 
configuration. 

(2) If there is no problem in the network, restart the following services on the managed 
machine side. (Start if the service is stopped.) 
DeploymentManager Agent Service 
DeploymentManager Remote Update Service Client 

 
<Detailed Information 14> 

・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ automatic update notice begins 
・ A socket error occurred. 
・ No such host is known. 
・ ...... 
Explanation: 

(1) Use the following procedures to execute ping for the machine. 
Enter ping IP address or ping host name and click Enter on the command 
prompt.(Enter a space between ping and the IP address/host name.) 
If there is no response, check whether there is a problem in the network 
configuration. 

(2) If there is no problem in the network, restart the following services on the managed 
machine side. (Start if the service is stopped.) 
DeploymentManager Agent Service 
DeploymentManager Remote Update Service Client 

 
<Detailed Information 15> 

・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update time setting begins 
・ Automatic update or scenario execution is in progress in the client. 
Automatic update time setting will become valid after restarting the client. 

・ ...... 
Explanation: 

The automatic update time configurations will be enabled when the machine is started next 
time. 

 
<Detailed Information 16> 

・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx) 
・ Automatic update time setting begins 
・ Setting in the client failed. 
・ Automatic update time setting will be valid after restarting the client. 
・ ...... 
Explanation: 

Connection to the managed machine failed because the managed machine power status is 
OFF, or the communications port is closed. The automatic update time configurations will be 
enabled after the client is restarted. 
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Q2 
The same package is distributed repeatedly in automatic update. 

 
A2 

Until the Management Server recognizes that the package has been applied, the distribution is 
repeated at every automatic update. Check the following items, and perform the process for each. 
・When the package type is HotFix 

- The MS number is wrong  
Check the MS number and correct it. 

- The HotFix that cannot be discerned from the MS number 
Set the ID information. 

- OS and language are not correct 
Check the OS and the language. If there is a problem, correct them. 

- ID information is wrong 
If a file such as text format (*.txt) without file version is specified for ID information file path, the 
applied status cannot be recognized if the file version is specified. If the file version is need to be 
specified, make the item blank. Also, if it is specified to replace or version up as the changed type 
using text format file, the applied status cannot be correctly recognized. In the case of text format, 
specify new or delete for the changed type. 

・When the package type is service pack 
- Major version and minor version are wrong. 

Check major version and minor version and correct them. 
- OS and language are not correct  

Check the OS and the language. If there is a problem, correct them. 
- ID information is wrong 

ID information is not necessary for the service pack. Set the correct values to for major version and 
minor version. 

・When the package type is application 
- Display name, display version is wrong. 

Check the display name and display version and correct them. 
- OS and language are not correct. 

Check the OS and the language. If there is a problem, correct them. 
- ID information is wrong 

If a file such as text format (*.txt) without file version is specified for ID information file path, the 
applied status cannot be recognized if the file version is specified. If the file version is need to be 
specified, make the item blank. Also, if it is specified to replace or version up as the changed type 
using text format file, the applied status cannot be correctly recognized. In the case of text format, 
specify new or delete for the changed type. 

 
 
 
Q3 

An automatic update error is displayed on the screen, and automatic update fails. 
 

A3 
The disk capacity of the Management Server may be insufficient. 
Check the disk capacity of the Management Server. If disk capacity is insufficient, secure the 
necessary disk capacity, and then restart the Management Server. 
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3.8. Automatic Download 
 

Q1 
An error occurred in automatic download. In Management view -> DPM Server icon -> Package 
Download Settings screen -> Latest Download Information column, XXXX/XX/XX XX:XX:XX 
Automatic Download Failed is displayed, and check the Event Viewer to find an error log registered. 

 
A1 

Check the log information registered in the Event Viewer, and perform the processes for each item. 
After the processes complete, execute the automatic download again. 

 
<Log Information 1> 
- DownloadFile: Failed to create the download directory, Dir = XXX. 
Explanation: 

Failed to create directory. 
This error occurs when the disk space of the managed machine is insufficient. Check the 
disk free space. 

 
<Log Information 2> 
- DownloadFile: Failed to parse URL, URL = XXX. 
Explanation: 

Unable to analyze address. 
IP address of the Package Web Server may not be correct. Confirm items such as 
whether only valid characters are used, or port configurations are correct. For details, 
see Section 2.7.3, "Package Download Setting" in Web Console Reference Guide. 

 
<Log Information 3> 
- DownloadFile: Failed to connect proxy server, Serve Name = XXX. 
Explanation: 

Cannot connect to the proxy server. 
 

Check the below items in the following order: 
(1) The proxy server address may not be correct. Confirm items such as whether only 

valid characters are used, or port configurations are correct. 
(2) The network settings may not be correct. 

Check whether user identification is set to the proxy server. Use an HTTP proxy if 
using a proxy. 

 
<Log Information 4> 
- DownloadFile: Failed to connect server, Serve Name = XXX. 
Explanation: 

Failed to connect to the Package Web Server. 
 

Check the below items in the following order: 
(1) IP address of the Package Web Server may not be correct. Confirm items such as 

whether only valid characters are used, or port configurations are correct. 
(2) The network settings may not be correct. 

Check whether user identification is set in the proxy server. Use the HTTP proxy 
when you use the proxy. 
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<Log Information 5> 
- DownloadFile: Web server happened exception, Serve Name = YYY. 

Refer to the following detailed message in the log information registered to the event viewer. 
SendRequest: Http response error status = XXX. 
(Possible values for XXX are: 500, 501, 502, 503, 504, 505) 

 
The error code XXX is specified in RFC2616. See "RFC2616" for details. 
For details, see "RFC2616". 

 
<Log Information 6> 
- DownloadFile: Failed to get response or response is error, URL = YYY. 

Refer to the following detailed message in the log information registered to the event viewer. 
SendRequest: Http response error status = XXX. 
(Possible values for XXX are: 400, 401, 402, 403, 404, 405, 406, 407, 408, 409, 410, 411, 412, 413, 
414, 415). 

 
The error message XXX is added the error code conformable to "RFC2616". 
See "RFC2616" for details. 

 
Example) SendRequest: Http response error status = 404 

->The specified URL does not exist. 
 

<Log Information 7> 
- DownloadFile: The free disk isn't enough to download, URL = XXX. 
Explanation: 

This error occurs when the disk space of the Management Server is insufficient. Check the 
disk free space. 

 
<Log Information 8> 
- DownloadFile: The file cannot be refresh, Filename = xxx. 
Explanation: 

Failed to update the file. Check whether a file named xxx is in use. 
If the file is in use, close it, and then download again. 

 
<Log Information 9> 
- PmDlDownloadPackages: Failed to compress files, Web Server ID = xxx, Package 
ID = xxx. 

Explanation: 
This error occurs when the disk space of the Management Server is insufficient. Check the 
disk free space. 

 
 
 

Q2 
Automatic download is configured, however it is not executed even when the set time is reached. 

 
A2 

Check the items below by the following order: 
(1) In Management view -> Package Download Setting screen, check Latest Download 

Information. 
If XXXX/XX/XX XX:XX:XX Automatic Download Failed is displayed, see Log Information 1 
through 9 of Section 3.8, "Automatic Download." 

(2) Check if the Package Web Server is added as the target of automatic download on the Package 
Download Setting screen. If none of the Package Web Servers are added, automatic download 
is not executed. After adding a Package Web Server, perform an automatic download again. 

(3) Check whether the Perform Automatic Download checkbox is checked on the Package 
Download Setting screen. If not, the automatic download cannot be performed. 
If the above procedure does not solve the problem, confirm that automatic update is not in 
progress, and then restart the Management Server. 
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3.9. Power On 
 

Q1 
The machine cannot be turned ON when executing Power On or executing scenario. 

 
A1 

When the machine was forcibly shut down on the POST screen, Remote Power On may not function at 
the next time. 
In this case, turn off the power after POST is completed, or start up the OS and then shut it down. 

 
 
 

Q2 
Although the power is ON, the icon displayed on the machine is power OFF. 

 
A2 

The screen may not be updated. Click Refresh on the Operation menu, or enter F5 to refresh the 
screen. 

 
 
 

Q3 
The power is turned ON, however a remote power ON error is displayed on the machine list. 

 
A3 

The managed machine may not support PXE boot, or the network boot order may be set lower than the 
HDD. 
Check the network boot order in the BIOS/UEFI settings. For details to check BIOS/UEFI, contact your 
sales or support representative. 

 
 
 

Q4 
The VMware ESXi virtual machine cannot be turned ON when executing Power On or executing 
scenario. 

 
A4 

The VMware ESXi virtual machine cannot be turned on because Remote Power On is not support for 
these machines. Turn the power ON manually. 

 
 

3.10. Schedule Management 
 

Q1 
Although you set the power management schedule, the machine power is not turned ON/shut down at 
the specified time. 

 
A1 

The machine may have been running a scenario. If the machine is running a scenario at the time set to 
Power ON/shutdown, the power will not be turned ON/shut down. 
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3.11. Machine Information Import/Export 
 

Q1 
Although the machine information is imported, the machine is not displayed on the managed machine 
list. 

 
A1 

Click Refresh on the Operation menu, or refresh the screen by pressing F5 key, and then the machine 
will be displayed. 
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3.12. Network Settings 
 
Q1 

The following error message is displayed: 
Failed to delete the computer name of the server. 
Check the network environment, and restart. 

 
A1 

The machine may not be connected to the network. 
Check whether the network cable is connected to the machine, and then restart. 

 
 
 

Q2 
Once DHCP server and the Management Server have been separately on the different machines, the 
MAC address of the machine cannot be obtained. 

 
A2-1 

The DHCP server on the Management Server may be running. On the Management Server, select 
Management Tools -> Services from Start menu, and confirm that "DHCP Server" is stop. If it is 
running, disable Startup Type on the Properties screen, and stop the service. 
 

A2-2 
On the Web Console, Management view -> DPM Server icon -> Detail Setting -> DHCP Server tab 
-> DHCP Server is installed on an another machine checkbox may be cleared. Check if DHCP 
Server is installed on another machine is checked. If the checkbox is not checked, check it and 
click OK, and then reboot the Management Server. (If the Management Server cannot be rebooted, 
stop all services listed in Appendix A, "Service List" by selecting Management Tools -> Services 
from Start menu, and then start them.) 

 
 
 

Q3 
The scenario cannot be executed because the managed machine cannot execute network boot. 

 
A3 

Network booting order may be set lower than the HDD in the BIOS configuration. Set the start order of 
the PXE network boot higher than the HDD, and then execute the scenario again. 

 
 
 

Q4 
When you try to manage different network by using two or more LAN boards, the following errors are 
displayed. 
PXE-E51: No DHCP or proxyDHCP offers were received. 
PXE-E55: ProxyDHCP service did not reply to request on port 4011. 
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A4 

Perform the following procedures Step (1) and (2). 
(1) Change the IP address used by the DHCP server. 

1) From Start menu, select Administrative Tools -> DHCP. 
2) DHCP screen appears. Right-click the server name from the tree view, and then select 

Properties. 
3) Properties screen appears. Select the Advanced tab and click Binding. 
4) Binding screen appears. Select only the IP address to be used and click OK. 
5) From Start menu, select Management Tools -> Services, and then restart the DHCP Server. 

(2) Change the IP used by DPM. 
1) From Management View -> DPM Server icon -> Detail Setting screen -> General tab -> -> 

Server Information -> IP Address on the Web Console screen, set the IP address which was 
set at Step (1). 

 
 
 

Q5 
When DHCP Server and the Management Server have been separately on the different machines, the 
following error was displayed at network boot execution. 
PXE-E55: ProxyDHCP service did not reply to request on port 4011. 

 
A5 

A DHCP server may exist which is set to option 60(060 Class ID) in DHCP server options. Check the 
DHCP server option settings, and delete the option 60(060 Class ID) setting. 

 
 
 

Q6 
Following error is displayed after changing the default gateway of the Management Server. 
PXE-E55: ProxyDHCP service did not reply to request on port 4011. 

 
A6 

There is a case when network profile is changed by changing default gateway on Windows OS. 
There is possibility that the port used on DPM might not be opened on the changed network profile. 
Confirm the network profile currently valid and whether the port used on DPM is opened or not. 
Open the port used on DPM when it is not opened. 
See Section 3.1, "Port Opening Tool" in Tool Reference Guide for details. 

 
 
 

Q7 
When you execute a scenario, the following errors are displayed. 
PXE-E16:No offers were received 
PXE-E51:No DHCP or proxyDHCP offers were received. 
PXE-E53:No boot filename received  
PXE-E55:ProxyDHCP service did not reply to request on port 4011. 

 
A7-1 

The DHCP server installation location configuration is incorrect. 
Open Management View -> DPM Server icon -> Detailed Setting screen on the DPM main window 
screen, and check that the setting of DHCP server tab is correct. 
Even if configuration is already correct, reconfigure the settings. 

 
If an error is displayed despite correct settings, first change the current settings to different settings (if 
the actual environment is DHCP Server is installed on the machine, then change it to DHCP 
Server is installed on an another machine, and if it is DHCP Server is installed on an another 
machine, then change it to DHCP Server installed on the machine), and then reconfigure the 
settings correctly. 

Example) If DHCP Server is installed on the machine is selected: 
(1) Select DHCP Server is installed on an another machine 
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(2) Click OK  
(3) According to the message displayed on the screen to restart the services 
(4) Select DHCP Server is installed on the machine 
(5) Click OK  
(6) According to the message displayed on the screen to restart the services 

 
A7-2 

Confirm whether the address pool of DHCP is starved or not. 
When it is starved, keep adequate address pool. 

 
A7-3 

Confirm that STP (spanning tree protocol) is not executed on LAN switch. 
 
 

Q8 
When you assigned IP addresses of the same segment to a machine with two or more LAN boards, 
power status cannot be detected properly. 

 
A8 

If static IP addresses are assigned to LAN boards which are not connected to LAN cables, the machine 
may not be able to communicate normally. If any LAN boards are not connected to LAN cables, either 
use DHCP settings without assigning static IP addresses, or set nothing for them. 

 
 
 

Q9 
During network boot, the following message is displayed on the screen of the managed machine, and a 
scenario execution error occurs. 
PXE-E32: TFTP open timeout 

 
A9 

The TFTP port (port number: 69) may be blocked due to the port blocking functionality of Windows 
Firewall, or other security software. Confirm that the TFTP port is not blocked on the Management 
Server. It is necessary to unblock the TFTP port in order to perform operations on DPM. 

 
 
 

Q10 
When you execute network boot for the managed machine which exist in different segment, the 
following error displayed. 
PXE-E16: No offer received. 

 
A10 

There is a possibility that the rooter option might not set on the scope option for DHCP. 
Execute the network boot again after setting the rooter option. 
See Section 2.2.1, "Network Environment" in First Step Guide to check the network setting.  
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3.13. Operation Without DHCP Server 
 

Q1 
An error occurs in Power ON, or Add Machine. 

 
A1 

Confirm if DPM Client is installed on the managed machine. See Section 2.2, "Installing DPM Client" 
in Installation Guide for the installation procedure. 

 
 
 

Q2 
Failed in executing Backup scenario/restore scenario/ disk configuration check scenario from bootable 
CD. 

 
A2 

Check the following: 
Is the managed machine registered? 
Is a scenario assigned to the managed machine? 
Is the scenario assigned to the managed machine correct? 
Is a Multicast Scenario assigned? 
Does the scenario specify two or more tabs, such as specifying both the Backup/Restore tab and the 
HW Setting tab selected? 
An error occurs by scenarios excluding backup scenario, restore (unicast) scenario, or disk 
configuration scenario. 

 
 
 

Q3 
When you insert a bootable CD into the managed machine and execute Backup/Restore Scenario from 
the Web Console, the scenario executes on a machine except the machine specified and the scenario 
completes properly, however a scenario execution error occurs on the machine specified in Operation. 

 
A3 

The machine may be mounted to two or more LAN boards which are executed the scenario, and each 
of those boards may be registered to DPM. If there are two or more registrations for the same 
machine, delete the unnecessary registrations, and then execute backup/restore again. 

 
 
 

Q4 
Even if you set a bootable CD to start the machine, the backup/restore scenario does not start. 

 
A4 

Is the CD listed at the beginning of the boot order? 
If not, change the boot order so that CD boot listed at the beginning. 

 
 
 

Q5 
When you insert the bootable CD and start the machine, A state of communication was bad condition 
is displayed on the screen. 

 
A5 

Some kind of error may have occurred. 
・ If timeout occurs before the managed machine connect to the Management Server: 

Set a greater value for Remote Power ON Timeout on the Network tab of the Detail Setting 



 

83 

screen, and then run backup/restore again. 
See Section 2.7.1.3, "Network Tab" in Web Console Reference Guide for details. 

・ If using a bootable CD and Do Not Use A DHCP Server is not selected on the DHCP Server tab of 
the Management Server Detail Setting screen: 
see Section 2.7.1.4, "DHCP Server Tab" in Web Console Reference Guide and set the DHCP 
Server tab items which correspond to the correct environment. 
* Restart the Management Server after changing the configuration is necessary. 

・ If the MAC address of the LAN board on the managed machine is not registered to DPM, which is in 
communication with the Management Server: 
Register an appropriate MAC address to DPM, and execute backup/restore again. 

・If neither of the above apply: 
For reasons such as the network being unconnected or influences from the network, the 
Management Server and the managed machine may be under a condition where they cannot 
connect with each other. Check the network status between the Management Server and the 
managed machine, and then execute backup/restore again. 

 
 
 

Q6 
When you insert the bootable CD and start the managed machine, the following message is displayed 
on the screen, and processing is interrupted: 
linuxrc: Cannot find CD-ROM Drives. 

 
A6-1 

This error occurs when the bootable CD is unable to recognize a device. 
If using a USB CD/FD drive, change the port which connects to the drive, and then try again. 
The CD drive used may not be supported by DPM. 

 
A6-2 

If you are using such drives, prepare another CD drive, or execute backup/restore by using Use A 
DHCP Server. 

 
A6-3 

When the managed machine has embedded SATA RAID configuration and the bootable CD storage 
file which has been used when creating bootable CD is other than "ia32_080331_24", there is a 
possibility that the driver file to recognize CD drive to the bootable CD might not be installed. 

 
For details, contact your sales or support representative. 

 
 
 

Q7 
Backup/restore does not start, and the following message appears on the screen. 
(The x below is a number.) 
ERROR: Failed to read a file (x) 

 
A7 

If backup target correspond to one of the following situation, error is displayed because the following 
target is recognized before the disk, 
・ If a USB device is connected to backup target machine. 
・ When interface is existing for backup target machine in order to connect USB device. 
・ When CD-DVD drive is built in the chassis of BladeServer. 
In this case, change the disk number of the scenario, and then execute the scenario. 
Also, the recognized disk number depends on the device, so if the same error occurs after changes, 
change the device numbers again and then execute backup. 
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Q8 

If restore is interrupted, the following messages are displayed:  
ERROR: Found the eof during the input of a binary stream.  
gzip: stdin: unexpected end of file. 

 
A8 

When restore is interrupted during data transfer, these messages may be displayed. If this message was 
displayed after restore was interrupted, execute restore again, or setup the OS. 

 



 

85 

3.14. Local Restoration without using the 
Management Server 

 
If any problem occurs in local restoration, contact your sales or support representative. 
 

3.15. PackageDescriber 
 

Q1 
Following error is displayed when you try to start PackageDescriber on Windows Vista. 
"Unable to access jarfile PackageDescriber.jar" 

 
A1 

There is a possibility that setting of "Temporary Folder" has not been changed from default. 
Execute either of following settings.  
・ Invalidate "User Account Control: UAC" and use PackageDescriber. 

To invalidate, uncheck Use User Account Control (UAC) to help protect your computer from 
Start menu, click Control Panel -> User Accounts -> Turn User Account Control on or off. 

・ Execute as administrator 
(1) Click Start menu -> All programs -> right click DPM PackageDescriber and select 

Properties 
(2) Properties of DPM PackageDescriber is displayed, click OK after checking Run this 

program as an Administrator on Privilege Level on Compatibility tab. 
(3) Click Continue when Access Denied is displayed. 
(4) Right click the short cut icon of DPM PackageDescriber on desktop and select Properties and 

follow Steps (2) and (3). 
 

Click Accept when User Account Control screen is displayed when PackageDescriber is started 
after setting above. 
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3.16. Collecting the Data in Case of Trouble 
 When you would like to inquire a failure while using DPM, please send the following information to the 

support representative.: 
・ Information of DPM version/the module for the machine model 
・ Managed machine information 

- Machine model/Product number 
- Configuration of optional products/Product number 
- Machine name 
- MAC address 
- OS type 

・ Date and time that the obstacle occurred 
・ Failure information 

- How to operate DPM, and what occurred. 
・ Display on screen 

- Management Server 
- Managed machine 

・ Repeatability 
- Always occurs 
- There is a case that it succeeds 
- Succeeded in the past, however it began to fail one day 
- On other managed machine, it occurred or not 

・ DPM log collected by DPM Log tool 
- Management Server 
- Managed machine 
*When the failure occurred, please collect log immediately 

If a scenario is executed on the same machine again, the log file may be overwritten. 
After about 1 week since the failure occurred, the log of DHCP Server will be overwritten. 

・ The figure of network configuration 
 

The procedure to collect the DPM log is listed below. 
Target machines of collecting logs are the Management Server, the Database Server(only when the 
database is configured on the different machine from the Management Server), and managed machines. 

 
 Log collection Procedure (Windows x86/x64) 

Collect logs on the Management Server, the Database Server (only when the database is configured on the 
different machine from the Management Server), and the managed machine on which the error occurred, 
following the procedure below. 

 
(1) Check that all operations of DPM (the following) are completed or ended. 

・ Operations for managed machines (scenario execution, automatic update, file distribution, file 
execution, file deletion and obtaining the information in File/Folder List screen) are completed. 

・ Web Console and various tools of DPM are ended. 
 
(2) Log on to the machine by a user with administrator authority. 

Log on to the Management Server (in the environment that the database is configured on the same 
machine as DPM Server) by a user who installed DPM Server. 
Log on to the Database Server by a user who configured the database. 
 

(3) When you collect logs on the Management Server, it is unnecessary to do this procedure. 
Skip to Step (4). When you collect logs on the Database Server or the managed machine, copy the 
following folder to the arbitrary folder. 
<Installation media>:\DPM\TOOLS\DpmLog 

 
(4) Start the command prompt and move to the following folder. 

・ On the Management Server: 
<DPM Server installation folder>\DpmLog 

・ On the Database Server or the managed machine: 
The folder which was copied in the Step (3). 
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Example) If the location of the folder copied at Step (3) is "C:\" 
cd /d C:\DpmLog 

 
(5) Add option -A, and execute DpmLog.exe. See the following message and send the collected log. 

 

 
 
Note: 

 While DpmLog.exe is running, do not perform any DPM operation. 
 

(6) Delete the saved log folder because it is unnecessary after sending logs. 
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 Log collection Procedure (Linux) 

Collect the following files. When you collect the files, try not to change the time stamp (for example, -p option 
of cp command and so on), then use a command such as zip or gzip to compress on Linux, and then send. 

・ System Setting File 
/etc/hosts 
/etc/resolv.conf 
/etc/sysconfig/network 
/etc/sysconfig/clock (only when you use earlier than Red Hat Enterprise Linux 7)  
/etc/sysconfig/iptables (only when you use earlier than Red Hat Enterprise Linux 7) 
/etc/sysconfig/ipchains (only when you use earlier than Red Hat Enterprise Linux 7) 
/etc/rc.d/rc (only when you use earlier than Red Hat Enterprise Linux 7) 
/etc/sysconfig/network-scripts/ifcfg-* 

 
・ Version Information 

- For Red Hat Enterprise Linux 7 or later: 
/etc/redhat-release 
/etc/os-release 

- For Red Hat Enterprise Linux 6 or earlier: 
/etc/redhat-release 

- For SUSE Linux Enterprise: 
/etc/SuSE-release 

 
・ Files related to DPM Client 

All files located in folder /opt/dpmclient/ 
/var/log/messages* (All files whose name begin with "messages") 
All files located in folder /tmp/dpm/ (If existed) 

 
・ Disk and partition Information 

Collect the execution result of the following command. 
fdisk -l 
 

・ Network Information 
Collect the execution results of the following command. 
ifconfig -a 
ip addr show 
netstat -anp 
route 
ps -axm | grep depagtd 
iptables -L 

 
・ System Information 

Collect the execution results of the following command. 
uname -a 
lspci -vx 
dmidecode 
biosdecode 
dmesg -s 524288 
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Appendix A Service List 
 
The following is DPM services and processes. 
 

Note: 
 "Automatic" listed in the column of "Startup Type" in the following table is resident service. 

 
 DPM Server 
Service 
Name 

Display  
Name 

Startup 
Type 

Process Name 
*1 

The 
Number 
of 
Process 

Function 

APIServ DeploymentManager 
API Service 

Automatic apiserv.exe 1 Setting of scenario 
execution and each item 

 (Child process)  mkParams.exe 1 or 
more 

Tool to create a Windows 
disk duplication data file  

magicsend.exe 1 Executing remote power-on 

ipconfig.exe 1 or 
more 

Setting of Network 

nbtstat.exe 1 or 
more 

Setting of Network 

bkressvc DeploymentManager 
Backup/Restore 
Management 

Automatic bkressvc.exe 1 Executing backup/restore 

depssvc DeploymentManager 
Get Client 
Information 

Automatic depssvc.exe 1 Receiving the information of 
OS/service packs/patches 
from the managed machine 

PxeSvc DeploymentManager 
PXE Management 

Automatic pxesvc.exe 1 Controlling network (PXE) 
boot 

 (Child process)  ipconfig.exe 1 or 
more 

Setting of network 

nbtstat.exe 1 or 
more 

Setting of network 

PxeMtftp DeploymentManager 
PXE Mtftp 

Automatic 
(*2) 

pxemtftp.exe 1 TFTP server function 
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rupdssvc DeploymentManager 

Remote Update 
Service 

Automatic rupdssvc.exe 1 Executing remote update 

 (Child process)  zip.exe 1 File compressing 
command 

unzip.exe 1 File extracting command 

schwatch DeploymentManager 
Schedule 
Management 

Automatic schwatch.exe 1 Managing schedule 

 (Child process)  magicsend.exe 
 

1 Executing remote 
power-on 

ipconfig.exe 1 or 
more 

Setting of network 

nbtstat.exe 1 or 
more 

Setting of network 

ftsvc DeploymentManager 
Transfer 
Management 

Automatic ftsvc.exe 1 File transfer service 

  (Child process)  CHKOS32.exe 
 

1 or 
more 

Tool for obtaining OS type 

DHCPServer DHCP Server(*3) Automatic svchost.exe 1  

Winmgmt Windows 
Management 
Instrumentation(*4) 

Automatic svchost.exe 1  

RpcSs Remote Procedure 
Call (RPC)(*4) 

Automatic svchost.exe 1  

*1 
The default installation folder is 
C:\Program Files (x86)\NEC\DeploymentManager. 

*2 
When you install DPM Server, if you select Do not use the TFTP service of DPM on TFTP Server tab of 
the Detailed Setting screen, this item will be disabled. 

*3 
When the following is set, this is not required. 
Management view -> DPM Server -> Detail Setting -> DHCP Server tab ->Do Not Use A DHCP Server  

*4 
Use when DPM Client (Linux) is used. 
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 Database (SQL Server)*1 

Service Name Display Name Startup 
type 

Process Name 
*2 
 

The 
Number 
of 
Process 

Function 

MSSQL$ 
Instance Name 

SQL Server 
(Instance Name) 

Automatic sqlservr.exe 1 SQL Server 
database 
(DPM) 

SQLBrowser SQL Server 
Browser 

Invalid sqlbrowser.exe 1 SQL Server 
database 

*1 
This runs on the machine on which the database(SQL Server) is configured. 

*2 
The default installation folder is 
C:\Program Files\Microsoft SQL Server\MSSQL13.Instance Name\MSSQL\Binn. 
 

 Database(PostgreSQL) *1 
Service Name Display Name Startup 

type 
Process Name 
*2 
 

The 
Number 
of 
Process 

Function 

postgresql-x64-9
.5 

postgresql-x64-9.
5 - PostgreSQL 
Server 9.5 

Automatic pg_ctl.exe 1 PostgreSQL 
database 

*1 
This runs on the machine on which the database (PostgreSQL) is configured. 

*2 
The default installation folder is  
C:\Program Files\PostgreSQL\9.5\bin 
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 Image Builder (Remote Console) 

Service Name Display Name Startup Type Process Name 
*1 

The Number of 
Process 

Function 

None None  DIBuilde.exe 1 Image 
Builder 

  (Child 
process) 

 DIBPkgMake.exe 1 Tool for 
creating a 
package 

DIBPkgDel.exe 1 Tool for 
deleting a 
package 

mkParams.exe 1 Tool for 
creating a 
Windows 
disk 
duplicatio
n data file 

ExecLinuxIParm.j
ar 

1 Tool for 
creating a 
Linux 
install 
paramete
rs 

ExecLinuxSysRe
p.jar 

1 Tool for 
creating a 
Linux disk 
duplicatio
n data file 

winftc.exe 1 File 
transferri
ng tool 

zip.exe 1 File 
compress
ing 
command 

CHKOSCD.EXE 1 Tool for 
checking 
OS media 

*1 
The default installation folder is C:\Program Files (x86)\NEC\DeploymentManager. 
 
 DPM Command Line 

Service Name Display Name Startup Type Process 
Name *2 
 

The 
Number of 
Process 

Function 

None None  dpmcmd.exe 1 or more Scenario 
execution and 
so on from DPM 
Command Line  

*1 
The default installation folder is C:\Program Files (x86)\NEC\DeploymentManager. 
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 DPM Client (Windows) 

Service Name Display Name Startup 
Type 

Process 
Name *1 
 

The 
Number 
of 
Process 

Function 

depagent DeploymentManager 
Agent Service 

Automatic DepAgent.exe 1 Powering off the 
managed 
machine from 
DPM Server 

rupdsvc DeploymentManager 
Remote Update 
Service Client 

Automatic rupdsvc.exe 1 Executing remote 
update 
Sending the 
information of 
OS/service 
packs/patches to 
DPM Server 

 (Child process)  unzip.exe 1 File extracting 
command 

Execution 
File 

1 Installer of the 
package 

GetBootServer
IP.exe 

1 Searching the 
Management 
Server  

None None  DPMTray.exe 1 or more Automatic update 
status display 

*1 
The default installation folder is: 
・ x64: C:\Program Files (x86)\NEC\DeploymentManager_Client 
・ x86: C:\Program Files\NEC\DeploymentManager_Client 
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 DPM Client (Linux) 

Service 
(daemon) Name 

Display Name Startup 
Type 

Process Name The 
Number 
of 
Process 

Function  

For 
Red Hat 
Enterprise Linux 
7 or later : 
depagt.service  
 
For Red Hat 
Enterprise Linux 
6 or earlier/ 
SUSE Linux 
Enterprise: 
depagt 
 

None Automatic depagtd *1 1,2 DPM Client 
Service 

 (Child 
process) 
Executed by 
system 
function 

 depagtd 1 Powering off 
from DPM 
Server 
Executing 
remote 
update  
Sending the 
information of 
OS/patches 
of the 
managed 
machine to 
DPM Server 

rpm  1 rpm package 
installer 

shutdown 1 Shutdown 
command 

mv 1 Command for 
moving files 

echo 1 Command for 
displaying 
messages 

unzip 1 Command for 
extracting 
compressed 
files 

touch 1 Command for 
changing the 
time stamp 

GetBootServerIP 1 Searching the 
Management 
Server 

*1 
The installation directory is /opt/dpmclient/agent/bin (fixed value). 

 

Procedure and Order of Starting and Stopping the 
Service 
DPM Server is linked to and dependent on each DPM related service. Therefore, if you start or stop services 
manually, execute by following order. 
About DPM Client services (daemon), according to a given order for start/stop. 
 
・ Start service order 
(1) SQL Server (Instance name) or postgresql-x64-9.5 - PostgreSQL Server 9.5 
 

(2) Services that begin with "DeploymentManager" 
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・ Stop service order 
(1) Services that begin with "DeploymentManager" 

 
(2) SQL Server (Instance name) or postgresql-x64-9.5 - PostgreSQL Server 9.5 
 

Appendix B Event Log 
 
About the event log, contact your sales or support representative. 
 

Appendix C Error Information 
 
About error information, contact your sales or support representative. 
 

Appendix D Network Port and Protocol List 
 

 Communication Ports used by DPM  
 
Note: 

 When you configure DHCP server and NFS Server on the Management Server, the communication 
which is described in each table is done between the Management Server and the managed 
machines. 

 About opening the communication port (Windows OS), which is used by DPM, automatically or 
manually, see Section 3.1, "Port Opening Tool" in Tool Reference Guide. 

 
・ Communications between the Management Server and managed machines 

Item Management Server Protocol Con
necti
on  
Dire
ction 

Address 
Specifica
tion 

Managed Machine 
Executable 
File Name 

Port  
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Port  
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Executab
le File 
Name 

Power On magicsend. 
exe 

*1 No UDP -> DirectBro
adcast 
*2 

5561 No  

Shutdown apiserv.exe 
schwatch.ex
e 

*1 No TCP -> Unicast 2650
9 
*10 

Yes For 
Windows:  
DepAgent
.exe 
For Linux:  
depagtd 

Shutdown 
(only for 
SSC 
product) 

apiserv.exe 
schwatch.ex
e 

*1 No TCP -> Unicast 2650
9 
*10 

Yes For 
Windows:  
DepAgent
.exe 
For Linux:  
depagtd 

rupdssvc.exe 26507 
*10 

Yes TCP <- Unicast *1 No For 
Windows:  
DepAgent
.exe 
For Linux:  
depagtd 

Monitoring apiserv.exe *1 No TCP -> Unicast 2650 Yes For 
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DPM Client 
(Only for 
SSC 
product) 

schwatch.ex
e 

9 
*10 

Windows:  
DepAgent
.exe 
For Linux:  
depagtd 

Existence 
Confirmatio
n (Power 
ON/OFF 
Status 
Check) 

apiserv.exe 
schwatch.ex
e 

- *3 No ICMP 
Echo 
request 

-> Unicast 8 *3 No  

apiserv.exe 
schwatch.ex
e 

0 *3 No ICMP 
Echo 
request 

<- Unicast - *3 No  

Network 
Boot 

pxesvc.exe 67 No UDP 
(DHCP) 

<- Broadcast 
*4 *5 

68 No  

pxesvc.exe 67 No UDP 
(DHCP) 

-> Broadcast 
*4 *5 

68 No  

pxesvc.exe 67 No UDP -> Unicast 68 No  
pxesvc.exe 4011 No UDP <- Unicast 68 No  
pxesvc.exe 4011 No UDP <- Unicast 4011 No  
pxesvc.exe 67 No UDP -> Unicast 4011 No  
pxemtftp.exe 69 No UDP 

(TFTP) 
<- Unicast *6 No  

pxemtftp.exe 69 No UDP 
(TFTP) 

-> Unicast *6 No  

bkressvc.exe 26503 
*10 

Yes TCP <- Unicast *1 No  

bkressvc.exe 26502 
*10 

Yes TCP <- Unicast *1 No  

OS 
installation 
by disk 
duplication 
*7 

ftsvc.exe 26508 
*10 

Yes TCP <- Unicast *1 No  

Restore 
(Multicast) 
*8 

ftsvc.exe 26508 
*10 

Yes TCP <- Unicast *1 No  

bkressvc.ex
e 

26501 
*10 

Yes TCP <- Unicast *1 No  

bkressvc.ex
e 

26530 
*10 

Yes UDP -> Multicast 2653
0 
*10 

Yes  

Restore 
(Unicast) *9 

ftsvc.exe 26508 
*10 

Yes TCP <- Unicast *1 No  

bkressvc.ex
e 

26501 
*10 

Yes TCP <- Unicast *1 No  

Backup *9 ftsvc.exe 26508 
*10 

Yes TCP <- Unicast *1 No  

bkressvc.ex
e 

26501 
*10 

Yes TCP <- Unicast *1 No  

CD Boot pxesvc.exe 26505 
*10 

Yes TCP <- Unicast *1 No  

Disk 
Configurati
on Check *9 

ftsvc.exe 26508 
*10 

Yes TCP <- Unicast *1 No  
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Installing 
service 
packs, 
hotfixes, 
Linux patch 
files, and 
application
s by remote 
update 

rupdssvc.exe *1 No TCP -> Unicast 26510 
*10 

Yes For 
Windows:  
rupdsvc.e
xe 
For Linux:  
depagtd 

rupdssvc.exe *1 No UDP -> Multicast 26529 
*10 

Yes For 
Windows:  
rupdsvc.e
xe 
For Linux:  
depagtd 

rupdssvc.exe 2650
7 
*10 
 

Yes TCP <- Unicast *1 No rupdsvc.e
xe 
(Windows 
only) 

Send 
managed 
machine 
information 
*11 

depssvc.exe 2650
4 
*10 

Yes TCP <- Unicast *1 No For 
Windows:  
rupdsvc.e
xe 
For Linux:  
depagtd 

rupdssvc.exe 2650
7 
*10 

Yes TCP <- Unicast *1 No rupdsvc.e
xe(Windo
ws only) 

Automatic 
Update 
Request *12 

rupdssvc.exe 2650
6 
*10 

Yes TCP <- Unicast *1 No rupdsvc.e
xe 

rupdssvc.exe 2650
7 
*10 

Yes TCP <- Unicast *1 No rupdsvc.e
xe 

Automatic 
update 
notice 

rupdssvc.exe *1 No TCP -> Unicast 26511 
*10 

Yes rupdsvc.e
xe 

Searching 
the 
Managemen
t Server *13 

pxesvc.exe 67 No UDP 
(DHCP) 

<- Broadcast 
*4 

68 *14 No Windows: 
GetBootS
erverIP.ex
e 
Linux: 
GetBootS
erverIP 

pxesvc.exe 67 No UDP 
(DHCP) 

-> Broadcast 
*4 

68 *14 No Windows: 
GetBootS
erverIP.ex
e 
Linux: 
GetBootS
erverIP 

pxesvc.exe 4011 No UDP <- Unicast *1 No Windows: 
GetBootS
erverIP.ex
e 
Linux: 
GetBootS
erverIP 

pxesvc.exe 4011 No UDP -> Unicast *1 No Windows: 
GetBootS
erverIP.ex
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e 
Linux: 
GetBootS
erverIP 

pxemtftp.exe  69 No UDP 
(TFTP) 

<- Unicast  *1 No  

pxemtftp.exe  69 No UDP 
(TFTP) 

-> Unicast  *1 No  

File 
distribution, 
File 
execution, 
File 
deletion, 
Acquisition 
of the 
information 
in 
File/Folder 
List *15 

apiserv.exe *1 No TCP -> Unicast 26520 Yes For 
Windows:  
rupdsvc.e
xe 
For Linux:  
depagtd 

*1 
The port is automatically assigned. 

*2 
A machine on the same segments as the Management Server is addressed 255.255.255.255. 
If the segments are different than those of the Management Server, the address specification is direct 
broadcast. 
Example) 
The segment 192.168.0.0(MASK=255.255.255.0) is addressed 192.168.0.255. 

*3 
With ICMP (Internet Control Message Protocol), communication specifying the port number is not performed, 
however it is routed by using the value in the ICMP Type field value. 

*4 
A packet relayed by DHCP relay may be addressed as Unicast. 

*5 
Only if the DHCP and the Management Server are installed on different machines. 

*6 
Undefined. Depends on the LAN board ROM of the machine. 

*7 
The protocols and port numbers listed in Restore are also required. 

*8 
The protocol and the port number in the table of Network Boot are also needed. (You can restore by 
multicast only when you use DHCP server.) 

*9 
If operations are performed using DHCP, the protocols and port numbers listed in Network Boot items are 
also required. 
If operations are performed without using DHCP, the protocols and port numbers listed in CD Boot are also 
required. 
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*10 
The default values of the ports to be used were changed from DPM Ver6.1. When you upgraded from the 
version earlier than DPM Ver6.1, the port numbers used before upgrading are taken over. Therefore, the 
port numbers are different from them (Values in the above table) of when you install DPM Server newly. 
However, the port for Web service (56050) is not taken over and new port (26500) is used. When you use 
the port which was used before upgrading, modify manually. The following is the default port when you 
install DPM Server newly and when you upgrade DPM Server. 

When you install DPM Server newly When you upgrade DPM Server from the 
version earlier than DPM Ver6.1 

26500 26500 
26501 56020 
26502 56022 
26503 56030 
26504 56011 
26505 56060 
26506 56024 
26507 56028 
26508 56023 
26509 56010 
26510 56000 
26511 56025 
26529 56001 
26530 56021 

*11 
Send managed machine information at the time of client service startup. 

*12 
Request the automatic update for service pack/hotfix/applications from the managed machine to the  
Management Server at the specified timing. 

*13 
Necessary if you search the Management Server when the client service start-up or scenario execution. 

*14 
When both you operate DPM with DHCP server and you operate DPM without DHCP server, the part of the 
communication sequence of DHCP is used and UDP:68 is used. 

*15 
Necessary if you distribute file to the managed machine, when you delete or execute files on the managed 
machine and when displaying File/Folder List screen. 

 
Note: 

 When OS of the managed machine is either of the following, ports and programs are opened 
as the following, depending on the status of the network which is used when DPM Client is 
installed. 

・ For Windows Server 2008/Windows Vista 
Ports and programs are opened for either of public profile, private profile, or domain profile 
of Windows Firewall. 

・ For Windows Server 2008 R2/Windows 7 or later 
- About DeploymentManager (DepAgent.exe) and DeploymentManager (rupdsvc.exe), 

ports and programs are opened for active public profile, private profile, or domain profile 
of Windows Firewall. 

- About File and Printer Sharing (Echo Request - ICMPv4-In), ports and programs are 
opened for either of public profile, private profile, or domain profile of Windows Firewall. 

 
Example) 

When the profile for the Windows firewall is changed to the domain profile as a result the 
managed machine joined the domain, the port/program which is used by DPM will be 
blocked and the communication becomes impossible. 
Open the ports or programs used by DPM in Domain Profile in advance on the managed 
machine that joins domain or the master machine of OS installation by disk duplication. 
You can open the ports of the managed machine or programs in Domain Profile, following 
the procedure below. 
・ Setup by domain policy: 
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Specify in the domain policy of domain controller on Windows Server 2008/Windows 
Vista or later. 

・ Setup locally on the managed machine: 
(1) On the managed machine, from Inbound Rules of Windows Firewall with Advanced 

Security, right-click the following items and select Properties. 
・ DeploymentManager(DepAgent.exe) 
・ DeploymentManager(rupdsvc.exe) 
・ File and Printer Sharing (Echo Request - ICMPv4-In)(*) 

* For Windows Vista/Windows 7 
Network - Echo Request(ICMPv4-In) 

(2) In Advanced tab of Properties dialog, select Domain checkbox in Profiles. 
 For Windows Server 2003(SP1/SP2)/Windows Server 2003 R2, all connection request are 

blocked by secirity update(Post-Setup Security Updates:PSSU) until latest update program is 
applied. 
Update the managed machine to latest status by Windows Update and so on, or release 
PSSU manually. To release PSSU manually, log on by administrator and close the security 
update window. 
When you set the firewall service on the managed machine to automatic start, all ports are 
closed from when the machine is started to when the firewall service is started regardless of 
that the firewall function is enabled or disabled. At this timing, if you operate the following, the 
processing will fail. 
・ If you execute a scenario or shut down, an error occurs because the Management Server 

cannot communicate with the managed machine. 
In this case, after confirming that the managed machine is powered on the Web Console, 
execute a scenario or shut down. 

・ When the version and revision of DPM Client is not matched with that of DPM Server, 
automatic upgrade of DPM Client will be done. However, the automatic upgrade fails 
because the Management Server cannot communicate with the managed machine at this 
timing. 

In this case, upgrade by a scenario, see Section 3.3.2, "Manual Upgrading for DPM Client" in 
Installation Guide. 

 
・ Communication between the Database Server and the Management Server 
Item Database Server  Prot

ocol 
Conne
ction 
Directi
on 

Address 
Specifica
tion  

Management Server 
Execu
table 
File 
Name 

Port  
No. 

Availability 
of 
Modifying 
Port No. 

Port  
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Executa
ble File 
Name 

Database  26512 
*2*3 
 
5432 
*2*4 

Yes TCP <- Unicast *1 No apiserv.
exe 
bkressv
c.exe 
depssvc
.exe 
ftsvc.ex
e 
pxesvc.
exe 
rupdssv
c.exe 
schwatc
h.exe 

*1 
The port is assigned automatically. 
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*2 
When you change the port number, change before installing DPM Server newly. After that, you cannot 
change. 

*3 
When using SQL Server. 

*4 
When using PostgreSQL(When you configure PostgreSQL on the same machine of DPM Server). 

 
・ Communication between DHCP server and managed machines 
Item DHCP Server  Protocol Conne

ction 
Directi
on 

Address 
Specifica
tion 

Managed Machine 
Executa
ble File 
Name 

Port  
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Port  
No. 

Availabili
ty of 
Modifyin
g Port 
No. 

Exec
utabl
e 
File 
Nam
e 

Obtaining 
the IP 
address 

 67 No UDP 
(DHCP) 

<- Broadcast 
*1 

68 No  

 67 No UDP 
(DHCP) 

-> Broadcast 
*1 

68 No  

*1 
A packet relayed by DHCP relay may be addressed as Unicast. 

 
・ Communication between NFS Server and managed machines 
Item NFS Server  Protocol Conne

ction 
Directi
on 

Address 
Specifica
tion 

Managed Machine 
Executa
ble File 
Name 

Port 
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Port 
No. 

Availabili
ty of 
Modifyin
g Port 
No. 

Exe
cuta
ble 
File 
Nam
e 

OS Clear 
Installation 

 111 No TCP <- Unicast *1 No  
 111 No UDP <- Unicast *1 No  
 1048 

*2 
No TCP <- Unicast *1 No  

 1048 
*2 

No UDP <- Unicast *1 No  

 2049 No TCP <- Unicast *1 No  
 2049 No UDP <- Unicast *1 No  

*1 
The port is automatically assigned. 

*2 
There is a case that the port number might be changed automatically. when communication fails in, use 
"rpcinfo -p" command to check the port number being used by mountd (NFS mount daemon) service, 
and then open the port. If the problem is not solved by this procedure, turn off the Windows Firewall. 
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・ Communication between HTTP Server and the managed machine 
Item HTTP Server Protocol Conne

ction 
Directi
on 

Address 
Specifica
tion 

Managed Machine 
Execut
able 
File 
Name 

Port 
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Port 
No. 

Availa
bility 
of 
Modify
ing 
Port 
No. 

Executa
ble File 
Name 

OS Clear 
Installation 

 80 No TCP 
(HTTP) 

<- Unicast *1 No  

*1 
The port is automatically assigned. 
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・ Communication between FTP Server and the managed machine 
Item FTP Server Protocol Conne

ction 
Directi
on 

Address 
Specifica
tion 

Managed Machine 
Execut
able 
File 
Name 

Port 
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Port 
No. 

Availa
bility 
of 
Modify
ing 
Port 
No. 

Executa
ble File 
Name 

OS Clear 
Installation 

 21 Yes TCP 
(FTP) 

<- Unicast *1 No  

*1 
The port is automatically assigned. 

・ Communication between the Web Console and the Management Server 
Item Machine used for Web 

Console 
Protocol Conne

ction 
Directi
on 

Address 
Specific
ation 

Management Server *2 

Executa
ble File 
Name 

Port 
No. 

Availa
bility 
of 
Modify
ing 
Port 
No. 

Port 
No. 

Availa
bility 
of 
Modif
ying 
Port 
No. 

Executa
ble File 
Name 

Web 
Console 

 *1 No TCP 
(HTTP) 

-> Unicast 80 *3 Yes Web 
service 
(IIS) 

*1 
The port is automatically assigned. 

*2 
Because the Management Server uses the port (TCP:26500) for the internal processing (the 
communication between DPM Server and Web Service (IIS)), do not use this port by other applications. 

*3 
You can change the port to be used by the following procedure. 

Example) For IIS 7.5 
1) Select Administrative Tools -> Internet Information Services (IIS) Manager from Start menu. 
2) Internet Information Services (IIS) Manager screen appears. Right-click computer name -> Sites 

-> Web Site name on the tree view, and select Edit Bindings... and change the port number. 
 

・ Communication between Image Builder (Remote Console) and the Management Server 
Item Machine used for Image 

Builder (Remote Console) 
Protocol Con

necti
on 
Dire
ction 

Address 
Specifica
tion 

Manageme
nt Server 

Executa
ble File 
Name 

Port 
No. 

Availabi
lity of 
Modifyi
ng Port 
No. 

Port 
No. 

Availabi
lity of 
Modifyi
ng Port 
No. 

Execu
table 
File 
Name 

Image 
Builder 
(Remote 
Console) 

DIBuilde
.exe 

*1 No TCP -> Unicast 26508 
*2 

Yes ftsvc.e
xe 

*1 
The port is automatically assigned. 

*2 
When you upgrade DPM Server from the version earlier than DPM Ver6.1, the port before upgrading 
(56023) is taken over. 
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・ Communication between DPM Command Line and the Management Server 
Item Machine used for DPM 

Command Line 
Protocol Connec

tion 
Directio
n 

Addre
ss 
Specif
icatio
n 

Management Server *2 

Executa
ble File 
Name 

Port 
No. 

Availabi
lity of 
Modifyi
ng Port 
No. 

Port 
No. 

Availabi
lity of 
Modifyi
ng Port 
No. 

Execu
table 
File 
Name 

DPM 
Command 
Line 

dpmcmd
.exe 

*1 No TCP 
(HTTP) 

-> Unicas
t 

80 *3 Yes Web 
service 
(IIS) 

*1 
The port is automatically assigned. 

*2 
Because the Management Server uses the port (TCP:26500) for the internal processing (the 
communication between DPM Server and Web Service(IIS)), do not use this port by other applications. 

*3 
You can change the port to be used by the following procedure. 

Example) For IIS 7.5 
1) Select Administrative Tools -> Internet Information Services (IIS) Manager from Start menu. 
2) Internet Information Services (IIS) Manager screen appears. Right-click computer name -> Sites 

-> Web Site name on the tree view, and select Edit Bindings... and change the port number. 
 

Note: 
 Depending on the type of OS, the DPM service may not be able to start if there is a port conflict 

between the DPM service and other service or application causing by the Ephemeral port.  
See "Regarding ports used by DPM" of Section 2.2.1, "Network Environment" in First Step Guide 
for details of checking and handling problems with ephemeral ports. 

 For router and switch configuration, see the manual of the network device or contact the vendor. 
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Appendix E Log Files Output by DPM 
 
 DPM Server 

The following are logs which are output on the machine on which DPM Server is installed. 
 

Note: 
 In the machine on which DPM Server is installed, Image Builder and DPM Command Line are also 

installed. See also the description of Image Builder (Remote Console) and DPM Command Line 
below. 

 
Folder <DPM Server installation folder>\Log 

(Default: C:\Program Files (x86)\NEC\DeploymentManager\Log) 
File apiserv.csv 

apitrace.log 
bkressvc.csv 
DepInit.csv 
depssvc.csv 
DIBPkgMake.csv 
DPMDBIConfig.log 
ftsvc.csv 
pmdb.log 
pminfo.log 
pxemtftp.csv 
pxesvc.csv 
rupdssvc.csv 
schwatch.csv 
rupdssvc_managed machine MachineName_ managed machine 
MACAddress.log 

Output Content DPM Server trace log, monitor log, error information, database access log 
Recording Method The maximum size of apitrace.log is 1MByte. The maximum size of 

pmdb.log and pminfo.log is 128KByte.  
There is no limit of the file size for DPMDBIConfig.log. 
The maximum size of the other files is 10MByte. 
If the size of apitrace.log exceeds the maximum file size, the file is 
overwritten in order from the top location in the file. 
The pmdb.log and pminfo.log and rupdssvc_manmaged machine 
MachineName_managed machine MACAddress.log are managed by 2 
generations. (If the size exceeds the maximum file size, *.log.bak is 
deleted. The file name of *.log is renamed to *.log.bak.) 
The *.csv files are managed by 5 generations. 
(If the size of *.csv exceeds the maximum file size, *.csv.4 is deleted. The 
file name of *.csv n is renamed to *.csv.[n+1] and *.csv is renamed to 
*.csv.1.) 
Also, each file can be deleted manually. (Delete *.csv and apitrace.log 
manually after stopping the DPM services.) 

 
Folder <DPM Server installation folder>\DataFile\LogFile\SnrReport  

(Default: 
C:\Program Files (x86)\NEC\DeploymentManager\DataFile\LogFile\ 
SnrReport) 

File Scenario.rpt 
Output Content Scenario Execution Results 
Recording Method There is no restriction for the file size. 

Furthermore, you can delete it from the Web Console. (For delete 
procedure details, see Section 4.5.2, "Delete Log" in Web Console 
Reference Guide.) 
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Folder <DPM Server installation folder>\DataFile\LogFile\AuReport  

(Default: 
C:\Program Files (x86)\NEC\DeploymentManager\DataFile\LogFile\ 

AuReport) 
File Index.rpt 

managed machine MACaddress.rpt 
Output Content Execution log for automatic update (application automatic delivery) on a 

managed machine 
Recording Method Each managed machine is individually managed by MAC address. 

There is no restriction for the file size. 
The maximum record numbers of the logs can be set from the Web 
Console. 
 
According to the setting of maximum number of logs, if the log number 
exceeds it, the logs will be deleted from index.rpt file from the oldest in 
order, or 10% of the logs will be deleted from the oldest. 
 
For maximum number of log settings, see Section 4.7.2, "Maximum 
Number of Logs Settings" in Web Console Reference Guide. 
 
Furthermore, when the oldest log records from Index.rpt are deleted, the 
related information is deleted from managed machine MACaddress.rpt. 
Also, you can delete the log file from the Web Console. (For delete 
procedure details, see Section 4.7.4, "Delete Log" in Web Console 
Reference Guide.) 

 
Folder <DPM Server installation folder>\DataFile\JSLog 

(Default: 
C:\Program Files (x86)\NEC\DeploymentManager\DataFile\JSLog) 

File CmdSelfJSLog_YYYYMMDD.csv 
MngUserJSLog_YYYYMMDD.csv 
MngSelfJSLog_YYYYMMDD.csv 
 
* YYYYMMDD is a date. 

Output Content Monitor log (the user operations/DPM Server internal operations) 
Recording Method Each file is saved to a file dated to the current day. 

There is no restriction for the file size. 
The files dated to the current day cannot be deleted while DPM Services 
are running. Only those files whose dates have already passed can be 
deleted even if those services are running. Furthermore, a file is 
automatically deleted when 30 days have elapsed from the file creation 
date. 
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Folder <DPM Server installation folder>\WebServer\Logs 

(Default:  
C:\Program Files (x86)\NEC\DeploymentManager\WebServer\Logs) 

File Browser.log 
Error.log 
JSOX-Event.csv 
LibAPI.log 
Polling.log 
Trace.log 
WebConsole.log 

Output Content Web Console error notifications, traces, and monitor logs 
Recording Method The maximum size of Polling.log is 1MByte. The maximum size of the 

other files is 10MByte. 
 
Polling.log is increased in one file, and the JSOX-Event.csv file is 
managed by 2 generations. (If the size exceeds the maximum file size, 
the file name is renamed to JSOX-Event.csv.1, and the original 
JSOX-Event.csv.1 is deleted.) 
 
The other files are managed by 6 generations. (If the size of *.log 
exceeds the maximum file size, *.log.5 is deleted. The file name of  
*.log.n is renamed to *.log.[n+1], and *.log is renamed to *.log.1)  
Each file can also be deleted manually. 

 
Folder <Folder for Image>\upload\dpmupload 

(Default: C:\Deploy\upload\dpmupload) 
File managed machine MACaddress_B.zip 

managed machine MACaddress_B.Error.zip 
managed machine MACaddress_R.zip 
managed machine MACaddress_R.Error.zip 
managed machine MACaddress_P.zip 
managed machine MACaddress_P.Error.zip 
managed machine MACaddress.zip 
managed machine MACaddress_Error.zip 

Output Content managed machine-side results from execution of backup/restore/disk 
format check 

Recording Method Each managed machine is individually managed by MAC address. 
The maximum size of each file is approx. 310KByte + (the number of 
target disks * approx. 50KByte). 
In the case of the managed machine in UEFI mode, approx. 460KByte + 
(the number of target disks * approx. 50KByte). 
The file is overwritten each time a scenario is executed. 
You can delete each file manually. 
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Folder %SystemRoot% 

(Default: C:\WINDOWS)  
File Inst_Dpm_Db.log 

Inst_Dpm_Dbadmin.log 
Inst_DPM_Mng.log 
Inst_Dpm pgdb.log 

Output Content DPM Server installation log 
Recording Method There is no limit for the file size. 

Inst_Dpm_Db.log is overwritten each time DPM Server is installed, and 
the size does not increase after installing. Other files increase 
monotonically. Each file can be deleted manually. 
When you configure the Database Server, Inst_Dpm_Db.log, 
Inst_Dpm_Dbadmin.log and Inst_Dpm_pgdb.log are not created. 
When you configure SQL Server on the same machine of DPM Server,  
Inst_Dpm_Db.log and Inst_Dpm_Dbadmin.log are created. 
When you create PostgreSQL on the same machine of DPM Server, 
Inst_Dpm_pgdb.log is created. 

 
 Database Server(SQL Server) 

The following are logs which are output on the machine on which the database is installed. 
 
Folder <SQL Server installation folder>\MSSQL13.Instance name 

\MSSQL\Log 
(Default: 
C:\Program Files\Microsoft SQL Server\MSSQL13.Instance name 
\MSSQL\Log) 

File ERRORLOG 
log_n.trc (n is a number) 

Output Content SQL Server log 
Recording Method There is no limit for each file size. 

 
ERRORLOG is managed by 7 generations. (If SQL Server(Instance 
name) restarts, ERRORLOG.6 is deleted The file name of 
ERRORLOG.n is renamed ERRORLOG.[n+1] and ERRORLOG is 
renamed to ERRORLOG.1. 
log_n.trc is managed by 5 generations. (If SQL Server(Instance name) 
service is restarted at a state in which log_1.trc to log_5.trc exist, 
log_1.trc is deleted, and new log_6.trc is created.) 
 
ERRORLOG cannot be deleted. 
The log_n.trc cannot be deleted while SQL Server(Instance name) 
service is running. Past logs can be deleted even if the service is running. 
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 Database(PostgreSQL) 

The following are logs which are output on the machine on which the database is installed. 
 
Folder <PostgreSQL installation folder>\data\pg_log 

(Default:C:\Program Files\PostgreSQL\9.5\data\pg_log) 
<PostgreSQL installation folder>\data\pg_clog 
(Default:C:\Program Files\PostgreSQL\9.5\data\pg_clog) 
<PostgreSQL installation folder>\data\pg_xlog 
(Default:C:\Program Files\PostgreSQL\9.5\data\pg_xlog) 

File ・ pg_log 
postgresql-YYYY-MM-DD_hhmmss.log 
*YYYYMMDD represents a date, hhmmss is time 

・ pg_clog 
nnnn (n represents numeric character. File name is four-digit 
sequence number) 

・ pg_xlog 
nnnnnnnnnnnnnnnnnnnnnnnn (n represents numeric character. File 
name is 24 characters.) 

Output Content Log of PostgreSQL 
Recording Method There is no limit for each file size. 

You can delete each file manually. 
 

 DPM Client (Windows) 
The following are logs which are output on the managed machine on which DPM Client (Windows) is 
installed. 

 
Folder <DPM Client installation folder> 

(Default: C:\Program Files (x86)\NEC\DeploymentManager_Client) 
File DepAgent.log 

rupdsvc.log 
DPMTray.log 
GetBootServerIP.log 
WindowsChgIP.log 

Output Content DPM Client trace log 
Logs of Automatic Update Status Display Tool 
Logs of searching the Management Server by DPM Client 

Recording Method The maximum file size of DPMTray.log is 1MByte. The maximum file 
size of other files is 2MByte. 
If the size of DPMTray.log exceeds the maximum size of the file, all logs 
are cleared and the log is recorded newly. 
DepAgent.log, rupdsvc.log, GetBootServerIP.log, and 
WindowsChgIP.log are managed by 2 generations. (If the size exceeds 
the maximum file size, *.log.bak is deleted. The file name of *.log is 
changed to *.log.bak.) 
Each file can also be deleted manually. 

 
Folder %SystemRoot%\DeploymentManager\JSLog 

(Default: C:\WINDOWS\DeploymentManager\JSLog)  
File CliSelfJSLog_YYYYMMDD.csv 

* YYYYMMDD is a date. 
Output Content Monitor log (DPM Client internal operations) 
Recording Method There is no restriction for the file size. 

Saved to a file dated to the current day. 
Files dated to the current day cannot be deleted while DPM Services 
are running. Only those files whose dates have already passed can be 
deleted even if those services are running. The file is automatically 
deleted when 30 days have elapsed from the file creation date. 
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Folder %SystemRoot% 

(Default: C:\WINDOWS) 
File Inst_DPM_Win_Cli.log 

Inst_Dpm_Ports.log 
Output Content Install log of DPM Client 
Recording Method There is no limit of the file size on each file. Each time DPM Client is 

installed, the file size is increased monotonically. Each file can be deleted 
manually. 

 
 DPM Client (Linux) 

The following are logs which are output on the managed machine on which DPM Client (Linux) is installed. 
 

Folder /opt/dpmclient/agent/log 
File depinst.log 

depagtd.log 
GetBootServerIP.log 
LinuxChgIP.log 

Output Content Install log of DPM Client 
Trace log of DPM Client 
Logs of searching the Management Server by DPM Client 

Recording Method There is no limit for the file size in depinst.log, and the file is overwritten 
each time DPM Client is installed. 
The depagtd.log, GetBootServerIP.log, and LinuxChgIP.log are 
managed by 2 generations. (If the size exceeds the maximum file 
size(2MByte), *.log.bak is deleted. The file name of *.log. is renamed to 
*.log.bak.) 
The file can be deleted manually. 

 
 Image Builder 

The following are logs which are output on the machine on which Image Builder is installed. 
 

Folder <Image Builder installation folder>\DataFile\JSLog  
(Default:  
C:\Program Files (x86)\NEC\DeploymentManager\DataFile\JSLog) 

File ImgUserJSLog_YYYYMMDD.csv 
ImgSelfJSLog_YYYYMMDD.csv 

* YYYYMMDD is a date. 
Output Content Monitor log (operations performed by the user/Image Builder internal 

operations) 
Recording Method There is no limit for the file size, and each file is saved to a file dated to 

the current day. 
Files dated to the current day cannot be deleted while DPM Services are 
running. Thus, only those files whose dates have already passed can be 
manually deleted even if those services are running. The file is 
automatically deleted when 30 days have elapsed from the file creation 
date. 
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 DPM Command Line 

The following are logs which are output on the machine on which DPM Command Line is installed. 
 

Folder <DPM Command Line installation folder>\Log  
(Default: C:\Program Files (x86)\NEC\DeploymentManager\Log) 

File DPM_Trace1.csv 
Output Content Monitor log (operations performed by the user/DPM Command Line 

internal operations) 
Recording Method The maximum file size of DPM_Trace1.csv is 10MByte. 

It is managed by 10 generations. (If the size of DPM_Trace1.csv exceeds 
the maximum file size, DPM Trace10.csv is deleted. The file name of 
DPM Tracen.csv is renamed to DPM Trace [n+1].csv.) 
Each file can also be deleted manually. Files cannot be deleted while 
DPM Command Line is running. 

 



 

112 

 

Appendix F Procedure to Check the Version 
of Each Component 

 
 DPM Server 

Check the bottom (footer) of the Web Console. 
About starting the Web Console and logging into DPM, see from Section 5.1.1, "Starting the Web Console" 
to Section 5.1.2, "Logging into DPM" in Installation Guide. 

Example) DeploymentManager 6.6-XXXXX 
* XXXXX stands for the number. 

 
 DPM Client (Windows) 

1) Select Setting from displayed charm by pointing the mouse pointer at the top right corner (or the bottom 
right corner)of Windows desktop. 
Setting screen will be displayed. 
Select Control Panel->Program->Programs and Features. 

2) Select Views menu-> Choose Details. 
3) On the Choose Details screen, check the Version checkbox and click OK. 
4) Check the Version displayed on DeploymentManager. 

Example) 6.60.000 
 
 DPM Client (Linux) 

Execute the command below, and check the version displayed. 
cd /opt/dpmclient/agent/bin 
depagtd -v 

 
Example) DeploymentManager Ver6.6 

 
 Image Builder (Remote Console) 

1) Select Setting from displayed charm by pointing the mouse pointer at the top right corner (or the bottom 
right corner)of Windows desktop. 
Setting screen will be displayed. 
Select Control Panel->Program->Programs and Features. 

2) Select Views menu-> Choose Details. 
3) On the Choose Details screen, check the Version checkbox and click OK. 
4) Check the Version displayed on DeploymentManager (Image Builder). 

Example) 6.60.000 
 
 DPM Command Line 

1) Select Setting from displayed charm by pointing the mouse pointer at the top right corner (or the bottom 
right corner)of Windows desktop. 
Setting screen will be displayed. 
Select Control Panel->Program->Programs and Features. 

2) Select Views menu-> Choose Details. 
3) On the Choose Details screen, check the Version checkbox and click OK. 
4) Check the Version displayed on DeploymentManager (DPM Command Line). 

Example) 6.60.000 
 
 PackageDescriber 

1) Select Setting from displayed charm by pointing the mouse pointer at the top right corner (or the bottom 
right corner)of Windows desktop. 
Setting screen will be displayed. 
Select Control Panel->Program->Programs and Features. 

2) Select Views menu-> Choose Details. 
3) On the Choose Details screen, check the Version checkbox and click OK. 
4) Check the Version displayed on DPM PackageDescriber. 

Example) 6.60.000 
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Appendix G Glossary 
 
 Alphabetical order 
 

A 
 
 
 

Automatic Download Function which automatically downloads a new package from the Package Web 
Server to the Management Server at timing configured in advance. 

automatic update The managed machine checks the Management Server at timing configured in 
advance, if there has packages which has not been applied. It will send distribution 
request and automatically apply those packages. 

automatic update notice Notification that the Management Server issues to the managed machine so that 
automatic update can be executed in real time when a package of highest urgency 
is registered to the Management Server and when issuing automatic notification to 
the managed machine from Web Console. 

B  
 
 

Backup/Restore Function to backup or restore data contained on a disk by either disk unit or 
partition unit. 

D  
 
 

Deploy-OS A Linux OS (kernel) customized for DPM that runs on the managed machine. 
Deploy-OS is sent to the managed machine from the Management Server, and is 
deployed on the memory of the managed machine during backup/restore/disk 
configuration check. 
Furthermore, if operating DPM without using a DHCP server, Deploy-OS is 
included in the bootable CD. 

DHCP server DHCP (Dynamic Host Configuration Protocol) is a protocol that dynamically 
modifies the IP address. 
DHCP server refers to the machine or network device which has the functionality 
to provide configuration information by DHCP. 
In DPM, the DHCP server is used when a managed machine performs a PXE 
boot, or to assign an IP address during OS installation by disk duplication. 

Disk configuration 
check  

Function to check disk configuration before backup/restore is executed. You can 
check the disk number specified at the time of backup/restore. 

DPM Client DPM component. It runs on a managed machine and transfers data to DPM 
Server. Also controls the managed machines (shutdown and so on) and sends 
information such as package applied/not applied. 

DPM Command Line DPM component. It performs processing such as status check of the managed 
machine and scenario execution from the command line. 

DPM Server DPM component. It performs processing to the managed machine through Web 
Console operations or DPM Command Line. 

E  
 
 

Effective sector backup Backup of the only effective sectors of a hard disk. 

ESXi Virtualization software offered by VMware, Inc. 
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Express5800 Series Business-oriented workstation server offered by NEC. 

Full Sector backup Backup all sectors of hard disk. 

F  
 
 

File Operation Function to copy or overwrite the file on the Management Server to the arbitrary 
place on the managed machine. Also, you can see the detail information of files 
and folders on the managed machine and delete a file. 

G  
 
 

Guest OS The OS operating on the virtual machine. 

H  
 
 

Host OS Indicates the OS which is the infrastructure on which virtualization software runs. 

Hyper-V Microsoft virtualization software offered by Microsoft. 

I  
 
 

IIS Abbreviation for Internet Information Services, software for internet services 
offered by Microsoft. 

Image Builder Create packages, and disk duplication data files used by OS installation by disk 
duplication, and then registers them to the Management Server. 

Image Builder (Remote 
Console) 

Image Builder used on machine except the Management Server. 

Installation media Indicates the media bundled in DPM product. 

L 
 
 
 

LAN board Board used to connect to a LAN (Local Area Network). Also called NIC (Network 
Interface Card) or LAN adaptor. 

Local restoring Function to store a backup image file, which is created by DPM, in DVD(CD) 
media and restore the image only on the managed machine by using the media. 

M  
 
 
 

MAC Address Abbreviation for Media Access Control address, which is a fixed ID number for 
each LAN board. 
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Managed Machine Machine which managed by DPM. May be noted as Computer, Client, or Client 
Computer. 

Management Server The physical server that DPM Server is installed. 

Master Image Disk image of the machine which is the master of OS installation by disk 
duplication source. 

Master Machine The machine which is the master of OS installation by disk duplication source. 

O  
 
 

OS clear Installation Function that installs Red Hat Enterprise Linux while setting detailed 
configurations for the managed machine. 

OS installation by disk 
duplication 

Machine cloning function using Sysprep tools (master image creation tools) and 
DPM backup/restore functionality. 

P  
 
 

Package  The combination of patch, application or package application file. 
Created by either Image Builder or PackageDescriber. 

Package Information 
File 

File that basic information, execution information, applicable OS information, 
dependent information and identification information of a patch or an application 
are stored. 
Created by either Image Builder or PackageDescriber. 

Package Registration Upload a package created by PackageDescriber to the Package Web Server. 
Furthermore, the package needs to be re-uploaded if has been modified by 
PackageDescriber to the Package Web Server. 

Package Web Server  The web server which stores the packages. The Package Web Server can share 
packages for two or more Management Servers. Access should be allowed by 
HTTP protocol. 

PackageDescriber DPM component. A tool that creates packages and registers them to the Package 
Web Server. 

Patch Windows OS service packs and hotfixes released by Microsoft. 

PostgreSQL Open source object relational database management system. 

Store the data which DPM manages. 

 

PXE boot (network boot) Abbreviation for Preboot eXecution Environment boot. 
Booting method using PXE (network booting standard) by the LAN board to start 
the program through the network. 
It is used by DPM to detect a managed machine, or to execute backup/restore/disk 
configuration check or package distribution. 

R  
 
 

Remote update Installing service packs, hotfixes, Linux patch files, and applications, and 
applications 
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S  
 
 

Scenario  A configuration used to execute processing such as Distribution of floppy disk image 
for BIOS/firmware, OS clear installation, Installing service packs, hotfixes, Linux patch 
files, and applications, and backup/restore/disk configuration check. 

SigmaSystemCenter The management software of IT platforms including virtual environment. 
DPM is bundled into SSC software suit. 

SQL Server Relational model database server provided by Microsoft. The data of DPM is stored in 
SQL Server. 

Sysprep Windows OS deployment tool provided by Microsoft. 

V  
 
 

Virtual Machine Indicates the machines virtually run on the virtual machine server. 

VLAN Technology which builds a logical network, and then divides the network into two or 
more broadcast domains, unlike physically network configuration. 

W  
 
 

Web Console Checks the status of a managed machine and executes processing to a managed 
machine. 

WOL(Wake On LAN) Function which allows a machine connected to LAN to be turned on the power from 
another machine via network. 

X  
 
 

XenServer Virtualization software provided by Citrix. 
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Disclaimers 
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Copying or reproducing this document, in whole or in part, without the prior written approval of NEC is 
prohibited. 
The contents of this document are subject to change without notice. 
URL and the contents in URL in this document may be changed at any time without prior notice or explanation. 
NEC assumes no responsibility for any technical or editorial errors or omissions that may exist in this 
document. 
NEC does not guarantee the accuracy, usefulness, or completeness of the content or any other information 
provided in this document. 
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