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Introduction
Target Audience and Purpose
"Caution Notes and Trouble Shooting Reference Guide" is targeted to system administrators who operate
DeploymentManager (hereafter, DPM) and explains DPM operations on the screen, tools, maintenance-related
information, and troubleshooting.

Document Structure
・
・
・

1 Maintenance: Explains the maintenance information of DPM.
2 Precautions: Explains precautions about DPM.
3 Troubleshooting: Explains the method to handle error information of DPM.

Appendixes
Appendix A
Appendix B
Appendix C
Appendix D
Appendix E
Appendix F
Appendix G
Appendix H

Service List
Event Log
Error Information
Network Port and Protocol List
Log Files Output by DPM
Procedure to Check the Version of Each Component
Glossary
Revision History

Documentation Guidelines for DeploymentManager
Manuals
See "Documentation Guidelines for DeploymentManager Manuals" in First Step Guide.
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1.

Maintenance

This chapter explains the information about the maintenance of DPM.

1.1. Procedure to Change the IP Address of the
Management Server
Explains the procedure to change the IP address of the Management Server where DPM Server is installed while
operating DPM.
DPM Server does not work properly, if you do not follow the procedure.
When changing the IP address and network configuration at the same time, see
Section 3.5.1, "Edit Machine Group" in Web Console Reference Guide and
modify Network Setting of each group.
(1) Log on to the Management Server by a user with administrator authority.
(2) Check that all operations of DPM (the following) are completed or ended.
・ Operations for managed machines (scenario execution, automatic update, file distribution, file deletion
and obtaining the information in File/Folder List screen) are completed.
・ Web Console and various tools of DPM are ended.
(3) Change IP address of the Management Server.
(4) Restart the Management Server.
(5) When ANY is selected on IP address on Management view -> DPM Server -> Detail Setting -> General
tab on the Web Console, select again the IP address for DPM Server and click OK.
(6) Restart the managed machines.
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1.2. Procedure to Change the IP Address of the
Database Server
Explains the procedure to change the IP address of the Database Server while operating DPM.
(1) Log on to the Management Server by a user with administrator authority.
(2) Check that all operations of DPM (the following) are completed or ended.
・ Operations for managed machines (scenario execution, automatic update, file distribution, file deletion
and obtaining the information in File/Folder List screen) are completed.
・ Web Console and various tools of DPM are ended.
(3) Stop all services whose names begin with "DeploymentManager" from Start menu -> Management
Tools -> Services on the Management Server.
(4) Change the IP address on the Database Server.
(5) Select Run from Start menu on the Management Server. Enter "regedit" in the name of the program to
execute and click OK.
(6) Registry editor is launched. Change the value in the Name of the following registry to the changed IP
address of the Database Server.
・ Key:
- When OS is x86
HKEY_LOCAL_MACHINE\SOFTWARE\NEC\DeploymentManager
- When OS is x64
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NEC\DeploymentManager
・ Name: DBSrvIPAddress
(7) Start ODBC Data Source Administrator screen following the procedure below.
- When OS is x86
From Start menu, select Management Tools -> Data Source(ODBC).
- When OS is x64
1) From Start menu, select Run. Enter "%WINDIR%\SysWOW64\cmd.exe" and click OK.
2) The command prompt appears. Execute the following command.
%WINDIR%\SysWOW64\odbcad32.exe
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(8) ODBC Data Source Administrator screen appears. After selecting System DNS tab, select DPM from
the list of System Data Source and click Configure.

(9) The following screen appears. Select the Database Server in Server of Which SQL Server do you
want to connect to? in addition, change it to IP address. Port of the Database Server after
changing\Instance name and click Finish.

(10) Start all services, which were stopped in Step (3) on the Management Server.
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1.3. Procedure to Change the IP Address of the
Managed Machine
If IP address of the managed machine is changed, the Management Server is notified automatically. It is not
necessary to do further action.
However, when changing IP address of the Management Server and IP address of managed machine at the
same time, the Management Server is not notified automatically. In this case, see "Upgrading DPM Client by
installation media" in Section 3.3.2, "Manual Upgrading for DPM Client" in Installation Guide to reconfigure the IP
address of the Management Server in DPM Client.
In addition, when DPM Client is not installed in the managed machine, the Management Server is not notified. In
this case, see Section 3.7.2, "Edit Managed Machine" in Web Console Reference Guide to reconfigure IP
address information of the managed machine.
It is recommended that you execute the backup scenario after changing IP address of the managed machine. If
you restore the backup image before changing the IP address, the content of the disk is return to the original
when executing the backup and IP address will be one before changing it.

1.4. Data Backup Plan
1.4.1.

Data Backup Procedure

Explains the procedure to backup the data while operating DPM.
(1) Log on to the Management Server by a user with administrator authority.
When you configure the database on the same machine with DPM Server, log on by the user who installed
DPM Server.
(2) When you changed detailed settings of DPM Server after installing DPM Server, select Management view
-> DPM Server icon -> Detailed Setting on the Web Console and note the displayed setting values.
(3) Check that all operations of DPM (the following) are completed or ended.
・ Operations for managed machines(scenario execution, automatic update, file distribution, file deletion and
obtaining the information in File/Folder List screen) are completed.
・ Web Console and various tools of DPM are ended.
(4) From Start menu, select Administrative Tools -> Services and stop all services whose names begin with
"DeploymentManager".
(5) Backup the data.
Backup the following data.
・ All files under <DPM Server installation folder>\Datafile
・ All files under <DPM Server installation folder>\Linux
・ All files under <DPM Server installation folder>\Log
・ <DPM Server installation folder>\WebServer\App_Data\Data
- Encypted.dat
- DpmProfile.xml
The default installation folder of DPM Server is:
"C:\Program Files\NEC\DeploymentManager".
・ All files under Folder for Image
Select Management view -> DPM Server -> Detail Setting -> General tab on the Web
Console and check Folder for Image of Image Setting. The default of Folder for
Image is "C:\Deploy".
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・ All files under Folder for Backup Image
Select Management view -> DPM Server -> Detail Setting -> General tab on the Web
Console and check Folder for Backup Image of Image Setting. The default of Folder
for Backup Image is "C:\DeployBackup".
・ The following folders and files under TFTP root folder
- backup
- DOSFD
- EFI64
- EFIBC
- EFIIA32
- gpxelinux
- HW
- HW64
- hwinfo
- kernel
- NBP
- probe
- pxelinux
- pxelinux.cfg
- uefipxelinux
- nbprestvar.ini
- Port.ini
When you configure the cooperation of TFTP service between DPM Server and
MasterScope Network Manager, see Appendix F, "Configuring DPM Server and
MasterScope Network Manager on the Same Machine" in Installation Guide, TFTP
root folder is <TFTP root folder of MasterScope Network Manager>.
The default of TFTP root folder is
"C:\Program Files\NEC\DeploymentManager\PXE\Images".
・ Others
Files or registries when you changed them manually
(6) Backup the database.
Enter the following backup command on the command prompt, and then extract the backup file
(DPM.bak).
When you configure the Database Server, log on by the user who configured the database on the
Database Server and execute the following.
sqlcmd.exe -E -S localhost\Instance name
BACKUP DATABASE DPM
TO DISK='DPM.bak'
WITH INIT
GO
Example)
sqlcmd.exe -E -S localhost\DPMDBI
BACKUP DATABASE DPM
TO DISK='DPM.bak'
WITH INIT
GO
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 The database name is "DPM".(Fixed)
 A backup file (DPM.bak) is created in the following folder:
<Microsoft SQL Server installation folder>\Backup
The default of <Microsoft SQL Server installation folder> is
C:\Program Files\Microsoft SQL Server\MSSQL12.Instance name\MSSQL
(7) Backup the registry data.
・ DPM Server
By executing the following command on the command prompt, extract the backup file
(RegExportDPM.reg).
(The following command is described in two or more lines. Enter it by one line in the actual screen.)
- When OS is x86
regedit /e RegExportDPM.reg
"HKEY_LOCAL_MACHINE\SOFTWARE\NEC\DeploymentManager"
- When OS is x64
regedit/eRegExportDPM.reg"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NEC\
DeploymentManager"
・ Database
By executing the following command on the command prompt, extract the backup file
(RegExportDPMDB.reg).
When you configure the Database Server, log on by the user who configured the database on the
Database Server and execute the following.
(The following command is described in two or more lines. Enter it by one line in the actual screen.)
- When OS is x86
regedit /e RegExportDPMDB.reg "HKEY_LOCAL_MACHINE\SOFTWARE\NEC
\DeploymentManager_DB"
- When OS is x64
regedit/eRegExportDPMDB.reg"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\NEC\De
ploymentManager_DB"
Backup files(RegExportDPM.reg and RegExportDPMDB.reg) will be created in the
folder where the command is executed.
(8) Start all services that were stopped in Step (4).
The backup of data updated while operating DPM is completed.

1.4.2.

Data Recover Procedure

Recover the DPM environment by the data which were backed up in Section 1.4.1, "Data Backup Procedure",
following the procedure below.
(1) Log on to the Management Server by a user with administrator authority.
When you only recover the data (DPM Server is already installed) and configure the database on the same
machine with DPM Server, log on by the user who installed DPM Server.
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When you configure the database on the same machine with DPM Server, it is
recommended that you log on by Administrator and install DPM Server. When you
installed DPM Server by a user with administrator authority except Administrator, you
need to launch Image Builder, which is installed on the same machine with DPM
Server, as an administrator.
(2) Install DPM Server and configure the detailed setting.
・ When you install DPM Server and recover
Install DPM Server(and configure the detailed setting), following the description below.
- Installation Guide
- Setting values that you noted when you installed DPM Server
If there are setting values that you noted in Step (2) of Section 1.4.1, "Data Backup Procedure" about
the setting in Detailed Setting screen displayed when installing DPM Server, enter the values.
・ When you only recover the data (DPM Server is already installed.)
Configure the setting values that you noted in Step (2) of Section 1.4.1, "Data Backup Procedure", in
Management view -> DPM Server icon -> Detailed Setting on the Web Console.
If you have not changed the detailed setting after installing DPM Server, configure the setting that you
noted when installing DPM Server.
(3) From Start menu, select Administrative Tools -> Services and stop all services whose names begin with
"DeploymentManager".
(4) Overwrite the same folder or file path as when you backed up by the backup data that were collected in Step
(5) of Section 1.4.1, "Data Backup Procedure".
Also, configure the noted setting when there are the setting that you noted in Step (5) "Others" of Section
1.4.1, "Data Backup Procedure"
(5) Copy the backup file of database, which has been obtained at step (6) in section 1.4.1 "Data Backup
Procedure" onto the same folder path when you performed back up.
When you configure the Database Server, log on by the user who configured the database on the Database
Server to execute.
(6) Confirm the configuration of the database.
When you configure the Database Server, log on by the user who configured the database on the Database
Server and execute the following.
1) From Explorer and others, display the property of DPM.bak and confirm whether the user whose name
that start with "MSSQL$Instance name" on Security tab exists or not.
2) Click Detailed Setting tab, and if there is a user whose name starts with "MSSQL$Instance name" in 1),
confirm whether the Include inheritable permissions from this object's parent checkbox is selected
or not.
If there is no user whose name starts with "MSSQL$Instance name" in 1), select the Include
inheritable permissions from this object's parent checkbox. (If this checkbox is selected, a user
whose name begins with " MSSQL$Instance name" will be added to the Security tab.)
(7) Start the command prompt, and then execute the following command.
When you configure the Database Server, log on by the user who configured the database on the Database
Server and execute the following.
sqlcmd.exe -E -S localhost\Instance name
RESTORE DATABASE DPM
FROM DISK = 'DPM.bak'
WITH REPLACE
GO
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Example)
sqlcmd.exe -E -S localhost\DPMDBI
RESTORE DATABASE DPM
FROM DISK = 'DPM.bak'
WITH REPLACE
GO
(8) Apply the backup file of the registry data extracted in Step (7) of Section 1.4.1, "Data Backup Procedure" on
the machine that you backed up. (Double-click from Explorer.)
(9) Start all services that were stopped in Step (3).
(10) Start the command prompt and execute the following command.
iisreset /restart
Recovering DPM data is completed.

1.5. Port Change Procedure on DPM
The section explains the procedure to change the port used by DPM.
 If you do not follow the procedure, the Management Server and managed machines
do not work properly.
 When you change the port used by ftsvc.exe (TCP:26508) following this procedure,
specify the same port in the Setting Connection screen of Image Builder (Remote
Console).
 When you install DPM Server of this version newly, DPM Client of the version earlier
than DPM Ver6.1 cannot be upgraded automatically.
Execute the either of the following.
・ Before you install DPM Server newly, set the port, which was used before
upgrading, in Port.ini following the procedure in this section.
・ After you installed DPM Server newly, upgrade DPM Client by a scenario, see
Section 3.3.2, "Manual Upgrading for DPM Client" in Installation Guide. (It takes
about 20 minutes until the scenario is completed.)
 The master image for OS installation by disk duplication, created in the version earlier
than DPM Ver6.1, cannot be used in the environment that DPM Server of this version
is installed newly. Re-create a master image in this version, or set the port, which was
used before upgrading, in Port.ini following the procedure in this section, before you
install DPM Server newly.
The default values of the ports to be used differ in the version earlier than DPM Ver6.1.
For details of the port number, see Appendix D, "Network Port and Protocol List."
 The procedure to change the port before installing DPM Server newly.
(1) Log on to the Management Server by a user with administrator authority.
(2) Copy the following file to %SystemDrive%( Default C:)\DPMPort\.
<Installation media>:\DPM\Setup\DPM\Port.ini
(3) Specify the port to use in the copied file and save the file.
(4) Install DPM Server newly.
When you upgrade DPM Server, the ports, which were used before upgrading, are taken
over.
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 The procedure to change the port after installing DPM Server.
Execute the following procedure on the Management Server.
(1) Log on to the Management Server by a user with administrator authority.
(2) Check that all following DPM operations are completed.
・ Operations which are being executed for managed machine(scenario execution, automatic update, file
distribution, file deletion, and obtaining the information in File/Folder List screen) are completed.
・ Web Console and each tool of DPM are ended.
(3) Edit <TFTP root folder>\Port.ini.
 The default of TFTP root folder is
"C:\Program Files\NEC\DeploymentManager\PXE\Images".
 When you change the port for Web Service (Default:26500), modify the following line
in <TFTP root folder>\WebServer\App_Data\Config\MgrServerList.xml.
<Port>The port to change</Port>
(4) Restart the Management Server.
(5) Restart managed machines.

2.

Precautions

This chapter explains precautions for DPM.

2.1. Notes for Device and Storage
2.1.1.

The Module for the Machine Model

The module for the machine model is the update module enables the machine model not supported by
Deploy-OS which is included as standard to the managed machine.
For notes about the module for the machine model, contact your sales or support representative.

2.2. Notes when You Change the Computer Name
(the Host Name) of the Management Server and
the Managed Machine
You can change the computer name (the host name) on the OS of the Management Server and the managed
machine at any timing.
When you use the host name in the URL on the Web Console, change it to match with the computer name of the
Management Server,
When you changed the computer name (the host name) of the managed machine, if you restore the backup
image before changing the computer name (the host name), the content of the disk is returned to the original
status when executing the backup and the computer name (the host name) will be one before changing it. It is
recommended that you execute the backup after changing the name.
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2.3. Notes when You Change the User Name/the
Password on the OS of the Management Server
and the Managed Machine
When you change the user name/the password on the OS of the Management Server and the managed machine,
it does not affect the operation later.
However, if you restore the backup image before changing the user name/the password on the OS of the
managed machine, the content of the disk is returned to the original status when executing the backup and the
user name/the password will be one before changing it. It is recommended that you execute the backup after
changing the user name/the password.

2.4. Notes for OS Clear Installation
When you cannot set up NFS server, you can execute OS clear installation of Red Hat Enterprise Linux 6 by
setting up FTP/HTTP server on the Management Server.
This chapter explains notes about the case. In addition ,explains as the folder for image has the following
configuration.
Management Server(IP address:192.168.0.1)
Folder for image
AnsFile\
Linux\
Boot parameter file
exports\
ks\
Install parameter file
Boot directory (Boot directory name: RHEL6)
Install image
daemon\
・ See Section 3.5.1, "Creating and Registering an Image" in Operation Guide, create and register an image.
Replace as the following about Section 3.5.1.1, 'Setting up NFS Service".
Seeing manuals of FTP/HTTP server and so on, set "exports" folder under Folder for Image set on the Web
Console as the virtual directory of FTP/HTTP server after configuring FTP/HTTP server,
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・ Perform the following before the procedure of Section 3.5.2, "Creating a Scenario" in Operation Guide.
- Open the boot parameter file by text editor and so on and modify the description of the file
server(underlined) following the environment, seeing the following example.
Example)
Before modification:
append initrd= RHEL6/initrd.img ks=nfs:192.168.0.1:/exports/ks/ks.cfg ksdevice=eth0
After modification:
- In the case of FTP server
append initrd= RHEL6/initrd.img ks=ftp://192.168.0.1/exports/ks/ks.cfg ksdevice=eth0
- In the case of HTTP server
append initrd= RHEL6/initrd.img ks=http://192.168.0.1/exports/ks/ks.cfg ksdevice=eth0
- Open the installation parameter file by text editor and so on, modify the description of the file
server(underlined) following the environment, seeing the following example.
Example)
Before modification:
...
nfs --server 192.168.0.1 --dir /exports/RHEL6
...
#Mount /mnt/exports
mkdir /mnt
mkdir /mnt/exports
/bin/mount -o nolock -t nfs $NFSSERVER:/exports /mnt/exports
...
After modification:
- In the case of FTP server
...
url -url ftp://192.168.0.1/exports/RHEL6
...
#Mount /mnt/exports
mkdir -p /mnt/exports/daemon/redhatall/ia32/
cd /mnt/exports/daemon/redhatall/ia32/
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depagt
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depagtd
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depagtd.res
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depcancel
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depinst
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depinst.res
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/depinst.sh
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/dpmversion.inf
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/GetBootServerIP
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/getinfo.sh
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/server.inf
wget ftp://192.168.0.1/exports/daemon/redhatall/ia32/xdpmmsg
...
- In the case of HTTP server
...
url -url http://192.168.0.1/exports/RHEL6
...
#Mount /mnt/exports
mkdir -p /mnt/exports/daemon/redhatall/ia32/
cd /mnt/exports/daemon/redhatall/ia32/
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depagt
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depagtd
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depagtd.res
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depcancel
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depinst
wget http://192.168.0.1/exports/daemon/redhatall/ia32/depinst.res
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wget http://192.168.0.1/exports/daemon/redhatall/ia32/depinst.sh
wget http://192.168.0.1/exports/daemon/redhatall/ia32/dpmversion.inf
wget http://192.168.0.1/exports/daemon/redhatall/ia32/GetBootServerIP
wget http://192.168.0.1/exports/daemon/redhatall/ia32/getinfo.sh
wget http://192.168.0.1/exports/daemon/redhatall/ia32/server.inf
wget http://192.168.0.1/exports/daemon/redhatall/ia32/xdpmmsg
...
- Mount ISO file for installation of Red Hat Enterprise Linux 6 and copy all the contents in ISO to the
boot directory.

3.

Troubleshooting

This chapter explains how to handle when the problem occurs on DPM.

3.1. Web Console
When you click Detail under HotFix/Application on the Machine Detail screen, the
HotFix/Application List screen items are not displayed.
To manage the managed machine in this version, DPM Client for this version must
be installed on the managed machine. If it is already installed, reinstall. About the
installation, see Section 2.2, "Installing DPM Client" in Installation Guide.
From Start menu on the managed machine, select Administrative Tools ->
Services, and confirm that DeploymentManager Agent Service and
DeploymentManager Remote Update Service Client are running.
The screen Socket error has occurred. is displayed when you update information. Or, the
following message is displayed as detailed information:
No connection could be made because the target machine actively refused
it. Management Server IP address:26500
The Management Server may be shut down. From Start menu, select
Administrative Tools -> Services and confirm that all of the services listed in
" DPM Server" in Appendix A, "Service List" are running.
If the service is stopped, start all of the services that are not running. Furthermore,
try to reconnect to Management Server after services started.
If you start the Web Console from the Web browser, error The Page cannot be displayed
appears.
One of the following is possible:
・ The URL to start the Web Console may be incorrect. Confirm that the URL is
correct.
・ The Web Site might not be running. From Start menu, select Administrative
Tools -> Internet Information Services (IIS) Manager, and confirm that Default
Web Site is running.
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If you access the Web Console from two or more windows or tabs(Only tabs in the case of
Internet Explorer 7), the following occurs due to the session sharing function of Internet
Explorer.
・ The user authority of the Web Console will be the same with the authority of the user
who logged last.
・ An error occurs when you switch the page in window or tab that you opened first, or
change the number of lines to be displayed.
When you open two or more Web Consoles, separate sessions in the following
procedure.
・ For Internet Explorer 8/9/10/11(compatibility mode)
Launch Internet Explorer as new session and open the Web Console. To launch
Internet Explorer as new session, select File -> New Session in Internet Explorer
which is already launched.
・ For Internet Explorer 7
Open the Web Console in another window.
Start the Web Console on Windows Server 2003/Windows Server 2003 R2 and the
following message is displayed each time the screen switches.

Click OK.
Something is wrong with the display of the error message.
If you use an HTML tag (<xx>) for a computer name or group name and so on, the
entered text is interpreted as HTML syntax and may not be properly displayed in the
error message. However, operations are not affected.
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Even if you start the Web Console from the Web browser, nothing is displayed on the Web
browser.
The following is possible :
・ From Tools menu -> Internet Options in Internet Explorer, select Trusted Sites
on the Security tab. After clicking Sites, add a URL which connects to the
Management Server.
Example) If the Management Server IP address is 192.168.2.41

If you start the Web Console on Windows Server 2003/Windows Server 2003 R2, the
following message is displayed:

Confirm that the URL is not wrong, and then click Add and add the Web site to the
Trusted Sites zone.
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You performed one of the following operations, however the File Download screen is not
displayed, and you could not download CSV files.
・ On the Monitor view -> Scenario Execution Result List -> Scenario Execution
Result List
screen, click Save In CSV in Operation menu.
・ On the Monitor view -> Automatic Update Result List -> Automatic Update Result
List screen, click Save In CSV in Operation menu.
・ On the Operations view -> Group List screen, click Export Machine Data in
Configuration menu.
Check security setting on Internet Explorer.
Select the Internet Explorer Tools menu -> Internet Options, then click Security
tab -> Security
level for this zone -> Custom level button, and configure as follows:
・ Set Enable from Downloads - File download.
・ Set Enable from Downloads - Automatically prompting for file
downloads.(Only Internet Explorer 7/8.)
The Web Console cannot be started. In the screen, "Internet Explorer cannot display the
webpage" is displayed.
Web Server may not be running. From Start menu, select Administrative Tools ->
Internet Information Services (IIS) Manager and confirm whether Default Web
Site is launched.
Anonymous access of IIS may be disabled. Change the setting as following.
(1) From Start menu, select Administrative Tools -> Internet Information
Services (IIS) Manager.
(2) Internet Information Services (IIS) Manager screen appears. Click DPM
directly under
Default Web Site in the left side of the screen.
(3) Select Authentication in IIS in the center of the screen and click Open
Feature in Actions in the right of the screen.
(4) Select Anonymous Authentication in Authentication screen in the center of
the screen and click Edit... in Actions in the right of the screen.
(5) Edit anonymous authentication qualification information appears. Confirm
whether Specific User is selected and the user name is "IUSR". If it is not
"IUSR", click Setting and set "IUSR" in the user name.
(6) Close the screen by clicking OK in Anonymous authentication qualification
information.
(7) Select Anonymous Authentication in Authentication screen and click
Enabled in Actions in the right of the screen.
When you open the Web Console screen (such as Add Machine screen or Add Scenario
screen) the characters displayed on the screen are garbled.
This may be avoided by turning off Auto-Select of Encoding on Internet Explorer.
You can set OFF by clearing View menu -> Encoding -> Auto-Select.
On the Backup/Restore tab of the scenario, you click Browse on the Image File and a
network drive or USB hard disk is not displayed.
Only local disk is displayed as a drive. When you specify a network drive or USB
hard disk, enter the image file path on Image File text box directly.
See Section 3.13.4, "Backup/Restore Tab" in Web Console Reference Guide for the
detail.
The MAC address of the managed machine is not displayed on the Web Console.
The MAC address may not be displayed temporarily because of replacing LAN
board to other machines and so on.
If such a phenomenon occurs, manually reboot the managed machine.
If the phenomenon occurs after reboot, delete the corresponding managed machine
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from the Web Console and then reregister.
* When the MAC address of the managed machine is not displayed, you cannot
perform the following
operations:
・ Set the Automatic Update Time for the managed machine
・ Obtain the power status
・ Obtain the managed machine information
・ Execute Scenario
・ Power ON
・ Shutdown
The MAC address for a managed machine running on Linux OS and mounted with
two or more LAN boards may not be displayed during operation.
In such a case, the corresponding managed machine may be registered to a New
Machine group. Delete the corresponding managed machine from the New Machine
group, and then reboot DPM Client on the managed machine. If the phenomenon
occurs after reboot, delete the corresponding managed machine from the Web
Console and then reregister.
After a certain amount of time passes without any operation, the display of the Web
Console is returned to Deployment Manager Login screen at the next operation.
If session timeout occurs on the Web Console, the display is returned to
Deployment Manager Login screen. Login again.
You can change the setting of timeout by the following procedure.
(1) From Start menu, select Administrative Tools -> Internet Information
Services (IIS) Manager.
(2) Internet Information Services (IIS) Manager screen appears. Click
Application Pools in the left side of the screen.
(3) Select DeploymentManagerPool in Application Pools in the center of the
screen and click Stop in Application Pool Task in the right side of the screen.
* For Windows Server2008 and Windows Sever 2008 R2,select "SP.NET v4.0
DeploymentManagerPool ".
(4) Click Default Web Site in the left side of the screen and click Stop in Manage
Web Site in the right of the screen.
(5) Click DPM directly under Default Web Site in the left side of the screen and
select Session State in ASP.NET in the center of the screen. Click Open
Feature in Actions in the right side of the screen.
(6) Specify the value of timeout in Cookie Settings -> Time-out (in
minutes)(O)(The default is 20 minutes) in Session State screen in the center
of the screen. Click Apply in Actions in the right side of the screen.
(7) Click DPM directly under Default Web Site in the left side of the screen. Select
Authentication of IIS in the center of the screen. Click Open Feature in
Actions in the right side of the screen.
(8) Select Forms Authentication in Authentication screen in the center of the
screen. Click Edit... in Actions in the right side of the screen.
(9) Edit Forms Authentication Settings screen appears. Specify the value of
timeout in Authentication cookie time-out (in minutes)(O)(The default is 30
minutes). Click OK.
(10) Click Application Pools in the left side of the screen. Select
DeploymentManagerPool in Application Pools in the center of the screen.
Click Advanced Setting in Edit Application Pools in the right side of the
screen.
* For Windows Server 2008/Windows Server 2008 R2, select " SP.NET v4.0
DeploymentManagerPool ".
(11) Advanced Settings screen appears. Specify the value of timeout in the
following 2 items. Click OK.
Process Model - Timeout in idle status(minute) (The default is 20 minutes)
Recycle - Periodic Interval (minute) (The default is 1740 minutes)
(12) Click Start in Application Pool Task in the right side of the screen.
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(13) Click Default Web Site in the left side of the screen and click Start in Manage
Web Site in the right side of the screen.

3.2. Management Server
When you set different machines as DHCP server and the Management Server, you cannot
obtain the MAC address for the managed machine.
The DHCP service on the Management Server may still be running. On the
Management Server, from Start menu, select Administrative Tools -> Services,
and confirm that Status under DHCP Server is not Started. If it is Started, open the
Properties screen, disable Startup type, and stop the service.
In Detail Setting, the DHCP server is installed on an another machine checkbox
may not be checked. Select Management view -> DPM Server -> Detail Setting on
the Web Console, click the DHCP Server tab, and confirm that the DHCP server is
installed on an another machine checkbox is checked. If the checkbox is not
selected, select it and click OK, and then reboot the Management Server. (If the
Management Server cannot be rebooted, stop all services listed in Appendix A,
"Service List" by selecting Administrative Tools -> Services from Start menu, and
then start all of the stopped services.)
DPM Server services are not running.
A service may terminate if an error occurs during scenario execution.
If a scenario is executing, wait until it completes and then perform the following
operations.
From Start menu, select Administrative Tools -> Services on the Management
Server, and then restart the following services.
(Start if the service is stopped.)
DeploymentManager API Service
DeploymentManager Backup/Restore Management
DeploymentManager Get Client Information
DeploymentManager PXE Management
DeploymentManager PXE Mtftp (Restart is not needed when startup type is
disabled.)
DeploymentManager Remote Update Service
DeploymentManager Schedule Management
DeploymentManager Transfer Management
By performing an overwrite installation of DPM Server, it will be recovered.
You cannot start the DeploymentManager API Service .
Port (TCP:56050/26500) may be in use by other applications and so on.
When Port(TCP:56050/26500) is used by other application, change the setting for
the port number of either DPM or other application.
If you change the port number of DPM, see Section 1.5 "Port Change Procedure on
DPM".
You cannot start the DeploymentManager Remote Update Service .
Furthermore, the following error log is listed in <DPM Server installation
folder>\Log\rupdssvc.csv :
"RUPDSSVC: FUNCTION: CreateSocket(): bind Failed, error code=10048"
Port (TCP:56024/26506, TCP:56028/26507) may be in use by other applications and
so on.
When Port(TCP:56024/26506, TCP:56028/26507) is used by other application,
change the setting for port number of either DPM or other application.
If you change the port number of DPM, see Section 1.5 "Port Change Procedure on
DPM".
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If you uninstall and then install DPM Server, scenarios and groups existing before the
uninstall still remain.
The uninstallation may not be performed properly. Follow the procedure below to
reinstall:
(1) Perform uninstall again.
(2) Reboot the machine installed with DPM Server.
(3) Delete the contents under the folder installed with DPM Server and the Folder
for Image
(the defaults are C:\Program Files\NEC\DeploymentManager and C:\Deploy).
(4) Install again.
If you perform an overwrite installation after interrupting uninstall, an error message
appears and you cannot overwrite.
Install DPM Server newly after uninstalling completely.
There is no response even if you execute DPM Server silent installation.
The network connection may not have been detectable.
After confirming the network environment, install DPM Server again.
Following message is displayed when DPM Server installation, and fail in installation.
"Failed to install DPM Server(DB)."
When Microsoft SQL Server2012 Native Client is already installed, there is a
possibility installation of DPM Server might fail in.
Uninstall Microsoft SQL Server 2012 Clienent and reinstall DPM Server.
When "`" is included in the folder path where DPM Server is installed, "It failed to set
DSN." is displayed and fail in overwriting.
Overwrite installation DPM Sever again after installing Microsoft SQL Server
2012 Native Client by following steps.
1) Copy below file to arbitrary (C:\).
・ For x86:
<Installation media>: \DPM\Setup\SQLNCLI\sqlncli_x86.msi
・ For x64:
<Installation media>:\DPM\Setup\SQLNCLI\sqlncli_x64.msi
2) Rename the copied file to "sqlncli.msi ".
3) Execute "sqlncli.msi ".
4) Delete copied file after execution.

3.3. Managed Machine
The standby function did not appear when you terminate the managed machine.
Check the following:
・ If the Terminal Service is enabled, you cannot use the standby function. From
the control panel, disable the Terminal Service.
・ Unless the device driver and so on are properly installed, the standby function
cannot be used.
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If you used Remote Desktop to perform installation, upgrading, or uninstallation of DPM
Client, the following message was displayed:
The following error occurred on the file, xxxxx\DepAgent.dll.
Access is denied.
(0x5)
* xxxxx is a (variable) file path.
If installation, upgrading, or uninstallation is performed while Event viewer on the
managed machine is open, the above message may be displayed.
To Install/Upgrade Install/Uninstall, after selecting the Ignore button and closing the
above message, reboot the managed machine and re-execute.
For Uninstall, the DepAgent.dll file is automatically deleted after the machine
restarts, so it is not necessary to re-execute.
You cannot start DeploymentManager Remote Update Service Client service.
Furthermore, the following error log is listed in rupdsvc.log.
* rupdsvc.log is located in the following folder:
・ For x86: C:\Program Files\NEC\DeploymentManager_Client\
・ For x64: C:\Program Files (x86)\NEC\DeploymentManager_Client\
RUPDSVC: bind() failed, code = 10048
Port (TCP:56000/26510, TCP:56025/26511) may be in use by other applications and
so on.
When Port(TCP:56000/26510, TCP:56025/26511) is used by other application,
change the setting for port number of either DPM or other application.
If you change the port number of DPM, see Section 1.5 "Port Change Procedure on
DPM".
You cannot start DeploymentManager Update Service Client service.
Furthermore, the following error log is listed in rupdsvc.log.
* rupdsvc.log is located in the following folder:
・ For x86: C:\Program Files\NEC\DeploymentManager_Client\
・ For x64: C:\Program Files (x86)\NEC\DeploymentManager_Client\
"Multicast receive socket create error, code = 10048"
Port (UDP:56001/26529) may be in use by other applications and so on.
When Port(TCP:56001/26529) is used by other application, change the setting for
port number of either DPM or other application.
If you change the port number of DPM, please refer 1.5 "Port Change Procedure on
DPM".
Joining a managed machine of Windows Server 2008/Windows Vista or later to the domain
will initialize the setting of Firewall and enable it.
This happens when the domain security policy is undefined in the domain server.
Define the domain security policy before joining to the domain.
You cannot WOL (Wake On LAN) remotely the managed machine.
Confirm followings.
・ Refer the manual for the hardware and enable the setting of WOL and network boot
to the managed machine.
・ WOL with on-board LAN is correspond to DPM.
・ There is a possibility when turning off the power forcibly by press and hold
button,WOL might fail in due to the specification of the hardware.
In that case, turn on the power manually and shut down after starting OS enables
WOL next time.
・ When Link Speed and Duplex of the switch port connected to the managed machine
are not set as Auto, WOL might not be performed.
Check whether LAN is linked up or not while the power of the managed machine is
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turned on.
There is a possibility that LAN is not linked up, WOL might not be performed from
DPM.
Check the setting of the switch port and the driver and set Link Speed and Duplex as
Auto.
Turn on the power manually if necessary.
When the Management Server and the managed machine exist in the different
segment, following settings are necessary.
・ Group setting for DPM
Confirm the setting of the group by referring section 3.3.1 "Add Machine Group"
in Web Console Reference Guide.
・ Setting router/switch Management Server
There is a possibility that the communication of power ON send from the
Management Server might not be reached to the managed machine.
See Section 2.2.1."Network Environment" in First Step Guide and check the
network setting.
・ When Teaming for LAN port for the management machine, set the same value of
MAC address registered to DPM Server for the physical LAN and MAC address of
virtual LAN which has been performed.
When MAC address of the virtual LAN and MAC address of the physical LAN are
different,WOL might not be performed by DPM.
・ There is a possibility that the managed machine might not WOL in some machines
if you turn off the power when registering machine to DPM by network boot.
In that case, turn on the power manually.
Confirm the specification of the hardware if the phenomenon is not improved despite
performing above steps, because WOL by DPM depends on the specification of the
hardware.
How to display again Automatic update status display on the task tray?
See Section "3.3.1 Client Setting Tool" in Tool Reference Guide.

3.4. Scenario
You cannot assign a scenario to the managed machine.
A scenario cannot be assigned to a machine in the following statuses: Scenario
Executing, Scenario Execution Stop, Scenario Execution Error or Remote Power ON
Error. Assign a scenario either after scenario execution completes, or clear the
machine status.
You want to change the scenario file name.
The scenario name cannot be changed. Please create a new scenario.
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3.5.

Execute Scenario

3.5.1.

General
You executed a scenario, however the managed machine Status is not Scenario
Executing.
If you click Refresh from Operation menu, or refresh the screen by pressing F5 key,
the status changes to Scenario Executing. Until the machine icon displays
Running, do not edit, delete or remove scenario assignment for any running
scenario. The scenario may not execute properly.
You checked the Forced Execution Of A Reboot Is Performed Before Execution
checkbox on the scenario Option tab, however the machine does not reboot.
When installing service packs, hotfixes, and applications, the machine does not
reboot before executing a scenario.
An error occurred while a scenario was running.
Use the following method to remove the error.
Next, check the error contents in the Event Viewer, confirm that the machine is in the
correct status on the Web Console, and then re-execute the scenario.
Example 1) Error Removal Method
(1) Click the machine in error status on the Machine List, and a machine
detail screen appears.
(2) Click Remove Error under Operation menu on the machine detail screen.
Example 2) Error Removal Method
(1) Click Monitor view - Scenario Execution List.
(2) In the tree view, click Scenario Execution List.
(3) In the Operation menu, click Batch Clear Status.
(4) On the Status Clear screen, select Scenario Execution Error.
(5) Click OK.
A Running Scenario does not complete.
Confirm the following:
・ Confirm that DPM Client is installed.
If DPM Client is not installed, interrupt the scenario, install DPM Client, and
re-execute the scenario.
・ Confirm that the IP address of the Management Server set when DPM Client was
installed on the managed machine is correct.
If it is incorrect, either change the following registry, or reinstall DPM Client and set
the correct IP address.
<Windows>
Key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\depagent\Para
meters
Key name: ServerIpAddress
<Linux>
Correct the following files in the /opt/dpmclient/agent/etc/ folder.
File Name: server.inf
Key name: dpmserverip=
・ At the time a scenario completes, the setting is that DPM Client can communicate
with the Management Server.
・ When the scenarios is running, if you change the configuration of Management
view -> DPM Server -> Detail Setting -> DHCP Server tab on the Web Console,
PXE boot fails in the managed machine and the completion of the scenario cannot
be detected. After stopping the scenario, re-execute the scenario after setting the
item in DHCP Server tab matching the proper environment.
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A scenario execution error occurred immediately after you executed a scenario.
The location of installation or settings of DHCP might be wrong, or DHCP Server
might not be able to lease IP address or the DHCP server might not operate properly.
Check the current situation from the following:
・ Select Management view -> DPM Server -> Detail Setting -> DHCP Server tab
on the Web Console, and confirm that the settings are correct.
・ Confirm that the lease IP address in the DHCP scope is not inactive.
・ Confirm that the DHCP Sever is approved by Active Directory when DHCP Server
joins a domain, and The IP address can be leased.
・ Confirm that the DHCP address pool has not run out. If the pool has run out, please
secure a sufficient pool of addresses.
・ If using a DHCP server except Windows, confirm that fixed addresses are
configured.
A remote update scenario may have been executed on a machine that exceeded the
Distribution Condition Setting - Maximum Targets configured in the scenario.
Reduce the number of machines to execute, or increase the value of Maximum
Targets.
HW configuration, OS installation, disk configuration check, or Backup/Restore
scenario may have been executed for turned ON machine.
When you turned OFF the machine and execute again or execute turned ON machine
forcibly, check the check box of Forced Execution Of A Reboot Is Performed
Before Execution on Option tab of scenario.
The command (execute file path + execute file name + setup parameter) of executed
package for a remote update scenario may exceed 259 characters. Correct so that the
length is 259 character or less by Image Builder and PackageDescriber.
An error occurred while running the scenario.
In the Event Viewer, error log information is registered.
Check the log information registered in the Event Viewer, and perform the processes
for each item.
A problem that still occurs after re-executing may cause incorrect behavior in related
services. If a scenario is executing, wait until it completes and then perform the
following operations from the Management Server. From Start menu, select
Administrative Tools -> Services on the Management Server, and then restart the
following services. (Start if the service is stopped.)
DeploymentManager API Service
DeploymentManager Backup/Restore Management
DeploymentManager Get Client Information
DeploymentManager PXE Management
DeploymentManager PXE Mtftp (Restart is not needed when startup type is
disabled.)
DeploymentManager Remote Update Service
DeploymentManager Schedule Management
DeploymentManager Transfer Management
- Log Information 1
・ Error: Timeout error and stop run scenario. No response from
target:
Explanation
The scenario execution timed out because there was no response from the
machine within a given time. The machine may have stopped due to an awaiting
input status, error display, or other reason. After checking the machine, scenario
content, setup parameter files and other information, remove the error from the
machine. Next, turn the machine power OFF and then re-execute the scenario.
- Log Information 2
・ Error cannot create thread (xxxxxxxxxxx)
・ Error cannot allocate xxxxxxxxxxxxxxxx
Explanation
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Failed to create the thread which processes machine requests and to allocate
buffer memory. There is the possibility that there are insufficient resources due to
factors such as the Management Server's high load state.
After checking the Management Server status, remove the error from the machine.
Next, turn the machine power OFF and then re-execute the scenario.
- Log Information 3
・ Error cannot read CLF
・ Error cannot change CLF
Explanation
Failed to read/write managing machine information.
Remove the error from the machine, and then turn the machine power OFF. After
waiting a while, re-execute the scenario.
- Log Information 4
・ Error cannot get xxxxxx path
・ Error cannot read xxxxxx
・ Error cannot open xxxxxx
Explanation
Failed to obtain the path for, open, and read file xxxxxx.
There may be insufficient resources or registry information may be damaged due to
factors such as the Management Server's high load state. After checking the
Management Server status, remove the error from the machine. Next, turn the
machine power OFF and then re-execute the scenario.
- Log Information 5
・ Starting process of the computer failed MAC = XX-XX-XX-XX-XX-XX
Explanation
Failed to power on the machine remotely.
The network cable is not connected, or remote power ON is not configured. If the
machine is forcibly shut down while the POST screen is displayed, remote power
ON may not function the next time the machine boots up.
Confirm HW settings and try again.
- Log Information 6
・ Starting process of the computer failed when execute scenario
MAC = XX-XX-XX-XX-XX-XX
Explanation
Failed to power on the machine remotely.
The network cable is not connected, or remote power ON is not configured. If the
machine is forcibly shut down while the POST screen is displayed, remote power
ON may not function the next time the machine boots up.
Confirm HW settings and try again.
- Log Information 7
・ scenario start write shared memory MAC : error =
XX-XX-XX-XX-XX-XX : XXX
Explanation
The service may have abnormally terminated.
(1) From Start menu, select Administrative Tools -> Services on the Management
Server, and then stop the following services:
DeploymentManager API Service
DeploymentManager Backup/Restore Management
DeploymentManager Get Client Information
DeploymentManager PXE Management
DeploymentManager PXE Mtftp (Stop is not needed when startup type is
disabled.)
DeploymentManager Remote Update Service
DeploymentManager Schedule Management
DeploymentManager Transfer Management
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(2) Start the services you stopped in Step (1).
(3) Execute the scenario again.
- Log Information 8
・ scenario start write shared memory MAC : error =
XX-XX-XX-XX-XX-XX : 112
Explanation:
WOL has not been executed on the target machine for scenario execution or
failed in PXE boot might be the cause.
When executing scenario for the machine whose power is turned off, DPM monitors
operation of PXE boot.
When PXE boot is not executed and WOL is not executed and scenario execution
error is occurred.
Set WOL and network boot with BIOS setting for the target machine.
See the manual attached to the hard ware for the detail of BIOS setting.
The managed machine does not turn on when the power is turned on or a scenario is
executed.
If the power is forced turned off during POST, the system may fail in Wake On LAN
when restarted.
Turn off the power after completion of POST or start the operating system and
perform the shutdown process.
The power was turned off during scenario execution by mistake.
On the Web Console, click Operations in the title bar to switch to the Operations
view. In the tree view, click Machines icon, and then select the group to which the
machine which power was turned off is registered. Select the specified machine, and
then select Scenario Execution Stop to interrupt the scenario. After the status
returns to normal, execute the scenario again.
The managed machine is not booted through the network, and the executed scenario
becomes time out error.
The network boot priority in the BIOS settings may be lower than the hard disk boot
priority. Make the network boot priority higher than the hard disk boot priority, and
re-execute the scenario.
When you manage a machine of UEFI mode, and if you start Windows OS after
scenario completion of disk duplication OS installation or
after changing UEFI boot option, two or more "Windows Boot Manager" are displayed
in UEFI boot option and the boot order of network boot may be changed.
Set the boot order of the network boot higher than "Windows Boot Manager" and
execute the scenario again.
There is a possibility that DPM Client might not receive request form DPM Server.
Confirm whether the port number DPM Client uses is not used for other application.
When the port number is used for other application which DPM Client used, change
one port number enable DPM Client to communicate.
See section 1.5 "Port Change Procedure on DPM" for the port number of DPM.
When you execute DPM Command Line, the specified command does not run.
In addition, an error does not appear at the command prompt.
You may be using DPM Command Line of the previous version (Command Line for
DPM). If you are using DPM Command Line (Command Line for DPM) of the previous
version, perform the upgrade installation, see Section 3.5, "Upgrading DPM
Command Line" in Installation Guide.
When you executed a scenario to two or more managed machines simultaneously, a
Remote Power On error occurred.
In the case of executing a scenario to two or more managed machines simultaneously,
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the default timeout value of the Remote Power On, which is specified in the
Management view -> DPM Server -> Detail Setting - Network tab, may cause a
timeout error.
As a guide, set the Remote Power On Timeout to the following value:
(Remote Power On Interval) multiplied by (the number of scenario executing
machines) plus (managed machine startup time).
When a scenario finishes or the running scenario is stopped, the following message appears
on the managed machine and the machine cannot be turned off:
ERROR: Failed to power down by calling APM BIOS. The system has halted.
A machine that does not support Advanced Power Management (APM) may not be
automatically turned off at shutdown. In this case, turn off the managed machine
manually.
When you execute DPM Command Line, the following message appears, and you cannot
execute the command:
The system cannot execute the specified program.
This message appears when runtime modules required for running DPM Command
Line are not properly installed.
Execute the following file to install the run-time modules:
<Installation media>:\DPM\Setup\VCRTL\vcredist_x86_2013.exe
To install the modules, Windows Installer 3.1 or later is required.
When you execute DPM Command Line, the following log is output to "System" in the [Event
viewer].
Source: SideBySide
Event ID:32
Explanation: The dependent assembly Microsoft.VC120.CRT could not be
detected.
Error: The referenced assembly is not installed to the system.
This message appears when runtime modules required for running DPM Command
Line are not installed properly.
Execute the following file to install the run-time modules:
<Installation media>:\DPM\Setup\VCRTL\vcredist_x86_2013.exe
To install the modules, Windows Installer 3.1 or later is required.
Following DPM Service does not start.
Message "Error 1067: The process terminated unexpectedly."has been displayed.
DeploymentManager API Service
DeploymentManager PXE Management
DeploymentManager Backup/Restore Management
When IP address for the Management Server has been changed without following
regular procedure, this error is occurred.
See Section 1.1 Procedure to Change the IP Address of the Management Server to
change IP address after returning to previous IP address for the Management
Server.
"Starting kswapd","NTFS driver v1.1.2.2[Flags:R/O]" is displayed when executing scenario.
Invalid "USB legacy system" on the keyboard setting for BIOS can avoid this error.
"The arguments is invalid."is displayed when executing DPM Command Line.
Error is occurred either blank or ">" is included in the argument.
In this case, enclose relevant argument within double quotation marks.
Following errors are displayed when executing DPM Command Line, and does not operate
properly.
ERROR:xxxx
ERROR CODE:7304
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ERROR MSG:xxxx
Proxy server is set to the machine on which DPM Command Line executes.
Following error might be displayed during DPM Command Line execution when
access to DPM Server via proxy server is not necessary.
-----------------------------------------------------------------ERROR: Failed to set the DPM Server.
xxx cannot be operated.
ERROR CODE:7304
ERROR MSG:Session: DPM Server returned the ending code which is not
successful.
(HTTP Status is not 200)
-----------------------------------------------------------------*xxx varies depending on the execution details.
HTTP is used for communication between DPM Command Line and DPM Server.
HTTP error occurs because access is performed via proxy server for the local
server(internal network server).
Set bypass for the proxy setting of WinHTTP.
Set bypass setting on WinHTTP proxy setting.
<Windows2008 or later>
Start command prompt and execute following command.
[For x64OS]:
%SystemRoot%\SysWOW64\netsh winhttp set proxy proxy-server="proxy server
address " bypass-list=" DPM Server address "
[For x86OS]:
netsh winhttp set proxy proxy-server="address of the proxy server
"bypass-list="address of DPM Server"
Example are below.
Command
\Windows\SysWOW64\netsh winhttp set proxy
proxy-server="testproxy.co.jp:8080"
bypass-list="192.168.1.1"
Execution result
Current WinHTTP proxy setting.
Proxy server: testproxy.co.jp:8080
Bypass list: 192.168.1.1
<Windows Server 2003 or earlier>
Start command prompt and execute followings.
proxycfg-p proxy server address DPM Server address
Example are below
Command
proxycfg -p testproxy.co.jp:8080 192.168.1.1
Updated WinHTTP proxy setting
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Inter
netSettings\Connections\WinHttpSettings :
Proxy server: testproxy.nec.co.jp:8080
Bypass list: 192.168.1.1
Following messages are displayed on the event log and cannot start DPM.
・ "The DeploymentManager API Service service terminated unexpectedly."
has been displayed and DeploymentManager API Service ends soon after starting.
・ "Cannot create a file when that file already exists."
is displayed and cannot start DeploymentManager Schedule Management.
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Relevant DPM service fails in starting by way of access to SQL Server (DPMDBI) at
the timing of starting when SQL Server (DPMDBI) service stops or when
you cannot access to the database with any cause.
Restart SQL Server (DPMDBI) and start relevant service.
"Unknown" is displayed on the "Disk Information (Disk Viewer)" screen on the Web Console.
There is a possibility that the file system and the disk type which are not
corresponded to DPM might be included in the disk of the managed machine.
Confirm whether the state of the disk of the managed machine is formatted with the
file system or the disk type which DPM is corresponded.
See Appendix A, "Function Tables" in First Step Guide for the detail of the file
system and disk format corresponded to DPM.
Error is displayed when "Disk Information (Disk Viewer)" on the Web Console is displayed
and disk configuration is not displayed.
There is a possibility that disk information is damaged or does not exist.
Execute disk configuration check scenario again.
Followings might be the cause.
・ Disk configuration check scenario has never been succeeded.
・ Disk configuration check scenario has not been succeeded after changing FC-LUN
configuration for the managed machine.
・ Disk information obtained by executing disk configuration check scenario is
damaged.
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3.5.2.

Creating a Linux Install Parameter File
When you select Open under File menu from the installation parameter setting tools and
when reading the existing Linux installation parameter file, the following message appears:
A candidate host file cannot be read.
About the selected Linux installation parameter file, OS may not be supported in this
version. For details, see Section 3.9.1, "System Requirements" or Appendix A,
"Function Tables" in First Step Guide.
The Linux installation parameter file may be damaged.
Check the contents of the Linux setup parameter file and Linux boot parameter file.
When you select Open under File menu from the installation parameter setting tools and
when reading the existing Linux installation parameter file, the following message appears:
The Linux OS installation parameter file cannot be read.
About the selected Linux installation parameter file, OS may not be supported in this
version. For details, see Section 3.9.1, "System Requirements" or Appendix A,
"Function Tables" in First Step Guide.
The Linux installation parameter file may be damaged.
Check the contents of the Linux setup parameter file and Linux boot parameter file.

3.5.3.

OS Installation by Disk Duplication
While you set up the OS by OS installation by disk duplication, the following message appeared on
the machine screen and processing stopped.
"The parameter file for this system is not prepared, or failed to be copied.
Follow the wizard to setup displayed after reboot. Press any key to reboot."
The number of machines trying to access the Management Server may exceed the
maximum number of machines concurrently accessible. Reduce the number of machines
concurrently accessing the Management Server concurrently.
During the Windows OS setup by OS installation by disk duplication, the process stopped under the
condition of being logged onto the machine.
Furthermore, machine names and so on that were specified by parameters are not set correctly.
It may have failed to reflect the specific information because it took time to initialize the
setting of Windows OS.
Open <Folder for Image>\Sysprep\Windows\DepConfig.ini by Text Editor and so on, and
change the following Timeout value (milliseconds). (Use numeric characters.)
DepConfig.ini can be edited after Copy-ExpressSysprep.vbs script is executed on the
master machine when the master image is created.
[SYSPREP]
Timeout=60000
Example)
[SYSPREP]
Timeout=300000
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Following message is displayed and processing has been stopped during OS set up by disk
duplication installation.
linftc: ERROR: ioctl - SIOCGIFADDR<iLocalSocket>(99 - Cannot assign requested address).
Disk duplication module could not obtain the IP address to communicate with the
Management Server.
Confirm whether LAN board of the managed machine is ready to communicate or not.
Confirm whether the IP address is assigned to the LAN board to communicate with the
managed server when LAN board of the managed machine is in the state of communication.
During the OS setup by OS installation by disk duplication of Windows Server 2008/Windows Vista
or later, either of the following messages appeared and the process stopped.
・ "Windows could not parse or process the unattended answer file for pass
[specialize]. The settings specified in the answer file cannot be applied.
The error was detected while processing settings for component
[Microsoft-Windows-Shell-Setup]."
・ "The computer restarted unexpectedly or encountered an unexpected error.
Windows installation cannot proceed. To install Windows, click "OK" to
restart the computer and then restart the installation."
The OS type in the disk duplication data file for the duplication destination machine may
differ from the OS type of the master machine. Also, Product Key may not be specified in
the disk duplication data file correctly.
Change the OS type in the disk duplication data file so that it matches that of the master
machine and specify Product Key correctly. Then, distribute the disk image again.
While you setup the OS by OS installation by disk duplication, the following message appeared on
the machine screen and processing stopped.
"The system registry contains invalid file paths. Installation cannot
proceed. This system image was applied without guaranteeing that drive-letter
assignments would match across computers."
This error may be displayed if the system configuration of the master image is multiboot.
Confirm that the master image is not a system configuration of multiboot. OS installation by
disk duplication in the multiboot environment cannot be executed. (Be sure to construct the
master image as a single system.)
After you set up the OS by OS installation by disk duplication, the characters of the connection
name registered in Network and Dial-up Connections were garbled.
If this occurs, change the connection name manually.
When you execute Sysprep command on the master machine in setting up OS by OS installation
by disk duplication, Windows Security Alert dialog appears and the message that "Do you want to
keep blocking this program? Name: Microsoft Remote Desktop Help Session Manager" is
displayed.
In the case of Windows Server 2003 R2, this may be displayed. The processing continues
automatically after a while and there is no problem. Wait for a while.
The screen requires IMJPZP.DI_file or others is displayed while disk duplication OS installation.
When IMJPZP.DI_ is required, copy IMJPZP.DI_file from the following to
\SYSPREP\I386\LANG folder of the master machine (for OS of Windows Server 2003
R2/Windows XP or earlier: \SYSPREP\I386\LANG\JPN) which has been created in the
procedure of "Executing the tool in the installation media manually" in 3.3.1.3, "Preparing for
Creating the Master Image" in Operation Guide.
Create LANG folder when there is no LANG folder under I386.
・ For Windows XP/Windows Server 2003/Windows Server 2003 R2(x86):
(CD-ROM) drive:\I386\LANG\IMJPZP.DI_
・ For Windows Server 2003 R2(x64):(CD-ROM)drive:\AMD64\LANG\IMJPZP.DI_
Refer to "Executing the tool in the installation media manually" in
3.3.1.3, "Preparing for Creating the Master Image" in Operation Guide and execute disk
duplication OS installation again.
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When the other file is required, add the file to the master machine by the same procedure
and execute disk duplication OS installation again.
After OS installation by disk duplication, messages such as the following appear at Linux OS
startup. Or, X-Window does not start.
"Could not look up internet address for "Hostname"(*) This prevents GNOME from
operating correctly. It may be possible to correct the problem by adding
"hostname"* to the file /etc/hosts."
* "Hostname" is the host name of each machine after OS installation by disk duplication.
An error may occur at X-Windows startup because a host name is not registered to the file
/etc/hosts. Register the hostname in the /etc/hosts file. If the environment uses a static IP
address, register the line as the following.
Example) 192.168.0.1 servername
If the computer obtains an IP address from DHCP, register the hostname with a
loopback address as follows:
Example) 127.0.0.1 localdomain.localhost localhost servername
IP address conflict occurred after OS installation by disk duplication.
If an alias interface is configured in the master machine, IP address conflict occurs after OS
installation by disk duplication. Use the following procedure to delete the alias interface
configuration file, and then restart the machine.
# cd /etc/sysconfig/network-scripts
# rm -f ifcfg-eth*:*
# rm -f ifcfg-bond*:*
If you execute backup of OS installation by disk duplication of a Linux-installed VMware ESX/ESXi
virtual machine as a master machine, the following error appears and the machine has been shut
down during OS start-up after completion of backup and restarting.
"Determining IP information for ethX ...failed; no link present. Check cable?"
Configuration described in "Executing the tool in the installation media manually" of Section
3.4.1.3, "Preparing for Creating the Master Image" in Operation Guide may not have been
done correctly in the preparation for OS installation by disk duplication on the master
machine.
Confirm the procedure and configuration, and then execute OS installation by disk
duplication again.
If you execute OS installation by disk duplication for a VMware ESX/ESXi virtual machine, the
following error appears and network adaptor has not been recognized during OS start-up after
restarting the machine by reflecting the specific information and restarted.
"Determining IP information for ethX ...failed; no link present. Check cable?"
When the disk duplication data file was created, the script data listed in Section 1.4.3,
"Creating a Disk Duplication Data File (Linux)" in Tool Reference Guide. may not have been
properly configured.
Confirm the procedure and configuration, and then execute OS installation by disk
duplication again.
Though execution of scenarios for setting up of a master machine
(System_LinuxMasterSetup/System_WindowsMasterSetup/System_WindowsMasterSetupVM)
succeeded OS installation by disk duplication fails.
DPM Client earlier than DPM Ver6.12 may be used. After upgrading DPM Client to this
version, execute OS installation by disk duplication again.
When I make mistake the turn of procedure to create the master image of disk duplication
installation, is it possible to make another try from the wrong step?
Follow the step of the Operation Guide from the beginning again after restoration of the
backup image of the master you created before.
If you retry from the wrong step, there is a possibility that the master image of the disk
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duplication installation might not be created properly.
Parameter file does not exist on disk duplication installation.
There is a possibility that connection to the Management Server might be failed because the
managed machine obtains the disk duplication parameter file from the Management Server.
In that case, there is a possibility that the domain which belongs to the Management Server
might not allow the user authorization for "Access to the computer via network"
->This user authority to connect with the managed server is necessary.
There are some items setup parameter is not applied after disk duplication installation.
There is a possibility that some items are not reflected when installing disk duplication.
In that case, set manually after completion of the disk duplication.
During disk duplication installation, stops at the login screen.
(Password error has been occurred).
Password has been set when you prepare for disk duplication installation on the master
machine. Set as "no password" of the master machine and execute backup again.
Execute disk duplication OS installation again by using the backup image you set as above.

3.5.4.

OS Clear Installation
After Distribution of floppy disk image for BIOS/firmware and an OS clear installation scenario was
executed, a scenario execution error occurs before you reboot the machine.
Is there a check-in on the Forced Execution Of A Reboot Is Performed Before Execution
checkbox on the scenario Options tab? If not, a scenario will not be executed for any
machine that has been turned ON. Modify the scenario or turn the machine OFF and
execute the scenario again.
Scenario execution has stopped and the following message appears on the screen of machine
while execution of OS clear installation scenario.
"Cannot connect data server. Please stop running scenario on management
server and press any key to reboot"
The maximum number of machines that accessing the Management Server simultaneously
may have been exceeded. Reduce the number of machines which accesses Management
Server simultaneously and execute again.
The OS installation has stopped due to an error.
OS installation will stop with error if you specify unusable character in the machine name.
For a list of unusable characters, see the manual of OS and others you are using.
During Linux installation, the following message appears, and the installation unable to be
completed.
Could not allocate requested partitions; Partitioning failed:
Could not allocate partitions as primary partitions
The partition settings may be wrong. (For example, if the number of primary partitions on
one basic disk exceeds the upper limit (4))
While creating the Linux installation parameter file, select Disk Information Settings Partition Settings - Delete All Existing Partitions and execute the Linux installation again.
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During Linux installation, the following message appears, and the installation unable to be
completed.
+--------------- Kickstart Error ------------+
Error opening: kickstart file
/tmp/ks.cfg: No such file or
directory
[OK]
+-----------------------------------------+
Confirm if NFS shared folder is configured correctly.
See Appendix C, "Configuring NFS Server" in Installation Guide to configure the folder
correctly, and then install Linux.
If you uninstall DPM Server with the exports folder as an NFS shared folder as previously
mentioned in Setting Up the NFS Service, and then reinstall DPM Server, the NFS shared
property is configured in Explorer, however the above error may occur when you actually
perform the installation. In this situation, release and then reconfigure the NFS shared
property.
Confirm that the install device you are using is configured to Installation Device of Linux
installation parameters.
See Section 1.4.5, "Creating a Parameter File for OS Clear Installation (Linux)" in Tool
Reference Guide to configure Installation Device correctly, and then install Linux again.
Network device exist as unknown device after OS installation.
Register appropriate device driver on DPM and specify as scenario to install device driver.
For the detail, contact your sales or support representative.

3.5.5.

Installing Service Packs / HotFixes / Linux Patch Files /
Application
Perform the following operations if scenario execution errors continue to occur in remote update.
Restart the Management Server. (If the Management Server cannot be rebooted, stop all
services described in Appendix A, "Service List" by selecting Management Tools ->
Services from Start menu, and then start all of the services you stopped.)
When you executed the scenario of installing service packs, hotfixes, Linux patch files, and
applications, however the machine in the Status column of the Monitor view -> Scenario
Execution List remains in Scenario Executing, and the scenario execution does not complete.
If the setup parameter is not configured correctly, a confirmation dialog box appears on the
machine and the scenario execution does not complete. You can check the setup parameter
by running the service pack or the hotfix with the option /h or -? , or see the web site of the
distributor and others. Make sure to specify the setup parameter to execute silent installation
and not to restart after installation.
Failed to create an image file during the registration of Installing service packs, hotfixes, Linux
patch files, and applications by Image Builder.
In installing service packs, hotfixes, Linux patch files, and applications, image file is saved in
ZIP file. If these ZIP files size exceed 2GByte, creation of the image file fails.
When you modified a package by Image Builder, the message "Failed to compress the file."
or " Failed to register in the Management Server." is displayed and package modification
fails.
If the modification date is earlier than the package creation date, package modification fails.
There may be some reasons, such as, the date-time of the machine was changed after
creating the package, or that date-time of the Management Server is different from one of
Image Builder (Remote Console) machine. After the date that the package was created,
modify the package, or delete the package and create the package again.
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The packages are stored in Management Server's Folder for Image \HotFix, or Folder for
Image \PP.
(The default of the Folder for Image is
C:\Deploy, and the package file name is "ServerID"-"PackageID".zip.)
Even if applying a service pack/hotfix/Linux patch file fails, the Web Console displays that scenario
execution completed successfully.
When the execution of a service pack or hotfix fails, the failure may not be detected. In such
case, fix the cause of the execution failure, and then execute the scenario again.
A scenario execution error occurs if you execute a scenario Distribution of floppy disk image for
BIOS/firmware or apply Installing service packs, hotfixes, Linux patch files, and applications install.
Confirm that the execution interruption processing is completed properly. If interruption is
cancelled before execution and then the scenario is executed, the scenario execution error
may occur.
Furthermore, if you want to execute the same scenario simultaneously on two or more
machines, set the maximum target number of multicast distribution conditions to the number
of machines you want to interruption process is completed, and then execute the scenario.
A scenario execution error occurs if you try to execute two or more service pack/hotfix/Linux patch
file/application install scenarios at the same time.
See the Scenario Details screen and check whether the same multicast IP address is
specified. If the same multicast IP address is not being used, reduce the maximum transfer
rate, or execute the scenarios one by one. (If the scenario is the same, you may also
execute the scenario on two or more machines.)
A scenario of installation service packs, hotfixes, Linux patch files, and applications does not start.
If the maximum target is not configured, or is greater than the machine attempting to
execute, the scenario executes after the maximum wait time passes. (The default setting of
the maximum wait time is 10 minutes.)
The maximum transmission rate has been set higher, however the scenario execution time does
not decrease.
Maximum transmission rate varies depending on the network environment of the customers.
Transmission rate cannot be higher than the perfomance of the network environment.
If you register an application or service pack/hotfix by Image Builder (Remote Console), the error
Failed to register to Management Server is displayed.
This error may occur when the size of the file to register is extremely large.
To prevent this error, edit the timeout value (number of seconds) that is specified by the
following registry:
Hive : HKEY_LOCAL_MACHINE
KEY : SOFTWARE\NEC\DeploymentManager
NAME : DIBReqTimeOut
Type : REG_DWORD
Value : 120
-> The default is 120 seconds. Set the timeout value.
Even if an error is displayed, registration is succeeded. Re-registration is unnecessary.
When you exit Image Builder, perform the following operations:
(1) Select Yes (Register) at batch registration.
(2) Select No (Delete) at the confirmation of overwriting.
If you register a service pack/hotfix/Linux patch file by Image Builder (Remote Console), the data
creation has succeeded. However, the registration to the Management Server fails.
This may occur if the path for the setup command name is extremely long.
If registering to the Management Server from the Remote Console, the upload process
checks the full path, including the Folder for Image path on the Management Server side as
the maximum path length. If the full path exceeds upper limit, registration is not be
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completed properly. Register shorter full path by moving files to be registered to location
close to the drive root on the Remote Console, and register the files again.
If you interrupt the execution of the scenario of installing service packs, hotfixes, Linux patch files,
and applications, and then cancel the interruption and execute the scenario again, a scenario
execution error occurs.
If the interruption occurs when communications with the managed machine is disrupted for
some reason, the interruption process cannot be completed, and the machine remains in an
interrupt status. In this status, even if a scenario is executed after the interruption is
cancelled, a scenario execution error occurs.
In this case, wait for a while (approximately 10 minutes) and before executing the scenario
again.
If scenario execution errors continues, perform the following operations.
On the managed machine, select Management Tools ->Services from Start menu, and
restart DeploymentManager Remote Update Service Client. (Start if the service is
stopped.)
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After executing DPM Client automatic upgrade scenario for a Linux managed machine, and then
execute another remote update scenario, which does not start.
When another remote update is executed within two minutes of executing DPM Client
automatic upgrade scenario and DPM Client service does not start properly. Restart DPM
Client service or restart the OS. To restart DPM Client service, start the Console and
execute the following:
・ In the case of earlier than Red Hat Enterprise Linux 7/SUSE Linux Enterprise
>service depagt stop
>service depagt start
・ In the case of Red Hat Enterprise Linux7 or later.
>systemctl stop depagt.service
>systemctl start depagt.service
If remote update is executed for a Linux managed machine, a scenario execution error occurs.
When installing service packs, hotfixes, Linux patch files, and applications in Image Builder,
an option that outputs to the console may be specified to Setup Parameters on the
Execution Configuration screen. The option may be specified.
See Section 1.5.3, "Create Linux Package" in Tool Reference Guide and confirm that
relevant options are not specified.
If the relevant options are specified, delete scenarios including that packages, correct the
packages from which relevant options were removed. Recreate the scenario file with the
corrected packages, and then execute the scenario again.
If a remote update is executed by multicast for the x64 Linux managed machine, a scenario
execution error occurs.
The necessary libraries may not be installed. Confirm that /lib/libgcc_s.so.1 exists.
If /lib/libgcc_s.so.1 does not exist, install the following rpm package:
libgcc-3.4.5-2.i386.rpm
After the installation, restart DPM Client service or restart the OS.
To start DPM Client service, start the Console and execute the following:
・ In the case of earlier than Red Hat Enterprise Linux 7 /SUSE Linux Enterprise
>service depagt start
・ In the case of Red Hat Enterprise Linux 7 or later
>systemctl start depagt.service
When remote update scenario is distributed by multicast, scenario execution error is occurred on
some of the managed machines.
If all of the following is applied and remote update scenario is distributed by multicast,
scenario execution error occurs.
If managed machines are connected to two or more LAN boards on the Management
Server, create and execute different scenarios for each LAN board.
・ ANY is selected on the Web Console screen under Management View -> DPM Server
icon -> Detail Setting screen -> General tab -> IP Address.
・ The managed machines are connecting with two or more LAN boards on the Management
Server.
Fail in the automatic installation for Service pack/HotFix.
Specify " /passive /norestart" to the command option when registering Windows Server 2003
Service Pack 1.2.
Specify as is the case with HotFix by checking the command option.
Fail in Linux patch application.
Followings might be the cause.
1. Dependency for other rpm packages.
->Distribute package which has dependencies and deliver the patch.
2. Same patch has been already applied.
3. The rpm package has not been signed.
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->Set the appropriate command option.
See section 1.5.3, "Create Linux Package" in Tool Reference Guide for the detail.

3.5.6.

Backup/Restore
Partition number displayed on the machine is different from the partition number specified when
creating scenario.
A hidden partition may exist in the target hard disk. The hidden partition will not be included in
the total count if the check box was checked for Hidden Partition Is Disregarded in partition
specification Backup/Restore. Clear the check box, or enter the corresponding partition
number correctly.
Only several tens of MBs are transferred per minute during Backup/Restore operations.
The maximum transmission rate may be specified too low, such as 1-10MByte/minute.
Confirm the Maximum transmission Rate column on the Multicast Condition Setting panel
in Backup/Restore tab on the Scenario Edit screen. If you want to save time, clear the check
box. If you want to reduce network workload, select the check box and specify the appropriate
values.
Data may not be transferred smoothly due to a high network workload. Minimize use of the
network as much as possible during the scenario execution.
Scenario execution error has been occurred suddenly while backup data transfer.
Data transmission may not be possible due to sufficient free space on the Management
Server. Make sure there is insufficient free space on Management Server where the backup
data is to be saved. Backup will not operate properly if there is not enough free space.
Reconsider the backup file destination, or reserve sufficient free space.
When you start the OS on the machine that is restored, the disk image of another machine was
restored.
The image files that you backed up may have been overwritten with the backup image of
another machine. When executing backup, make sure that you do not use a redundant image
file name. Otherwise, the previous data will be overwritten.
Furthermore, if the same scenario is assigned to two or more machines and execute backup
simultaneously, check whether machine name, MAC address, or UUID under the textbox on
the scenario file Backup/Restore tab is selected.
Even if restore is executed simultaneously, several of the managed machines do not execute
scenarios, and Waiting for Restore Execution is displayed on the Backup/Restore Execution List
screen.
The Maximum Targets set for the scenario file may be less than the actual machine number
you are trying to execute. In this case, after completing the execution of preceding scenario,
and then the scenarios for the rest machines start.
The restore operation has been in waiting for restore execution status and does not start.
The setting of the Maximum Waiting Time under the Distribution Condition Setting group
box on the Backup/Restore tab for the scenario file can not to be configured. If the column is
blank, the scenario will not execute until the number of machines ready to execute scenarios
reaches the Maximum Target value. Click Run Now on the Backup/Restore Execute List
screen, or interrupt the execution and specify an appropriate value for Maximum Wait Time
of the scenario file.
Even if you the maximum target number as 10 in the restore scenario, and then execute the scenario
on 10 machines simultaneously, the scenario executes on only 5 machines at once.
If the Management view -> DPM Server -> Detail Setting -> Network tab ->Machines For
Simultaneous Execution value is 5, the scenario executes on only 5 machines at once,
although the maximum target value is specified as 10. If you want to execute on 10 machines
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simultaneously, change the value of Machines For Simultaneous Execution under Detail
Setting to 10.
Although maximum transmission rate has been set higher, the scenario execution time is not
shortened,.
Maximum transmission rate depends on network environment of each customer.
Transmission rate cannot be higher than the performance of the network environment.
Even through the execution of a backup scenario, a unicast restore scenario, or disk configuration
check scenario completed, the status of Scenario Execution List status remains Preparing.
If you executed a backup scenario, a unicast restore scenario, or disk configuration check
scenario on another machine before the same scenario execution has completed, the status
of Scenario Execution List on the Web Console may display Preparing from the time the
backup, restore, disk configuration check completes to the time that the execution of the
scenario completes. However, it does not affect the operation.
When checking scenario execution status on Backup/Restore Execution List while a multicast
restore scenario is executing, the scenario status is displayed as already complete although
execution was still in progress, or it may not be displayed.
Backup/Restore Execution List cannot be updated immediately, after executing scenarios.
The status is updated at the timing of start of reading or writing to the Backup/Restore disk.
Until then, the status before execution is displayed.
When displaying the screen before update, open the screen again or click Refresh after a
while.
During backup, a scenario execution error occurs, however no error message is displayed.
If the OS did not shut down properly when the machine was power off, the delayed write to
disk process may not have been completed during shutdown, and the file system may be
damaged. Furthermore, if the machine was power off and shutdown was not performed while
the disk was accessing, physical damage on the disk may have occurred.
If backup was executed on such a disk, a scenario execution error may occur.
In such case, reinstall the OS, or use a file system fix tool, and so on to fix the file system, and
then execute backup again.
Furthermore, if there is a physical damage on the disk (bad sector), you cannot
backup/restore using a fix tool and so on. If there are bad sectors, change a new HDD and
recover it by physically formatting and then execute a restore from a previous backup image.
When two or more restore scenarios are executed simultaneously, a scenario starts on the first
machine booted up, however after getting Backup System image is displayed on the other
machines, a scenario execution error has occurred, and the error is displayed on the Scenario
Execution List screen. On the machine screen, the following error message was displayed:
"ERROR: Received the error from the PXE server.
Please contact your system administrator or support group."
The same multicast IP address is specified when the scenario was created may be specified
in all scenario files. Open the Edit Scenario screen, and check the value of multicast IP
address on the Distribution Condition Setting group box in the Backup/Restore tab. If the
specified IP address is the same to another restore scenario, one of two scenarios may not
start properly. Enter a non-redundant IP address again on the Modify Scenario screen. If
Remove Scenario Execute Error is selected for the machine on which an error was
occurred, error display disappears, and the scenario can be executed again.
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When you execute a restore scenario by specifying a partition, either of the following error messages
is displayed and the scenario execution error occurs.
Cannot restore the data to a partition of a different size than the size you
backed up.
Specify a partition with the following size.
(required size of a partition to restore)
(size of the specified partition)
(XXXXX bytes)
(XXXXX bytes)
Cannot restore the data to a partition of a different type than the type
you backed up.
Specify a partition with the type same as you backed up.
(ID of the backed-up partition)
(ID of the specified partition)
(0xXX)
(0xXX)
Confirm the partition size and the type of file system are matched between the original disk
and the destination disk. Open the Edit Scenario screen, set the applicable partition, and then
execute the scenario again.
You may have specified a partition which is different from one that you backed up. Restore the
image file to the same partition when it was backed up. Open the Edit Scenario screen, set
the applicable partition and then execute the scenario again.
When the Hidden Partition Is Disregarded checkbox was selected and hidden partitions
exist on the managed machine, you may specify a partition that is different from when backup.
In this case, clear the Hidden Partition Is Disregarded checkbox, and then execute the
scenario again.
Without ending processing, while executing a backup/restore scenario, and the following messages
are displayed on the managed machine:
FS: Cannot open root device "" or xx:xx
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on xx:xx
There may be a problem in the LAN connection between the Management Server and the
managed machine, or the workload on the Management Server may be high. Check the LAN
connection and the Management Server workload, and then turn off the machine and execute
the scenario again.
While executing a restore scenario, the following message is displayed on the managed machine,
and a scenario execution error occurs.
The size of the backup data to be restored is larger than that of the destination
storage device. It cannot be restored. Specify a destination device whose size
is larger than or equal to the following size.
(minimum required size of a destination device)
(the specified device: its size)
(XXXXX bytes)
(DeviceName: XXXXX bytes) .
Check HDD size of the backup source and the restore destination.
When the HDD size of the restore destination is smaller, above message may be displayed.
Use HDD with the same or larger size than the backup source
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When you execute a backup scenario, the following message is displayed on the managed machine
and the scenario exectuion error occurs.
Failed to backup.
There is something wrong with the management information of the GPT disk.
Check and repair the disk by CHKDSK or other tools,
and re-execute the scenario.
When Hyper-V virtual disk is GPT type, above message may be displayed.
In this case, execute the full sector backup. Select Full Sector Option on Backup/Restore
tab of Edit Scenario screen and execute the scenario.
When you execute a restore scenario, the following message is displayed on the managed machine
and the scenario exectuion error occurs.
Failed to restore.
The data is not written to the destination storage device.
Invalid data in the backup image.
For this error, contact your sales or support representative.
When original Hyper-V virtual disk is GPT type, above message may be displayed if you
restore the backup image file created in the version earlier than DPM Ver6.2.
You cannot restore it because the backup image file includes invalid data.
In this case, recreate a backup image file by selecting Full Sector Option on
Backup/Restore tab when creating a scenario, and executing the backup scenario.
When the following error occurs and a process ends with error for some reason, you cannot execute
a shutdown or re-boot even if you press p or r (Key input cannot be recognized).
ERROR: <error message>
Press the p key to power off, and the r key to reboot:
Key input may not function on certain kinds of machines using a USB keyboard/mouse which
cannot be recognized.
Press (and hold down) the power button to turn off the power.
When you interrupted the execution of a restore scenario, the following message is displayed on the
managed machine:
Failed to read or write the data in the managed machine.
For this error, contact your sales or support representative.
This message is displayed when a scenario execution is interrupted. This message displays
because the data of the intended size could not be obtained due to disconnected
communication between Management Server and the managed machine.
This is not problematic to the scenario execution interruption process.
While executing a restore scenario, the restore data cannot be read.
Confirm that the backup image is not damaged and there is no trouble on the network.
Following message is displayed when executing backup and becomes scenario execution error.
Failed to backup.
The basic disks with non-512-byte sector is not supported.
(sector size of the specified device)

----(xxxxx)

There is a possibility that above message might be output when you backup
from the hard disk also, it is the basic MBR disk of 4k sector.
Execute full sector backup.
Execute scenario again by checking "Full Sector" check box on "Backup/Restore" tab in the
screen of "Scnenario Editing".
Following message is displayed when executing backup and becomes scenario execution error.
Failed to backup.
The dynamic disks with non-512-byte sector is not supported.
(sector size of the specified device)
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(xxxxx)
There is a possibility that above message might be output when you backup
from the hard disk also, it is the dynamic disk of 4k sector.
Execute Full Sector backup.
Execute scenario again by checking "Full Sector" check box on " Backup/Restore" tab in the
screen of "Scnenario Editing".
Following message is displayed when restoring and becomes scenario execution error.
Failed to restore.
The data is not written to the destination storage device.
The dynamic disks with non-512-byte sector is not supported.
(sector size of the specified device)
----(xxxxx)
When you restore by assigning partition, there is a possibility that above message might be
displayed in case the desitination hard disk is a dynamic disk with 4K sector.
Execute scenario again by assigning 512 sector basic disk (MBR).
Following message is displayed when restoring and becomes scenario execution error.
Failed to restore.
The data is not written to the destination storage device.
The basic disks with non-512-byte sector is not supported.
(sector size of the specified device)
----(xxxxx)
When you restore by assigning partition, there is a possibility that above message might be
displayed in case the desitination hard disk is a basic MBR disk with 4K sector.
Execute scenario again by assigning 512 sector basic disk (MBR).
Following message is displayed when restoring and becomes scenario execution error.
Failed to restore.
The data is not written to the destination storage device.
Cannot restore the data of a different sector size.
Please specify the appropriate device, and check
if the specified Deploy-OS is correct.
(required sector size of a destination device)
(the specified device: its sector size)
----(xxxxx bytes)
(DeviceName: xxxxx bytes)
There is a possibility that above message is displayed when the sector size which you backup
and that of restoration destination are different.
Confirm the sector size of the disk of restoration destination and select disk which matches the
sector size which you back up.
If there is no problem with the size, confirm designated Deploy-OS.
For the detail of correspondence depending on the model, contact your sales or support
representative.
When a restore scenario is multicast distributed, the restore does not executed, and scenario
execution is interrupted.
Furthermore, the following message was displayed on the managed machine, and then the machine
restarted.
(After restarting, scenario execution error was displayed on the status of the managed machine on
the Web Console.)
Failed to read or write the data in the managed machine.
For this error, contact your sales or support representative.
This System is rebooted after XX seconds.
gzip: stdin: Unexpected end of file.
This phenomenon may occur when both ANY is specified for the IP address used by
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Management Server and the restore scenario is distributed by multicast. Configure except
ANY for the IP Address used by Management Server (the IP address configured by the using
LAN board). For configuration method details, see Section 2.7.1.1, "General Tab" in Web
Console Reference Guide.
Confirm whether the switching hub and router in use are set to send multicast or not.

When scenario is running, "boot:" or "login:" is displayed on the manged machine, and the processing
does not proceed.
You may have entered the key to stop processing such as "Ctrl" + "C". Do not enter a key on
the managed machine when backup or restore scenario is running.
PXE boot fails on the managed machine.
Is the Management view -> DPM Server -> Detail Setting -> DHP Server tab set to Do Not
Use a DHCP Server?
If Do Not Use a DHCP Server is selected, a PXE boot cannot be executed on the managed
machine.
If a PXE boot is necessary, configure a DHCP server, and select Use a DHCP server.
Furthermore, restart the Management Server after changing it since the configurations are
enabled after Management Server restarts.
When you execute backup/restore scenario, the following message is displayed on the screen of the
managed machine and a scenario execution error occurs.
ERROR: FC storage configuration is different from the result of the disk
configuration check scenario.
Please retry the disk configuration check scenario.
When the configuration includes FC LUN, an error occurs because the information is different
from that obtained by disk configuration check. When you change either of the following
configuration, the error may occur.
・ Adding, changing, or deleting LUN
・ Changing the redundancy configuration of the path
・ Change the configuration including FC LUN to other configuration (internal RAID
configuration and so on.) and vice versa.
Execute disk configuration check to obtain new configuration information and re-execute a
scenario.
Recheck the disk number as necessary.
When the configuration includes FC LUN(LUN configuration, redundancy configuration), an
error occurs because the information is different from that obtained by disk configuration
check. When the part of paths cannot be connected due to physical problem and so on, the
above message may be displayed.
Recheck the connection status of the path or the redundancy configuration, or execute disk
configuration check to obtain new configuration information and re-execute a scenario.
Recheck the disk number as necessary.
Restration requires more time than backup.
Because writing speed to storage device for the client is slower than writing speed to the
storage device for the server.
Following might be the cause.
・ RAID setting
・ NTFS compression on the file system is valid
・ Fragmentation has been occurred on the hard disk.
If fragmentation is the cause, defragmentation might improve the speed.
Following message is displayed on the managed machine which executing restoration.
ERROR: Retry timeout, Disk writing cannot be completed, i_work==XX
This phenomenon is occurred because time out is occrred without complete writing restoration
data.
Execute restoration again.
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Follow the below steps and change registry to extend time out time duration when the
phenomenon is not fixed.
1. Log in to the Management Server by a user with administrator authority.
2. Start the registrator editor.
3. Change the following registry.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\bkressvc\Parameters
Name: ClientResultDisplayRetrytimes
Default is 300 seconds and the maximum value is 65535 seconds. Increase this value.
Name: UnicastReceiveTimeoutMillisec
Default is 600000 ms and the maximum value is 4294967295 ms. Increase this value.
4. Start below service.
DeploymentManager Backup/Restore Management
"Cannot find the corresponding disk(2)" is displayed while backup/restoration.
There might be mistake in specification of the disk number when you execute scenario creation.
Specify the disk number after checking the followings.
・ Check whether the disk number is correspond to the disk to backup or to restore.
・ The storage device which is recognized to the destination machine for backup/restoration is
connected.
Scenario execution error occurs while backup due to capacity shortage of the Management Server
side.
Size up the free area of HDD of backup destination for the Management Server.
Create backup image file as temporary and overwrite on the previous file at the timing of
completion of backup.
Temorarily ,the free space is necessary for this step.
Following error is displayed, without starting backup/restore.
"Could not find IP address and NetworkDeviceName."
There is a possibility that LAN board mounted on the Managed Machine might not be
corresponded to DPM. Check and follow step as below.
For the detail of the corresponding model list, contact your sales or support representative.
Time is rquired on scenario execution by CD boot until the actual process begins.
Scenario execution by CD boot makes an atttempt to the Management Server by using NIC in
order which is detected on the managed machine.
To identify NIC connected to the Management Server needs several tens of minutes on the
managed machine mounted multiple NIC.
Add "ClientEth:x" on "DPMIP.conf" to specify eth number to save time when eth number of NIC
which is connected to the Management Server is clear.
See "Executing Backup, Restore, or Disk Configuration Check" in Appendix A "Operating DPM
without Using the DHCP Server" in Operation Guide for the detail of setting.
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Either of the error messages listed below is displayed on the screen of the managed machine and
the event log of the Management Server when executing backup/restore/disk configuration check
scenario.
On the screen of the managed machine
・ AddDrv.sh: ERROR: <driver file name>: Cannot get driver file.
Event log of the Management Server
・ ft: ERROR: Failed to search folder, Path =..\<driver file name> ftsvc.cpp:xxx:xxx xx xxxx
・ File Download Failed.File Name:<driver file storage folder>\scsi\<driver file name>,
ClientMac:xx-xx-xx-xx-xx-xx
*<driver file name>: The name of the driver which problem has been occurred
*<driver file storage folder>:Differs depending on the environment
There is a possibility that the driver file (xxxx.o/xxxx.ko) which is included in the error message
output to the screen of the managed machine and the event log of the Management Server
might not be installed to the Management Server.
Check whether the driver file is installed or not with either of the following steps.
Countermeasure 1: Confirm the event log "File Download Failed" of the Management
Server.
Check whether the driver file specified by the message "File Name:" exist or not when above
error message is output.
・ File Download Failed. File Name:<driver file storage folder>\scsi\xxxx,
ClientMac:xx-xx-xx-xx-xx-xx.
Example: Output event log:
File Download Failed.
File Name:C:\Deploy\FD-Linux\drivers\ia32_121228_26\scsi\megasr.ko,
Client Mac:00-15-5d-01-64-01.
->Check whether C:\Deploy\FD-Linux\drivers\ia32_121228_26\scsi\megasr.ko exists or
not.
Countermeasure2: Confirm "AddDrv.sh: ERROR: xxxxx" on the screen of the managed
machine or the event log of the Management Server "ft: ERROR:
Failed to search folder xxxxx ".
1. Confirm the path of the driver file storage folder from below table by checking type of
"Deploy-OS " which is assigned to the managed machine on the Web Console.
Value set to Deploy-OS
Use the default value

NEC Express5800 001
NEC Express5800 002
VMware ESX Virtual
Machine 001
Microsoft Hyper-V
Virtual Machine 001
NEC Express5800 006
VMware ESXi Virtual
Machine 002
Microsoft Hyper-V
Virtual Machine 002

Path of the Driver file Storage Folder*
<Image storage folder>\FD-Linux\drivers\<default value>
<default value>is the name displayed in "Detail Setting" ->"General"
on the DPM Server.
Default is "ia32_110331_26".
< Image storage folder >\FD-Linux\drivers\ia32_080331_24
< Image storage folder >\FD-Linux\drivers\ia32_110331_26

< Image storage folder >\FD-Linux\drivers\ia32_121228_26
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VMware ESXi Virtual
Machine 003
Others

< Image storage folder >\FD-Linux\drivers\ia32_150413_26
< Image storage folder >\FD-Linux\drivers\<ia32_xxxxxx_xx>
Refer to the manual of the module for the machine model for
<ia32_xxxxxx_xx>.

*Default for Image storage folder is C:\Deploy.
*For the bootable CD, driver file storage folder should be the same of Deploy-OS for the Management
Server.
2. Confirm whether the driver file (xxxx.o/xxxx.ko) is included in the error message exists under
the driver storage folder path.
Example:
Output event log:
ft: ERROR: Failed to search folder, Path = ..\megasr.ko, ftsvc.cpp:874:Dec 22 2014
Deploy-OS of the managed machine
NEC Express5800 002
->Confirm whether C:\Deploy\FD-Linux\drivers\ia32_110331_26
megasr.ko exists in C:\Deploy\FD-Linux\drivers\ia32_110331_26\scsi or not.
For the detail of driver pack installation, contact your sales or support representative.
Re execute the scenario after above procedures.
Following error message is displayed on the managed machine when executing backup/restore/disk
configuration.
BUG: soft lockup - CPU#0 Stuck for 67s!
*CPU number differs depending on the operation environment.
There is a possibility that operation delay is occurred on Deploy-OS and
soft lockup error is detected when managed machine is the virtual machine of VMware ESXi 5.1
or later and configurated with one and more CPUs.
Applicable condition/source of supply for the patch module to avoid this phenomenon is
decribed as follows.
[Applicable condition]
- The managed machine is the virtual machine for VMware ESXi 5.1 or later.
[Source of supply of the patch module to avoid this phenomenon]
- <Installation media>\DPM\TOOLS\PreventSoftLockup_Module
* Refer to the manual for the detail of application procedure under the folder.
Applying patch module might inhibit soft lockup error and improve this phenomenon.
Execution errror is occurred during backup.
Confirm whether temporary file remains in the backup image storage folder (*.dpmtmp) or not.
When the temporary file remains, delete manually.

3.5.7.

Distribution of Floppy Disk Image for BIOS/Firmware
The managed machine does not boot by the network boot after scenario that Distribution of floppy
disk image for BIOS/firmware is executed.
If BIOS is upgraded, the BIOS configuration may return to the default settings. Check whether
the priority order of the network boot is not changed. If the priority order is changed, set
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network boot to the top priority.
A scenario execution error occurs when you execute a Distribution of floppy disk image for
BIOS/firmware, Installing service packs, hotfixes, Linux patch files, and applications install scenario.
Confirm that the execution interruption processing is completed properly. If interruption is
cancelled before the process of the interruption completes and then the scenario is executed,
a scenario execution error may occur.
Are you trying to execute the same scenario which is being executed on another machine? If
you want to execute the same scenario on two or more machines simultaneously, specify the
maximum target number under Multicast Condition to the number of machines that you want
to execute, and then execute the scenario.
A scenario execution error occurs before the machine restarts after a scenario of Distribution of
floppy disk image for BIOS/firmware and a scenario of OS clear installation is executed.
Did you specify the Forced Execution Of A Reboot Is Performed Before Execution on the
scenario Options tab before execution? If not, a scenario is not executed for any machine that
is power on. Modify the scenario, or turn off the machine and execute the scenario again.

3.6. Registering a Managed Machine
Even if you turn on a managed machine, a new registration is not performed.
The DHCP configuration may be wrong, or the DHCP server may not operate properly. Check
the following items:
・ Select Management view -> DPM Server -> Detail Setting -> DHCP Server tab on the
Web Console, and confirm that the Use A DHCP Server configurations are correct.
・ Confirm that the lease IP address in the DHCP scope is not inactive.
・ Confirm that the DHCP server is approved and the IP address can be leased.
・ Confirm that the DHCP address pool has not run out. If the pool has run out, please
secure a sufficient amount of addresses.
・ If using a DHCP server except Windows, confirm that fixed addresses are configured.
The managed machine may be a model that does not support PXE boot, or the network
startup order may be set lower than the HDD.
On an x86 architecture machine, check the network startup order in the BIOS settings. For
methods to check the BIOS, contact your sales or support representative.
If you operate without using the DHCP Server, and the setting is changed to Do Not Use A
DHCP Server in the Management view -> DPM Server -> Detail Setting -> DHCP Server
tab, it is necessary to restart the Management Server to enable the setting. Restart the
Management Server, and then restart the managed machine.
If two or more LAN boards are mounted on the managed machine, confirm that the LAN board
used for DPM communications is registered on DPM Server.
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3.7. Automatic Update
Open Monitor view -> Automatic Update Result List screen, and check the detailed information of
the corresponding machine and date/time, then registration of error log information can be confirmed.
Check the detailed information, and fix each problem.
If you execute automatic update after fixing the problem, reboot the managed machine.
<Detailed Information 1>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update begins
・ An error occurred while preparing for the automatic update.
・ ......
Explanation: Management Server resource may be insufficient. Restart the Management
Server.
<Detailed Information 2>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update begins
・ A socket error occurred.
・ ......
Explanation: WinSock initialization failed.
Check the network configuration of the Management Server (if TCP/IP protocol is installed).
If there is no problem, restart the Management Server.
<Detailed Information 3>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update begins
・ The connection to the client failed.
・ ......
Explanation: The Management Server could not connect to the managed machine.
(1) Use the following procedures to execute ping for the machine.
From the Start menu, select Run, enter cmd in the name column, and click OK. The
command prompt appears. Enter ping IP address or ping hostname and press
Enter. (Enter a space between ping and the IP address/host name.)
If there is no response, check whether there is a problem in the network configuration.
(2) If there is no problem in the network, restart the following services on the machine
side. (If the service is stopped, start again.)
DeploymentManager Agent Service
DeploymentManager Remote Update Service Client
<Detailed Information 4>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update begins
・ Search for the packages that are applicable to the client failed.
・ ......
Explanation: Automatic update function may not be supported on the OS of the machine
on which the error occurred. Check the OS of the machine and language. The following is
the list of OS that automatic update function is supported. The supported language of the
machine is English only.
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OS Name
Windows XP Professional
Windows Server 2003 Standard Edition
Windows Server 2003 Enterprise Edition
Windows Server 2003 Standard x64 Edition
Windows Server 2003 Enterprise x64 Edition
Windows Server 2003 R2 Standard Edition
Windows Server 2003 R2 Enterprise Edition
Windows Server 2003 R2 Standard x64 Edition
Windows Server 2003 R2 Enterprise x64 Edition
Windows Vista Business
Windows Vista Enterprise
Windows Vista Ultimate
Windows Server 2008 Standard
Windows Server 2008 Enterprise
Windows Server 2008 Standard x64
Windows Server 2008 Enterprise x64
Windows Server 2008 R2 Standard
Windows Server 2008 R2 Enterprise
Windows Server 2008 R2 Datacenter
Windows 7 Professional
Windows 7 Ultimate
Windows 7 Enterprise
Windows 7 Professional x64
Windows 7 Ultimate x64
Windows 7 Enterprise x64
Windows Server 2012 Standard
Windows Server 2012 Datacenter
Windows 8 Pro
Windows 8 Enterprise
Windows 8 Pro x64
Windows 8 Enterprise x64
Windows Server 2012 R2 Standard
Windows Server 2012 R2 Datacenter
Windows 8.1 Pro
Windows 8.1 Enterprise
Windows 8.1 Pro x64
Windows 8.1 Enterprise x64
<Detailed Information 5>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update begins
・ Reconfirmation of the connection to the client failed.
・ ......
Explanation: A communication error occurred with the machine.
(1) Use the following procedures to execute ping for the machine.
From the Start menu, select Run, enter cmd in the name column, and click OK. The
command prompt appears. Enter ping IP address or ping hostname and press Enter.
(Enter a space between ping and the IP address/host name.)
If there is no response, check whether there is a problem in the network configuration.
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(2) If there is no problem in the network, restart the following services on the machine
side.(Start if the service is stopped.)
DeploymentManager Agent Service
DeploymentManager Remote Update Service Client
<Detailed Information 6>
・ Computer: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ Creating file in the client failed.
・ ......
Explanation: The disk space of the machine may be insufficient.
Check the machine disk free space. Normally, it required free disk space that at least
three times the size of the package to send.
Example) To apply a 100MByte package, it is necessary that the free space of the
managed machine system drive should be at least 300MByte.
<Detailed Information 7>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ An error occurred while preparing for the file transfer.
・ ......
Explanation: An error occurred in the process before the file is transferred.
The Management Server may have insufficient resources. Restart the Management
Server.
<Detailed Information 8>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ Creating file transfer control thread failed.
・ ......
Explanation: Failed to call WindowsAPI (CreateThread()).
The resource on the Management Server may be insufficient. Restart the Management
Server.
<Detailed Information 9>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ Creating file transfer control thread failed.
・ ......
Explanation: Failed to call WindowsAPI (CreateThread()).
The resource on the Management Server may be insufficient. Restart the Management
Server.
<Detailed Information 10>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ An error occurred during the transfer of xxxxxxxx.
・ ......
Explanation: A communications error occurred when sending a file.
(1) Use the following procedures to execute ping for the machine.
From the Start menu, select Run, enter cmd in the name column, and click OK. The
command prompt appears. Enter ping IP address or ping hostname and press
Enter. (Enter a space between ping and the IP address/host name.)
If there is no response, check whether there is a problem in the network
configuration.
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(2) If there is no problem in the network, restart the following services on the machine
side.( Start if the service is stopped.)
DeploymentManager Agent Service
DeploymentManager Remote Update Service Client
<Detailed Information 11>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ File transfer to the client failed.
・ ......
Explanation: A communications error occurred when sending a file.
(1) Use the following procedures to execute ping for the machine.
From the Start menu, select Run, enter cmd in the name column, and click OK. The
command prompt appears. Enter ping IP address or ping hostname and press
Enter. (Enter a space between ping and the IP address/host name.)
If there is no response, check whether there is a problem in the network
configuration.
(2) If there is no problem in the network, restart the following services on the managed
machine side.
(Start if the service is stopped.)
DeploymentManager Agent Service
DeploymentManager Remote Update Service Client
(3) A file in transit may be in use by another process on the machine.
If virus scan or other such software is running on the machine, a file in transit may be
locked by the virus scan software, and transmission may fail. In such a case, when
the next automatic update is executed, the file is sent again and applied.
<Detailed Information 12>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ During the execution of xxxxxxxx package, an error occurred.
・ ......
Explanation: The package was sent to the machine, however an error occurred during
execution.
(1) Use the following procedures to execute ping for the machine.
From the Start menu, select Run, enter cmd in the name column, and click OK. The
command prompt appears. Enter ping IP address or ping hostname and press
Enter. (Enter a space between ping and the IP address/host name.)
If there is no response, check whether there is a problem in the network configuration.
(2) The disk space may be insufficient.
This error occurs when the machine disk space is insufficient. Check the machine disk
free space. Normally, it requires free disk space that at least three times the size of
the package to send.
Example)
To apply a 100MByte package, it is necessary that the free space of the
managed machine system drive should be at least 300MByte.
(3) Uncompressing failed.
Check whether there is a problem in the package sent to the machine. Confirm
whether the package can be uncompressed on the machine.
<Detailed Information 13>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update Begins
・ "Automatic update completed" response could not be received from the
client.
・ ......
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Explanation:
(1) Use the following procedures to execute ping for the machine.
From the Start menu, select Run, enter cmd in the name column, and click OK. The
command prompt appears. Enter ping IP address or ping hostname and press
Enter. (Enter a space between ping and the IP address/host name.)
If there is no response, check whether there is a problem in the network
configuration.
(2) If there is no problem in the network, restart the following services on the managed
machine side. (Start if the service is stopped.)
DeploymentManager Agent Service
DeploymentManager Remote Update Service Client
<Detailed Information 14>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ automatic update notice begins
・ A socket error occurred.
No such host is known.
・ ......
Explanation:
(1) Use the following procedures to execute ping for the machine.
From the Start menu, select Run, enter cmd in the name column, and click OK. The
command prompt appears. Enter ping IP address or ping hostname and press
Enter. (Enter a space between ping and the IP address/host name.)
If there is no response, check whether there is a problem in the network
configuration.
(2) If there is no problem in the network, restart the following services on the managed
machine side. (Start if the service is stopped.)
DeploymentManager Agent Service
DeploymentManager Remote Update Service Client
<Detailed Information 15>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update time setting begins
・ Automatic update or scenario execution is in progress in the client.
Automatic update time setting will become valid after restarting the
client.
・ ......
Explanation:
The automatic update time configurations will be enabled when the machine is started
next time.
<Detailed Information 16>
・ Machine: xxx (MAC:xx-xx-xx-xx-xx-xx)
・ Automatic update time setting begins
・ Setting in the client failed.
Automatic update time setting will be valid after restarting the
client.
・ ......
Explanation:
Connection to the managed machine failed because the managed machine power status
is OFF, or the communications port is closed. The automatic update time configurations
will be enabled after the client is restarted.
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The same package is distributed repeatedly in automatic update.
Until the Management Server recognizes that the package has been applied, the distribution
is repeated at every automatic update. Check the following items, and perform the process for
each.
<When the package type is HotFix>
・ The MS number is wrong
Check the MS number and correct it.
・ The HotFix that cannot be discerned from the MS number
Set the ID information.
・ OS and language are not correct
Check the OS and language, and correct them.
・ ID information is wrong
If a file such as text format (*.txt) without file version is specified for ID information file
path, the applied status cannot be recognized if the file version is specified. If the file
version is need to be specified, make the item blank. Also, if it is specified to replace or
version up as the changed type using text format file, the applied status cannot be
correctly recognized. In the case of text format, specify new or delete for the changed
type
<When the package type is service pack>
・ Major version and minor version are wrong.
Check major version and minor version and correct them.
・ OS and language are not correct
Check the OS and language, and correct them.
・ ID information is wrong
ID information is not necessary in the case of service pack. Set the correct values to for
major version and minor version.
<When the package type is application>
・ Display name, display version is wrong.
Check the display name and display version and correct them.
・ OS and language are not correct.
Check the OS and language, and correct them.
・ ID information is wrong
If a file such as text format (*.txt) without file version is specified for ID information file
path, the applied status cannot be recognized if the file version is specified. If the file
version is need to be specified, make the item blank. Also, if it is specified to replace or
version up as the changed type using text format file, the applied status cannot be
correctly recognized. In the case of text format, specify new or delete for the changed
type.
An automatic update error is displayed on the screen, and automatic update fails.
The disk capacity of the Management Server may be insufficient.
Check the disk capacity of the Management Server. If disk capacity is insufficient, secure the
necessary disk capacity, and then restart the Management Server.

55

3.8. Automatic Download
An error occurred in automatic download. In Management view -> DPM Server icon -> Package
Download Settings screen -> Latest Download Information column, XXXX/XX/XX XX:XX:XX
Automatic Download Failed is displayed, and check the Event Viewer to find an error log
registered.
Check the log information registered in the Event Viewer, and perform the processes for each
item.
After the processes complete, execute the automatic download again.
<Log Information 1>
DownloadFile: Failed to create the download directory, Dir = XXX.
Explanation:
Failed to create directory.
This error occurs when the disk space of the managed machine is insufficient. Check the disk
free space.

・

<Log Information 2>
DownloadFile: Failed to parse URL, URL = XXX.
Explanation:
Unable to analyze address.
IP address of the Package Web Server may not be correct. Confirm items such as whether
only valid characters are used, or port configurations are correct. For details, see Section
2.7.3, "Package Download Setting" in Web Console Reference Guide.

・

<Log Information 3>
DownloadFile: Failed to connect proxy server, Serve Name = XXX.
Explanation:
Cannot connect to the proxy server.

・

Check the below items in the following order:
(1) The proxy server address may not be correct. Confirm items such as whether only valid
characters are used, or port configurations are correct.
(2) The network settings may not be correct.
Check whether user identification is set to the proxy server. Use an HTTP proxy if using
a proxy.
<Log Information 4>
DownloadFile: Failed to connect server, Serve Name = XXX.
Explanation:
Failed to connect to the Package Web Server.

・

Check the below items in the following order:
(1) IP address of the Package Web Server may not be correct. Confirm items such as
whether only valid characters are used, or port configurations are correct.
(2) The network settings may not be correct.
Check whether user identification is set in the proxy server. Use the HTTP proxy if
using a proxy.
<Log Information 5>
DownloadFile: Web server happened exception, Serve Name = YYY.
Refer to the following detailed message in the log information registered to the event viewer.
SendRequest: Http response error status = XXX.
(Possible values for XXX are: 500, 501, 502, 503, 504, 505)

・
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An error code in line with RFC2616 is added to an error message indicated by error code
XXX. For details, see RFC2616.
<Log Information 6>
・ DownloadFile: Failed to get response or response is error, URL = YYY.
Refer to the following detailed message in the log information registered to the event
viewer.
SendRequest: Http response error status = XXX.
(Possible values for XXX are: 400, 401, 402, 403, 404, 405, 406, 407, 408, 409, 410,
411, 412, 413, 414, 415)
An error code following RFC2616 is added to an error message displayed by error code
XXX. For details, see RFC2616.
Example) SendRequest: Http response error status = 404
->The specified URL does not exist.
<Log Information 7>
・ DownloadFile: The free disk isn't enough to download, URL = XXX.
Explanation:
This error occurs when the disk space of the Management Server is insufficient. Check the
disk free space.
<Log Information 8>
・ DownloadFile: The file cannot be refresh, Filename = xxx.
Explanation:
Failed to update the file. Check whether a file named xxx is in use.
If the file is in use, close it, and then download again.
<Log Information 9>
・ PmDlDownloadPackages: Failed to compress files, Web Server ID = xxx,
Package ID = xxx.
Explanation:
This error occurs when the disk space of the Management Server is insufficient. Check the
disk free space.
Automatic download is configured, however it is not executed even when the set time is reached.
Check the items below by the following order:
(1) In Management view -> Package Download Setting screen, check Latest Download
Information.
If XXXX/XX/XX XX:XX:XX Automatic Download Failed is displayed, see Log Information 1
through 9 of Section 3.8, "Automatic Download."
(2) Check if the Package Web Server is added as the target of automatic download on the
Package Download Setting screen. If none of the Package Web Servers are added,
automatic download is not executed. After adding a Package Web Server, perform an
automatic download again.
(3) Check whether the Perform Automatic Download checkbox is selected on the Package
Download Setting screen. If not, the automatic download cannot be performed.
If the above procedure does not solve the problem, confirm that automatic update is not in
progress, and then restart the Management Server.
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3.9. Power On
The machine cannot be turned ON when executing Power On or executing scenario.
When the machine was forcibly shut down on the POST screen, Remote Power On may not
function at the next time.
In this case, turn off the power after POST is completed, or start up the OS and then shut it
down.
Although the power is ON, the icon displayed on the machine is power OFF.
The screen may not be updated. Click Refresh on the Operation menu, or enter F5 to
refresh the screen.
The power is turned ON, however a remote power ON error is displayed on the machine list.
The managed machine may not support PXE boot, or the network boot order may be set
lower than the HDD.
For x86, check the network boot order in the BIOS settings. For methods to check the BIOS,
contact your sales or support representative.
The VMware ESX/ESXi virtual machine cannot be turned ON when executing Power On or
executing scenario.
The VMware ESX/ESXi virtual machine cannot be turned on because Remote Power On is
not support for these machines. Turn the power ON manually.

3.10. Schedule Management
Although you set the power management schedule, the machine power is not turned ON/shut down
at the specified time.
The machine may have been running a scenario. If the machine is running a scenario at the
time set to Power ON/shutdown, the power will not be turned ON/shut down.

3.11. Machine Information Import/Export
Although the machine information is imported, the machine is not displayed on the managed
machine list.
Click Refresh on the Operation menu, or refresh the screen by pressing F5 key, and then
the machine will be displayed.
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3.12. Network Settings
The following error message was displayed:
Failed to delete the computer name of the server.
Check the network environment, and restart.
The machine may not be connected to the network.
Check whether the network cable is connected to the machine, and then restart.
Once DHCP server and the Management Server have been separately on the different machines, the
MAC address of the machine cannot be obtained.
The DHCP server on the Management Server may be running. On the Management Server,
select Management Tools -> Services from Start menu, and confirm that "DHCP Server" is
stop. If it is running, disable Startup Type on the Properties screen, and stop the service.
On the Web Console, Management view -> DPM Server icon -> Detail Setting, -> DHCP
Server tab -> DHCP Server is installed on an another machine checkbox may be cleared.
Check if DHCP Server is installed on another machine is checked. If the checkbox is not
selected, select it and click OK, and then reboot the Management Server. (If the Management
Server cannot be rebooted, stop all services listed in Appendix A, "Service List" by selecting
Management Tools -> Services from Start menu, and then start them.)
The scenario cannot be executed because the managed machine cannot execute network boot.
Network booting order may be set lower than the HDD in the BIOS configuration. Set the start
order of the PXE network boot higher than the HDD, and then execute the scenario again.
When you try to manage different network by using two or more LAN boards, the following errors are
displayed.
PXE-E51: No DHCP or proxyDHCP offers were received.
PXE-E55: proxyDHCP service did not reply to request on port 4011.
Perform the following procedures Step (1) and (2).
(1) Change the IP address used by the DHCP server.
1) From Start menu, select Administrative Tools -> DHCP.
2) DHCP screen appears. Right-click the server name from the tree view, and then select
Properties.
3) Properties screen appears. Select the Advanced tab and click Binding.
4) Binding screen appears. Select only the IP address to be used and click OK.
5) From Start menu, select Management Tools -> Services, and then restart the DHCP
Server.
(2) Change the IP used by DPM.
1) From Management View -> DPM Server icon -> Detail Setting screen -> General tab ->
-> Server Information -> IP Address on the Web Console screen, set the IP address
which was set in Step (1).
When DHCP Server and the Management Server have been separately on the different machines, the
following error was displayed at network boot execution.
PXE-E55: proxyDHCP service did not reply to request on port 4011.
A DHCP server may exist which is set to option 60(060 Class ID) in DHCP server options. Check
the DHCP server option settings, and delete the option 60(060 Class ID) setting.
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Following error is displayed after changing the default gateway of the Management Server.
PXE-E55: proxyDHCP service did not reply to request on port 4011.
There is a case when network profile is changed by changing default gateway on Windows OS.
There is possibility that the port used on DPM might not be opened on the changed network
profile.
Confirm the network profile currently valid and whether the port used on DPM is opened or not.
Open the port used on DPM when it is not opened.
See Section 3.1 "Port Opening Tool " in Tool Reference Guide.
If you execute a scenario, the following errors are displayed.
PXE-E51:No DHCP or proxyDHCP offers were received.
PXE-E53:No boot filename received
PXE-E55:PROXY DHCP Service did not reply to request on port 4011.
The DHCP server installation location configuration is incorrect.
Open Management View -> DPM Server icon -> Detailed Setting screen on the DPM main
window screen, and check that the setting of DHCP server tab is correct.
Even if configuration is already correct, reconfigure the settings.
If an error is displayed despite correct settings, first change the current settings to different
settings (if the actual environment is DHCP Server is installed on the machine, then change it
to DHCP Server is installed on an another machine, and if it is DHCP Server is installed on
an another machine, then change it to DHCP Server installed on the machine), and then
reconfigure the settings correctly.
Example) If DHCP Server is installed on the machine is selected::
(1) Select DHCP Server is installed on an another machine
(2) Click OK
(3) According to the message displayed on the screen to restart the services
(4) Select DHCP Server is installed on the machine
(5) Click OK
(6) According to the message displayed on the screen to restart the services
Confirm whether the address pool of DHCP is starved or not.
When it is starved, keep adequate address pool.
Confirm that STP (spanning tree protocol) is not executed on LAN switch.

If you assigned IP addresses of the same segment to a machine with two or more LAN boards, power
status cannot be detected properly.
If static IP addresses are assigned to LAN boards which are not connected to LAN cables, the
machine may not be able to communicate normally. If any LAN boards are not connected to LAN
cables, either use DHCP settings without assigning static IP addresses, or set nothing for them.
During network boot, the following message is displayed on the screen of the managed machine, and a
scenario execution error occurs.
PXE-E32: TFTP open timeout
The TFTP port (port number: 69) may be blocked due to the port blocking functionality of
Windows Firewall, or other security software. Confirm that the TFTP port is not blocked on the
Management Server. It is necessary to unblock the TFTP port in order to perform operations on
DPM.

3.13. Operation Without DHCP Server
An error occurs in Power ON, or Add Machine.
Confirm if DPM Client is installed on the managed machine. See Section 2.2, "Installing
DPM Client" in Installation Guide for the installation method.
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Failed in executing Backup scenario/restore scenario/ disk configuration check scenario from
bootable CD.
Check the following:
Is the managed machine registered?
Is a scenario assigned to the managed machine?
Is the scenario assigned to the managed machine correct?
Is a Multicast Scenario assigned?
Does the scenario specify two or more tabs, such as specifying both the Backup/Restore
tab and the HW Setting tab selected?
An error occurs by scenarios excluding backup scenario, restore (unicast) scenario, or
disk configuration scenario.
If you insert a bootable CD into the managed machine and execute Backup/Restore Scenario
from the Web Console, the scenario executes on a machine except the machine specified and the
scenario completes properly, however a scenario execution error occurs on the machine specified
in Operation.
The machine may be mounted to two or more LAN boards which are executed the
scenario, and each of those boards may be registered to DPM. If there are two or more
registrations for the same machine, delete the unnecessary registrations, and then execute
backup/restore again.
Even if you set a bootable CD to start the machine, the backup/restore scenario does not start.
Is the CD the first in boot order?
If not, change the boot order so that CD boot comes first.

If you insert the bootable CD and start the machine, A state of communication was bad
condition is displayed on the screen.
Some kind of error may have occurred.
・ If timeout occurs before the managed machine connect to the Management Server:
Set a greater value for Remote Power ON Timeout on the Network tab of the Detail
Setting screen, and then run backup/restore again.
For details, see Section 2.7.1.3, "Network Tab" in Web Console Reference Guide.
・ If using a bootable CD and Do Not Use A DHCP Server is not selected on the DHCP
Server tab of the Management Server Detail Setting screen:
see Section 2.7.1.4, "DHCP Server Tab" in Web Console Reference Guide and set the
DHCP Server tab items which correspond to the correct environment.
*The Management Server must be restarted after the configuration is changed.
・ If the MAC address of the LAN board on the managed machine is not registered to DPM,
which is in communication with the Management Server:
Register an appropriate MAC address to DPM, and execute backup/restore again.
・ If neither of the above apply:
For reasons such as the network being unconnected or influences from the network, the
Management Server and the managed machine may be under a condition where they
cannot connect with each other. Check the network status between the Management
Server and the managed machine, and then execute backup/restore again.
If you insert the bootable CD and start the managed machine, the following message is displayed
on the screen, and processing is interrupted:
linuxrc: Cannot find CD-ROM Drives.
This error occurs when the bootable CD is unable to recognize a device.
If using a USB CD/FD drive, change the port which connects to the drive, and then try
again.
The CD drive used may not be supported by DPM.
If you are using such drives, prepare another CD drive, or execute backup/restore by using
Use A DHCP Server.
When the managed machine has embedded SATA RAID configuration and the bootable
CD storage file which has been used when creating bootable CD is other than
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"ia32_080331_24", there is a possibility that the driver file to recognize CD drive to the
bootable CD might not be installed.
For the detail, contact your sales or support representative.
Backup/restore does not start, and the following message appears on the screen.
(The x below is a number.)
ERROR: Failed to read a file (x)
If backup target correspond to one of the following situation, error is displayed because the
following target must be recognized earlier than disk,
・ If a USB device is connected to backup target machine.
・ When interface is existing for backup target machine in order to connect USB device.
・ When CD-DVD drive is built in the chassis of BladeServer.
In this case, change the disk number of the scenario, and then execute the scenario.
Also, the recognized disk number depends on the device, so if the same error occurs after
changes, change the device numbers again and then execute backup.
If restore is interrupted, the following messages are displayed:
ERROR: Found the eof during the input of a binary stream.
gzip: stdin: unexpected end of file.
When restore is interrupted during data transfer, these messages may be displayed. If this
message was displayed after restore was interrupted, execute restore again, or setup the
OS.
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3.14.

Local Restoration without using the
Management Server

If any problem occurs in local restoration, contact your sales or support representative.

3.15.

PackageDescriber

Following error is displayed when you try to start PackageDescriber on Windows Vista.
"Unable to access jarfile PackageDescriber.jar"
There is a possibility that setting of "Temporary Folder" has not been changed from default.
Execute either of following settings.
・ Invalidate "User Account Control: UAC" and use PackageDescriber.
To invalidate,uncheck Use User Account Control (UAC) to help protect your computer
from Start menu, click Control Panel -> User Accounts -> Turn User Account Control on
or off.
・ Execute as administrator
(1) Click Start menu -> All programs -> right click DPM PackageDescriber and select
Properties
(2) Properties of DPM PackageDescriber is displayed, click OK after checking Run this
program as an Administrator on Privilege Level on Compatibility tab.
(3) Click Continue when Access Denied is displayed.
(4) Right click the short cut icon of DPM PackageDescriber on desktop and select Properties
and follow steps (2) and (3).
Click Accept when User Account Control screen is displayed when PackageDescriber is
started after setting above.
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3.16. Collecting the Data in Case of Trouble
 When you would like to inquire a failure while you use DPM, please send the following information:
・ Information of DPM version/the module for the machine model
・ Managed machine information
- Machine model/Product number
- Configuration of optional products/Product number
- Machine name
- MAC address
- OS type
・ Date and time that the obstacle occurred
・ Failure information
- How to operate DPM, and what occurred.
・
Display on screen
- Management Server
- Managed machine
・ Repeatability
- Always occurs
- There is a case that it succeeds
- Succeeded in the past, however it began to fail one day
- On other managed machine, it occurred or not
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DPM log collected by DPM Log tool
- Management Server
- Managed machine
*When the failure occurred, please collect log immediately
If a scenario is executed on the same machine again, the log file may be overwritten.
After about 1 week since the failure occurred, the log of DHCP Server will be overwritten.
・ The figure of network configuration
・

The method to collect the DPM log is listed below.
Target machines of collecting logs are the Management Server, the Database Server(only when the database
is configured on the different machine from the Management Server), and managed machines.
 Log collection Procedure (Windows x86/x64)
Collect logs on the Management Server, the Database Server (only when the database is configured on the
different machine from the Management Server), and the managed machine on which the error occurred,
following the procedure below.
(1) Check that all operations of DPM (the following) are completed or ended.

・ Operations for managed machines (scenario execution, automatic update, file distribution, file
deletion and obtaining the information in File/Folder List screen) are completed.
・ Web Console and various tools of DPM are ended.
(2) Log on to the machine by a user with administrator authority.
Log on to the Management Server (in the environment that the database is configured on the same
machine with DPM Server) by a user who installed DPM Server.
Log on to the Database Server by a user who configured the database.
(3) When you collect logs on the Management Server, it is unnecessary to do this procedure.
Skip to Step (4). When you collect logs on the Database Server or the managed machine, copy the
following folder to the arbitrary folder.
<Installation media>:\DPM\TOOLS\DpmLog
(4) Start the command prompt and move to the following folder.
・ On the Management Server:
<DPM Server installation folder>\DpmLog
・ On the Database Server or the managed machine:
The folder which was copied in the Step (3).
Example) If the location of the folder copied in Step (3) is "C:\"
cd /d C:\DpmLog
(5) Add option -A, and execute DpmLog.exe. See the following message and send the collected log.

 When "log" folder exists under the folder of step (4), delete "log" folder and
execute DpmLog.exe.
 While DpmLog.exe is running, do not perform any DPM operation.
(6) Delete the saved log folder because it is unnecessary after sending logs.
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 Log collection Procedure (Linux)
Collect the following files. When you collect the files, try not to change the time stamp (for example, -p option
of cp command and so on), then use a command such as zip or gzip to compress on Linux, and then send.
- System Setting File
/etc/hosts
/etc/resolv.conf
/etc/sysconfig/network
/etc/sysconfig/clock (only when you use earlier than Red Hat Enterprise Linux 7)
/etc/sysconfig/iptables (only when you use earlier than Red Hat Enterprise Linux 7)
/etc/sysconfig/ipchains (only when you use earlier than Red Hat Enterprise Linux 7)
/etc/rc.d/rc (only when you use earlier than Red Hat Enterprise Linux 7)
/etc/sysconfig/network-scripts/ifcfg-*

-

-

Version Information
- In the case of earlier than Red Hat Enterprise Linux 7 or earlier:
/etc/redhat-release
- In the case of -Red Hat Enterprise Linux 7 or later:
/etc/redhat-release
/etc/os-release
- In the case of SUSE Linux Enterprise:
/etc/SuSE-release

-

Files related to DPM Client
All files located in folder /opt/dpmclient/
/var/log/messages* (All files whose name begin with "messages")
All files located in folder /tmp/dpm/ (If existed)

-

Disk and partition Information
Collect the execution result of the following command.
fdisk -l

-

Network Information
Collect the execution results of the following command.
ifconfig -a
ip addr show
netstat -anp
route
ps -axm | grep depagtd
iptables -L
System Information
Collect the execution results of the following command.
uname -a
lspci -vx
dmidecode
biosdecode
dmesg -s 524288
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Appendix A Service List
The following is DPM services and processes.
"Automatic" listed in the column of "Startup Type" in the following table is resident service.
 DPM Server
Service

Display

Startup

Process Name

The

Name

Name

Type

*1

Number

Function

of
APIServ

DeploymentManager

Automatic

apiserv.exe

Process
1

mkParams.exe

1 or

Tool to create a Windows

more

disk duplication data file

magicsend.exe

1

Executing remote power-on

ipconfig.exe

1 or

Setting of Network

API Service
(Child process)

Setting of scenario
execution and each item

more
nbtstat.exe

1 or

Setting of Network

more
bkressvc

DeploymentManager

Automatic

bkressvc.exe

1

Executing backup/restore

Automatic

depssvc.exe

1

Receiving the information of
OS/service packs/patches
from the managed machine

Automatic

pxesvc.exe

1

Controlling network (PXE)
boot

ipconfig.exe

1 or

Setting of network

Backup/Restore
Management
depssvc

DeploymentManager
Get Client
Information

PxeSvc

DeploymentManager
PXE Management
(Child process)

more
nbtstat.exe

1 or

Setting of network

more
PxeMtftp

DeploymentManager

Automatic

PXE Mtftp

(*2)

pxemtftp.exe
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1

TFTP server function

rupdssvc

DeploymentManager

Automatic

rupdssvc.exe

1

Executing remote update

zip.exe
unzip.exe

1
1

File compressing command
File extracting command

schwatch.exe

1

Managing schedule

magicsend.exe

1

Executing remote power-on

ipconfig.exe

1 or

Setting of network

Remote Update
Service
(Child process)
schwatch

DeploymentManager

Automatic

Schedule
Management
(Child process)

more
nbtstat.exe

1 or

Setting of network

more
ftsvc

DeploymentManager

Automatic

ftsvc.exe

1

File transfer service

CHKOS32.exe

1 or
more

Tool for obtaining OS type

Transfer
Management
(Child process)

*1
The default installation folder is
C:\Program Files\NEC\DeploymentManager.
*2
When you install DPM Server, if you select Do not use the TFTP service of DPM on TFTP Server tab of the
Detailed Setting screen, this item will be disabled.
 Database *1
Service Name

Display Name

Startup

Process Name

The

type

*2

Number

Function

of
Process
MSSQL$

SQL Server

Automatic

sqlservr.exe

1

Instance Name
(Instance Name)
*1
This runs on the machine on which the database is configured.
*2
The default installation folder is
C:\Program Files\Microsoft SQL Server\MSSQL11.Instance Name\MSSQL12\Binn.
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SQL database
(DPM)

 Image Builder (Remote Console)
Service Name
Display Name
None

Startup Type

None
(Child
process)

Process Name *1
DIBuilde.exe

The Number of
Process
1

DIBPkgMake.exe

1

DIBPkgDel.exe

1

mkParams.exe

1

ExecLinuxIParm.j
ar

1

ExecLinuxSysRep
.jar

1

winftc.exe

1

zip.exe

1

CHKOSCD.EXE

1

Function
Image
Builder
Tool for
creating a
package
Tool for
deleting a
package
Tool for
creating a
Windows
disk
duplicatio
n data file
Tool for
creating a
Linux
install
paramete
rs
Tool for
creating a
Linux disk
duplicatio
n data file
File
transferrin
g tool
File
compress
ing
command
Tool for
checking
OS media

*1
The default installation folder is C:\Program Files\NEC\DeploymentManager.
 DPM Command Line
Service Name

Display Name

Startup

Process

The

Type

Name *2

Number of

Function

Process
None

None

dpmcmd.exe

1 or more

Scenario
execution and so
on from DPM
Command Line

*1
The default installation folder is C:\Program Files\NEC\DeploymentManager.
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 DPM Client (Windows)
Service Name

Display Name

Startup

Process

The

Type

Name *1

Number of

Function

Process
depagent

DeploymentManager

Automatic

Agent Service

DepAgent.ex

1

e

Powering off the
managed
machine from
DPM Server

rupdsvc

DeploymentManager

Automatic

rupdsvc.exe

1

Executing remote

Remote Update

update

Service Client

Sending the
information of
OS/service
packs/patches to
DPM Server

(Child process)

unzip.exe

1

File extracting
command

Execution

1

package

File
GetBootServ

Installer of the

1

erIP.exe

Searching the
Management
Server

None

None

DPMTray.ex

1 or more

e

*1
The default installation folder is:
・ In the case of x86: C:\Program Files\NEC\DeploymentManager_Client
・ In the case of x64: C:\Program Files (x86)\NEC\DeploymentManager_Client
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Automatic update
status display

 DPM Client (Linux)
Service
(daemon) Name

In the case of
earlier than Red
Hat Enterprise
Linux 7/
SUSE Linux
Enterprise:
depagt

Display Name

Startup
Type

Process Name

None

Automatic

depagtd *1

The
Number
of
Process
1,2

depagtd

1

rpm

1

shutdown

1

mv

1

echo

1

unzip

1

touch

1

GetBootServerIP

1

(Child
process)
Executed by
system
function

In the case of
Red Hat
Enterprise Linux 7
or later :
depagt.service

Function

DPM Client
Service
Powering off
from DPM
Server
Executing
remote
update
Sending the
information of
OS/patches of
the managed
machine to
DPM Server
rpm package
installer
Shutdown
command
Command for
moving files
Command for
displaying
messages
Command for
extracting
compressed
files
Command for
changing the
time stamp
Searching the
Management
Server

*1
The installation directory is /opt/dpmclient/agent/bin (fixed value).

Procedure and Order of Starting and Stopping the
Service
DPM Server is linked to and dependent on each DPM related service. Therefore, if you start or stop services
manually, execute by following order.
About DPM Client services (daemon), according to a given order for start/stop .
・ Start service order
(1) SQL Server (Instance name)
(2) Services that begin with "DeploymentManager"
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・ Stop service order
(1) Services that begin with "DeploymentManager"
(2) SQL Server (Instance name)

Appendix B Event Log
About the event log, contact your sales or support representative.

Appendix C Error Information
About error information, contact your sales or support representative.

Appendix D Network Port and Protocol List
 Communication Ports used by DPM
 When you configure DHCP server and NFS Server on the Management Server, the
communication which is described in each table is done between the Management Server and
the managed machines.
 About opening the communication port (Windows OS), which is used by DPM, automatically or
manually, see Section 3.1, "Port Opening Tool" in Tool Reference Guide.
・ Communications between the Management Server and managed machines
Item
Management Server
Protocol Con Address
nec Specificati
Executable
Port
Availabil
tion on
File Name
No.
ity of
Dire
Modifyin
ctio
g Port
n
No.

Power On

magicsend.
exe

*1

No

UDP

->

Shutdown
/Monitorin
g DPM
Client
(Only for
SSC
product)
Existence
Confirmati
on (Power
ON/OFF
Status
Check)

apiserv.exe
schwatch.ex
e

*1

No

TCP

->

DirectBroad
cast
*2
Unicast

apiserv.exe
schwatch.ex
e
apiserv.exe
schwatch.ex
e

- *3

No

->

0 *3

No

ICMP
Echo
request
ICMP
Echo
request

<-
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Managed Machine
Port
Avail Executa
No.
abilit ble File
y of Name
Modi
fying
Port
No.
5561
No

26509
*10

Yes

Unicast

8 *3

No

Unicast

- *3

No

For
Windows:
DepAgen
t.exe
For
Linux:
depagtd

Network
Boot

OS
installation
by disk
duplication
*7
Restore
(Multicast)
*8

Restore
(Unicast) *9

pxesvc.exe

67

No

pxesvc.exe

67

No

pxesvc.exe
pxesvc.exe
pxesvc.exe
pxesvc.exe
pxemtftp.ex
e
pxemtftp.ex
e
bkressvc.ex
e
bkressvc.ex
e
ftsvc.exe

67
4011
4011
67
69

No
No
No
No
No

69

No

26503
*10
26502
*10
26508
*10

ftsvc.exe

26508
*10
26501
*10
26530
*10
26508
*10
26501
*10
26508
*10
26501
*10
26505
*10
26508
*10

bkressvc.e
xe
bkressvc.e
xe
ftsvc.exe

Backup *9

bkressvc.e
xe
ftsvc.exe

CD Boot

bkressvc.e
xe
pxesvc.exe

Disk
Configurati
on Check *9

ftsvc.exe

<-

Yes

UDP
(DHCP)
UDP
(DHCP)
UDP
UDP
UDP
UDP
UDP
(TFTP)
UDP
(TFTP)
TCP

68

No

68

No

->
<<->
<-

Broadcast
*4 *5
Broadcast
*4 *5
Unicast
Unicast
Unicast
Unicast
Unicast

68
68
4011
4011
*6

No
No
No
No
No

->

Unicast

*6

No

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No

Yes

UDP

->

Multicast

Yes

Yes

TCP

<-

Unicast

26530
*10
*1

Yes

TCP

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No

Yes

TCP

<-

Unicast

*1

No
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->

No

Installing
service
packs,
hotfixes,
Linux
patch
files, and
applicati
ons by
remote
update

rupdssvc.ex
e

*1

No

TCP

->

Unicast

26510
*10

Yes

rupdssvc.ex
e

*1

No

UDP

->

Multicas
t

26529
*10

Yes

rupdssvc.ex
e

2650
7
*10

Yes

TCP

<-

Unicast

*1

No

Acquisiti
on of
managed
machine
OS/HotFi
x
informati
on
Automati
c Update
Request

depssvc.exe

2650
4
*10

Yes

TCP

<-

Unicast

*1

No

For Windows:
rupdsvc.exe
For Linux:
depagtd

rupdssvc.ex
e

2650
6
*10
2650
7
*10
*1

Yes

TCP

<-

Unicast

*1

No

rupdsvc.exe

Yes

TCP

<-

Unicast

*1

No

rupdsvc.exe

No

TCP

->

Unicast

Yes

rupdsvc.exe

Yes

TCP

<-

Unicast

No

rupdsvc.exe

Yes

TCP

<-

Unicast

*1

No

rupdsvc.exe

pxesvc.exe

2650
6
*10
2650
7
*10
67

26511
*10
*1

No

UDP
(DHCP
)

<-

Broadca
st
*4

68 *11

No

pxesvc.exe

67

No

UDP
(DHCP
)

->

Broadca
st
*4

68 *11

No

pxesvc.exe

4011

No

UDP

<-

Unicast

*1

No

pxesvc.exe

4011

No

UDP

->

Unicast

*1

No

Windows:
GetBootServerIP.exe
Linux:
GetBootServerIP
Windows:
GetBootServerIP.exe
Linux:
GetBootServerIP
Windows:
GetBootServerIP.exe
Linux:
GetBootServerIP
Windows:
GetBootServerIP.exe
Linux:
GetBootServerIP

pxemtftp.exe

69

No

<-

Unicast

*1

No

pxemtftp.exe

69

No

UDP
(TFTP)
UDP
(TFTP)

->

Unicast

*1

No

rupdssvc.ex
e
Automati
c update
notice

rupdssvc.ex
e
rupdssvc.ex
e
rupdssvc.ex
e

Searchin
g the
Manage
ment
Server
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For Windows:
rupdsvc.exe
For Linux:
depagtd
For Windows:
rupdsvc.exe
For Linux:
depagtd
rupdsvc.exe (Windows
only)

File
apiserv.exe
*1
No
TCP
->
Unicast
26520 Yes
For Windows:
distributi
rupdsvc.exe
on,
For Linux:
File
depagtd
deletion,
Obtainin
g the
informati
on in
File/Fold
er List
screen
*1
The port is automatically assigned.
*2
A machine on the same segments as the Management Server is addressed 255.255.255.255.
If the segments are different than those of the Management Server, the address specification is direct
broadcast.
Example) The segment 192.168.0.0(MASK=255.255.255.0) is addressed 192.168.0.255.
*3
With ICMP (Internet Control Message Protocol), communication specifying the port number is not performed,
however it is routed by using the value in the ICMP Type field value.
*4
A packet relayed by DHCP relay may be addressed as Unicast.
*5
Only if the DHCP and the Management Server are installed on different machines.
*6
Undefined. Depends on the LAN board ROM of the machine.
*7
The protocols and port numbers listed in Restore are also required.
*8
The protocol and the port number in the table of Network Boot are also needed. (You can restore by multicast
only when you use DHCP server.)
*9
If operations are performed using DHCP, the protocols and port numbers listed in Network Boot items are
also required.
If operations are performed without using DHCP, the protocols and port numbers listed in CD Boot are also
required.

75

*10
The default values of the ports to be used were changed from DPM Ver6.1. When you upgraded from the
version earlier than DPM Ver6.1, the port numbers used before upgrading are taken over. Therefore, the port
numbers are different from them (Values in the above table) of when you install DPM Server newly. However,
the port for Web service (56050) is not taken over and new port (26500) is used. When you use the port which
was used before upgrading, modify manually. The following is the default port when you install DPM Server
newly and when you upgrade DPM Server.
When you install DPM Server newly
When you upgrade DPM Server from the
version earlier than DPM Ver6.1

26500
26501
26502
26503
26504
26505
26506
26507
26508
26509
26510
26511
26529
26530

26500
56020
56022
56030
56011
56060
56024
56028
56023
56010
56000
56025
56001
56021

*11
When both you operate DPM with DHCP server and you operate DPM without DHCP server, the part of the
communication sequence of DHCP is used and UDP:68 is used.
 When OS of managed machine is either of the following, ports and programs are
opened as the following, depending on the status of the network which is used when
DPM Client is installed.
・ In the case of Windows Server 2008/Windows Vista
Ports and programs are opened for either of public profile, private profile, or domain
profile of Windows Firewall.
・ In the case of Windows Server 2008 R2/Windows 7 or later
- About DeploymentManager (DepAgent.exe) and DeploymentManager
(rupdsvc.exe), ports and programs are opened for active public profile, private
profile, or domain profile of Windows Firewall.
- About File and Printer Sharing (Echo Request - ICMPv4-In), ports and programs
are opened for either of public profile, private profile, or domain profile of
Windows Firewall.
Example)
When the managed machine joins domain and the Domain Profile was changed, the
port and the product which are used by DPM will be blocked, and the machine cannot
communicate anymore.
Open the ports or programs used by DPM in Domain Profile in advance on the
managed machine that joins domain or the master machine of OS installation by disk
duplication.
You can open the ports of the managed machine or programs in Domain Profile,
following the procedure below.
・ Setup by domain policy:
Specify in the domain policy of domain controller on Windows Server 2008/Windows
Vista or later.
- Setup locally on the managed machine:
(1) On the managed machine, from Inbound Rules of Windows Firewall with
Advanced Security, right-click the following items and select Properties.
・ DeploymentManager(DepAgent.exe)
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・ DeploymentManager(rupdsvc.exe)
・ File and Printer Sharing (Echo Request - ICMPv4-In)(*)
* In the case of Windows Vista/Windows7
Network - Echo Request(ICMPv4-In)
(2) In Advanced tab of Properties dialog, select Domain checkbox in Profiles.
 For Windows Server 2003(SP1/SP2)/Windows Server 2003 R2, all connection request
are blocked by secirity update(Post-Setup Security Updates:PSSU) until latest update
program is applied.
Update the managed machine to latest status by Windows Update and so on, or
release PSSU manually. To release PSSU manually, log on by administrator and close
the security update window.
 When you set the firewall service on the managed machine to automatic start, all ports
are closed from when the machine is started to when the firewall service is started
regardless of that the firewall function is enabled or disabled. At this timing, if you
operate the following, the processing will fail.
・ If you execute a scenario or shut down, an error occurs because the Management
Server cannot communicate with the managed machine.
In this case, after confirming that the managed machine is powered on the Web
Console, execute a scenario or shut down.
・ When the version and revision of DPM Client is not matched with that of DPM
Server, automatic upgrade of DPM Client will be done. However, the automatic
upgrade fails because the Management Server cannot communicate with the
managed machine at this timing.
In this case, upgrade by a scenario, see Section 3.3.2,"Manual Upgrading for DPM
Client" in Installation Guide.
・ Communication between the Database Server and the Management Server
Item
Database Server
Protoco Conne Address
ction
Specifica
Execu Port
Availa l
Directi tion
table
No.
bility
on
File
of
Name
Modif
ying
Port
No.
Database
26512
Yes
TCP
<Unicast
*2

Management Server
Port
Avail Executab
No.
abilit le File
y of
Name
Modi
fying
Port
No.
apiserv.ex
*1
No
e
bkressvc.
exe
depssvc.e
xe
ftsvc.exe
pxesvc.ex
e
rupdssvc.
exe
schwatch.
exe

*1
The port is assigned automatically.
*2
When you change the port number, do it before installing DPM Server newly. After that, you cannot
change.
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・ Communication between DHCP server and managed machines
Item
DHCP Server
Protocol
Conne Address
ction
Specifica
Executa Port
Availa
Directi tion
ble File
No.
bility
on
Name
of
Modif
ying
Port
No.
Obtaining
67
No
UDP
<Broadcast
the IP
(DHCP)
*1
address
67
No
UDP
->
Broadcast
(DHCP)
*1
*1
A packet relayed by DHCP relay may be addressed as Unicast.

Managed Machine
Port
Availabili
No.
ty of
Modifyin
g Port
No.

68

No

68

No

Exec
utabl
e
File
Nam
e

・ Communication between NFS Server and managed machines
Item
NFS Server
Protocol
Conne Address
Managed Machine
ction
Specifica Port
Executa Port
Availa
Availabili Exe
Directi tion
ble File No.
bility
No.
ty of
cuta
on
Name
of
Modifyin
ble
Modif
g Port
File
ying
No.
Nam
Port
e
No.
OS Clear
111
No
TCP
<Unicast
*1
No
Installation
111
No
UDP
<Unicast
*1
No
1048 No
TCP
<Unicast
*1
No
*2
1048 No
UDP
<Unicast
*1
No
*2
2049 No
TCP
<Unicast
*1
No
2049 No
UDP
<Unicast
*1
No
*1
The port is automatically assigned.
*2
There is a case that the port number might be changed automatically. when communication fails in, use
"rpcinfo -p" command to check the port number being used by mountd (NFS mount daemon) service, and
then open the port. If the problem is not solved by this method, turn off the Windows firewall.
・ Communication between HTTP Server and the managed machine
Item
HTTP Server
Protocol
Conne
ction
Execut Port
Availa
Directi
able
No.
bility
on
File
of
Name
Modif
ying
Port
No.
OS Clear
80
No
TCP
<Installation
(HTTP)
The port is automatically assigned.
*1
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Address
Specifica
tion

Unicast

Managed Machine
Port
Availa Executa
No.
bility
ble File
of
Name
Modify
ing
Port
No.
*1
No

・ Communication between FTP Server and the managed machine
Item
FTP Server
Protocol
Conne
ction
Execut Port
Availa
Directi
able
No.
bility
on
File
of
Name
Modif
ying
Port
No.
OS Clear
21
Yes
TCP
<Installation
(FTP)
The port is automatically assigned.
*1

Address
Specifica
tion

Unicast

・ Communication between the Web Console and the Management Server
Item
Machine used for Web
Protocol Conne Address
Console
ction
Specifica
Directi tion
Executa Port
Availa
on
ble File
No.
bility
Name
of
Modify
ing
Port
No.
Web
*1
No
TCP
->
Unicast
Console
(HTTP)

Managed Machine
Port
Availa Executa
No.
bility
ble File
of
Name
Modify
ing
Port
No.
*1
No

Management Server *2
Port
No.

80 *3

Availa
bility
of
Modif
ying
Port
No.
Yes

Execu
table
File
Name

Web
service
(IIS)

*1
The port is automatically assigned.
*2
Because the Management Server uses the port (TCP:26500) for the internal processing (the communication
between DPM Server and Web Service (IIS)), do not use this port by other applications.
*3
You can change the port to be used by the following procedure.
Example) For IIS 7.0
1) Select Administrative Tools -> Internet Information Services (IIS) Manager from Start menu.
2) Internet Information Services (IIS) Manager screen appears. Right-click computer name -> Sites
-> Web Site name on the tree view, and select Edit Bindings... and change the port number.
・ Communication between Image Builder (Remote Console) and the Management Server
Item
Machine used for Image
Protocol
Con
Address
Manageme
Builder (Remote Console)
necti Specifica nt Server
on
tion
Executa Port
Availabi
Port
Availabi Execu
Dire
ble File
No.
lity of
No.
lity of
table
ction
Name
Modifyi
Modifyi File
ng Port
ng Port Name
No.
No.
Image
DIBuilde *1
No
TCP
->
Unicast
26508 Yes
ftsvc.e
Builder
.exe
*2
xe
(Remote
Console)
*1
The port is automatically assigned.
*2
When you upgrade DPM Server from the version earlier than DPM Ver6.1, the port before upgrading
(56023) is taken over.
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・ Communication between DPM Command Line and the Management Server
Item
Machine used for DPM
Protocol
Connec Addre
Command Line
tion
ss
Directio Specif
Executa Port
Availabi
n
icatio
ble File
No.
lity of
n
Name
Modifyi
ng Port
No.

Management Server *2
Port
No.

Availabi
lity of
Modifyi
ng Port
No.

Exe
cuta
ble
File
Nam
e
Web
servic
e (IIS)

DPM
dpmcmd *1
No
TCP
->
Unicas 80 *3
Yes
Command
.exe
(HTTP)
t
Line
*1
The port is automatically assigned.
*2
Because the Management Server uses the port (TCP:26500) for the internal processing (the communication
between DPM Server and Web Service(IIS)), do not use this port by other applications.
*3
You can change the port to be used by the following procedure.
Example) For IIS 7.0
1) Select Administrative Tools -> Internet Information Services (IIS) Manager from Start menu.
2) Internet Information Services (IIS) Manager screen appears. Right-click computer name -> Sites
-> Web Site name on the tree view, and select Edit Bindings... and change the port number.
Depending on the type of OS, the DPM service may not be able to start if there is a port
conflict between the DPM service and other service or application causing by the
Ephemeral port. For methods of checking and handling problems with ephemeral ports,
see "Regarding ports used by DPM" of Section 2.2.1, "Network Environment" in First Step
Guide.
For router and switch configuration, see the manual of the network device or contact the
vendor.
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Appendix E Log Files Output by DPM
 DPM Server
The following are logs which are output on the machine on which DPM Server is installed.
In the machine on which DPM Server is installed, Image Builder and DPM Command Line
are also installed. See also the description of Image Builder (Remote Console) and DPM
Command Line below.
Folder
File

Output Content
Recording Method

Folder

File
Output Content
Recording Method

<DPM Server installation folder>\Log
(Default: C:\Program Files\NEC\DeploymentManager\Log)
apiserv.csv
apitrace.log
bkressvc.csv
DepInit.csv
depssvc.csv
DIBPkgMake.csv
ftsvc.csv
pmdb.log
pminfo.log
pxemtftp.csv
pxesvc.csv
rupdssvc.csv
schwatch.csv
rupdssvc_managed machine MachineName_ managed machine
MACAddress.log
DPM trace log, monitor log, error information, database access log
The maximum size of apitrace.log is 1MByte. The maximum size of
pmdb.log and pminfo.log is 128KByte. The maximum size of the other files
is 10MByte.
If the size of apitrace.log exceeds the maximum file size, the file is
overwritten in order from the top location in the file.
The pmdb.log and pminfo.log and rupdssvc_manmaged machine
MachineName_managed machine MACAddress.log are managed by 2
generations. (If the size exceeds the maximum file size, the file is renamed
to *.log.bak, and the original *.log.bak is deleted.)
The *.csv files are managed by 5 generations.
(If the size of *.csv exceeds the maximum file size, the file is renamed to
*.csv.1, and each original *.csv.n file is renamed to *.csv.n+1, and *.csv.4 is
deleted.)
Also, each file can be deleted manually. (Delete *.csv and apitrace.log
manually after stopping the DPM services.)
<DPM Server installation folder>\Datafile\LogFile\SnrReport
(Default:
C:\Program Files\NEC\DeploymentManager\Datafile\LogFile\SnrReport)
Scenario.rpt
Scenario Execution Results
There is no restriction for the file size.
Furthermore, you can delete it from the Web Console. (For delete
procedure details, see Section 4.5.2, "Delete Log" in Web Console
Reference Guide.)
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Folder

File
Output Content
Recording Method

<DPM Server installation folder>\Datafile\LogFile\AuReport
(Default:
C:\Program Files\NEC\DeploymentManager\Datafile\LogFile\AuReport)
Index.rpt
managed machine MACaddress.rpt
Execution log for automatic update (application automatic delivery) on a
managed machine
Each managed machine is individually managed by MAC address.
There is no restriction for the file size.
The maximum record numbers of the logs can be set from the Web
Console.
According to the setting of maximum number of logs, if the log number
exceeds it, the logs will be deleted from index.rpt file from the oldest in
order, or 10% of the logs will be deleted from the oldest.
For maximum number of log settings, see Section 4.7.2, "Maximum
Number of Logs Settings" in Web Console Reference Guide.
Furthermore, when the oldest log records from Index.rpt are deleted, the
related information is deleted from managed machine MACaddress.rpt.
Also, you can delete the log file from the Web Console. (For delete
procedure details, see Section 4.7.4, "Delete Log" in Web Console
Reference Guide.)

Folder

File

Output Content
Recording Method

<DPM Server installation folder>\Datafile\JSLog
(Default:
C:\Program Files\NEC\DeploymentManager\Datafile\JSLog)
CmdUserJSLog_YYYYMMDD.csv
CmdSelfJSLog_YYYYMMDD.csv
MngUserJSLog_YYYYMMDD.csv
MngSelfJSLog_YYYYMMDD.csv
* YYYYMMDD is a date.
Monitor log (the user operations/DPM Server internal operations)
Each file is saved to a file dated to the current day.
There is no restriction for the file size.
The files dated to the current day cannot be deleted while DPM Services
are running. Only those files whose dates have already passed can be
deleted even if those services are running. Furthermore, a file is
automatically deleted when 30 days have elapsed from the file creation
date.
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Folder

File

Output Content
Recording Method

<DPM Server installation folder>\WebServer\Logs
(Default:
C:\Program Files\NEC\DeploymentManager\WebServer\Logs)
Browser.log
Error.log
JSOX-Event.csv
LibAPI.log
Polling.log
Trace.log
WebConsole.log
Web Console error notifications, traces, and monitor logs
The maximum size of Polling.log is 1MByte. The maximum size of the
other files is 10MByte.
Polling.log is increased in one file, and the JSOX-Event.csv file is
managed by 2 generations. (If the size exceeds the maximum file size,
the file name is renamed to JSOX-Event.csv.1, and the original
JSOX-Event.csv.1 is deleted.)
The other files are managed by 6 generations. (If the size of *.log
exceeds the maximum file size, the file name is renamed to *.log.1, and
each original *.log.n file is rename to *.log.(n+1), and *.log.5 is deleted.)
Each file can also be deleted manually.

Folder
File

Output Content
Recording Method

Folder
File

Output Content
Recording Method

<Folder for Image>\upload\dpmupload
(Default: C:\Deploy\upload\dpmupload)
managed machine MACaddress_B.zip
managed machine MACaddress_B.Error.zip
managed machine MACaddress_R.zip
managed machine MACaddress_R.Error.zip
managed machine MACaddress_P.zip
managed machine MACaddress_P.Error.zip
managed machine MACaddress.zip
managed machine MACaddress_Error.zip
managed machine-side results from execution of backup/restore/disk
format check
Each managed machine is individually managed by MAC address.
The maximum size of each file is approx. 310KByte + (the number of
target disks * approx. 50KByte).
In the case of the managed machine in UEFI mode, approx. 460KByte +
(the number of target disks * approx. 50KByte).
The file is overwritten each time a scenario is executed.
You can delete each file manually.
%SystemRoot%
(Default: C:\WINDOWS)
Inst_Dpm_Db.log
Inst_Dpm_Dbadmin.log
Inst_Dpm_Ports.log
Inst_DPM_Mng.log
DPM installation log
There is no limit for the file size.
Inst_Dpm_Db.log is overwritten each time DPM Server is installed, and
the size does not increase after installing. Other files increase
monotonically. Each file can be deleted manually.
When you configure the Database Server, Inst_Dpm_Db.log and
Inst_Dpm_Dbadmin.log are not created.
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 Database Server
The following are logs which are output on the machine on which the database is installed.
Folder

File
Output Content
Recording Method

<SQL Server installation folder>\MSSQL12.Instance name
\MSSQL\Log
(Default:
C:\Program Files\Microsoft SQL Server\MSSQL12.Instance name
\MSSQL\Log)
ERRORLOG
log_n.trc (n is a number)
SQL Server log
There are no file size restrictions on any of the files.
ERRORLOG is managed by 7 generations. (If SQL Server(Instance
name) restarts, the file name is changed to ERRORLOG.1, and each
original ERRORLOG.n file is changed to become ERRORLOG.(n+1),
and ERRORLOG.6 is deleted.)
log_n.trc is managed by 5 generations. (If SQL Server(Instance name)
service is restarted at a state in which log_1.trc to log_5.trc exist,
log_1.trc is deleted, and new log_6.trc is created.)
ERRORLOG cannot be deleted.
The log_n.trc cannot be deleted while SQL Server(Instance name)
service is running. Past logs can be deleted even if the service is
running.
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 DPM Client (Windows)
The following are logs which are output on the managed machine on which DPM Client (Windows) is installed.
Folder
File

Output Content

Recording Method

Folder
File
Output Content
Recording Method

Folder
File
Output Content
Recording Method

<DPM Client installation folder>
(Default: C:\Program Files\NEC\DeploymentManager_Client)
DepAgent.log
rupdsvc.log
DPMTray.log
GetBootServerIP.log
WindowsChgIP.log
DPM Client service log
Logs of Automatic Update Status Display Tool
Logs of searching the Management Server by DPM Client
The maximum file size of DPMTray.log is 1MByte. The maximum file
size of other files is 2MByte.
If the size of DPMTray.log exceeds the maximum size of the file, all logs
are cleared and the log is recorded newly.
DepAgent.log, rupdsvc.log, GetBootServerIP.log, and
WindowsChgIP.log are managed by 2 generations. (If the size exceeds
the maximum file size, the file name is changed to *.log.bak, and the
original *.log.bak is deleted.)
Each file can also be deleted manually.
%SystemRoot%\DeploymentManager\JSLog
(Default: C:\WINDOWS\DeploymentManager\JSLog)
CliSelfJSLog_YYYYMMDD.csv
* YYYYMMDD is a date.
Monitor log (DPM Client internal operations)
There is no restriction for the file size.
Saved to a file dated to the current day.
Files dated to the current day cannot be deleted while DPM Services
are running. Only those files whose dates have already passed can be
deleted even if those services are running. The file is automatically
deleted when 30 days have elapsed from the file creation date.
%SystemRoot%
(Default: C:\WINDOWS)
Inst_DPM_Win_Cli.log
DPM install log
There is no limit of the file size on each file. Each time DPM Client is
installed, the file size is increased monotonically. The file can be
deleted manually.
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 DPM Client (Linux)
The following are logs which are output on the managed machine on which DPM Client (Linux) is installed.
Folder
File

Output Content

Recording Method

/opt/dpmclient/agent/log
depinst.log
depagtd.log
GetBootServerIP.log
LinuxChgIP.log
Install log of DPM Client
Service log of DPM Client
Logs of searching the Management Server by DPM Client
There is no limit for the file size in depinst.log, and the file is overwritten
each time DPM Client is installed.
The depagtd.log, GetBootServerIP.log, and LinuxChgIP.log are
managed by 2 generations. (If the size exceeds the maximum file
size(2MByte), the file name is changed to *.log.bak. Original *.log.bak is
deleted.)
The file can be deleted manually.

 Image Builder (Remote Console)
The following are logs which are output on the machine on which Image Builder (Remote Console) is installed.
Folder
File

Output Content
Recording Method

<Image Builder (Remote Console) installation folder>\Datafile\JSLog
(Default: C:\Program Files\NEC\DeploymentManager\Datafile\JSLog)
ImgUserJSLog_YYYYMMDD.csv
ImgSelfJSLog_YYYYMMDD.csv
* YYYYMMDD is a date.
Monitor log (operations performed by the user/Image Builder internal
operations)
There is no limit for the file size, and each file is saved to a file dated to
the current day.
Files dated to the current day cannot be deleted while DPM Services are
running. Thus, only those files whose dates have already passed can be
manually deleted even if those services are running. The file is
automatically deleted when 30 days have elapsed from the file creation
date.

 DPM Command Line
The following are logs which are output on the machine on which DPM Command Line is installed.
Folder
File
Output Content
Recording Method

<DPM Command Line installation folder>\Log
(Default: C:\Program Files\NEC\DeploymentManager\Log)
DPM_Trace1.csv
Monitor log (operations performed by the user/DPM Command Line
internal operations)
The maximum file size of DPM_Trace1.csv is 10MByte.
It is managed by 5 generations. (If the size of DPM_Trace1.csv exceeds
the maximum file size, the file name is changed to DPM_Trace2.csv, and
each original DPM_Tracen.csv file is changed to become
DPM_Trace[n+1].csv, and DPM_Trace5.csv is deleted.)
Each file can also be deleted manually. Files cannot be deleted while
DPM Command Line is running.
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Appendix F

Procedure to Check the Version
of Each Component

 DPM Server
Check the bottom (footer) of the Web Console.
About starting the Web Console and logging into DPM, see from Section 5.1.1, "Starting the Web Console" to
Section 5.1.2, "Logging into DPM" in Installation Guide.
Example) DeploymentManager 6.4-XXXXX
* XXXXX is the number.
 DPM Client (Windows)
1) From the Start menu, click Control Panel -> Programs and Features.
2) Select Views menu-> Choose Details.
3) On the Choose Details screen, select the Version check box and click OK.
4) Check the Version displayed on DeploymentManager.
Example) 6.40.000
 DPM Client (Linux)
Execute the command below, and check the version displayed.
cd /opt/dpmclient/agent/bin
depagtd -v
Example) DeploymentManager Ver6.4
 Image Builder (Remote Console)
1) From the Start menu, click Control Panel -> Programs and Features.
2) Select Views menu-> Choose Details.
3) On the Choose Details screen, select the Version check box and click OK.
4) Check the Version displayed on DeploymentManager (Image Builder).
Example) 6.40.000
 DPM Command Line
1) From the Start menu, click Control Panel -> Programs and Features.
2) Select Views menu-> Choose Details.
3) On the Choose Details screen, select the Version check box and click OK.
4) Check the Version displayed on DeploymentManager (DPM Command Line).
Example) 6.40.000
 PackageDescriber
1) From the Start menu, click Control Panel -> Programs and Features.
2) Select Views menu-> Choose Details.
3) On the Choose Details screen, select the Version check box and click OK.
4) Check the Version displayed on DPM PackageDescriber.
Example) 6.40.000
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Appendix G

Glossary

 Alphabetical order

A
Automatic Download

Function which automatically downloads a new package from the Package Web
Server to the Management Server at timing configured in advance.

automatic update

The managed machine checks the Management Server at timing configured in
advance, if there has packages which has not been applied. It will send distribution
request and automatically apply those packages.

automatic update
notice

Notification that the Management Server issues to the managed machine so that
automatic update can be executed in real time when a package of highest urgency is
registered to the Management Server and when issuing automatic notification to the
managed machine from Web Console.

B
Backup/Restore

Function to backup or restore data contained on a disk by either disk unit or partition
unit.

D
Deploy-OS

A Linux OS (kernel) customized for DPM that runs on the managed machine.
Deploy-OS is sent to the managed machine from the Management Server, and is
deployed on the memory of the managed machine during backup/restore/disk
configuration check.
Furthermore, if operating DPM without using a DHCP server, Deploy-OS is included
in the bootable CD.

DHCP server

DHCP (Dynamic Host Configuration Protocol) is a protocol that dynamically modifies
the IP address.
DHCP sever refers to the machine or network device which has the functionality to
provide configuration information by DHCP.
In DPM, the DHCP server is used when a managed machine performs a PXE boot,
or to assign an IP address during OS installation by disk duplication.

Disk configuration
check

Function to check disk configuration before backup/restore is executed. You can
check the disk number specified at the time of backup/restore.

DPM Client

DPM component. It runs on a managed machine and transfers data to DPM Server.
Also controls the managed machines (shutdown and so on) and sends information
such as package applied/not applied.

DPM Command Line

DPM component. It performs processing such as status check of the managed
machine and scenario execution from the command line.

DPM Server

DPM component. It performs processing to the managed machine through Web
Console operations or DPM Command Line.

E
Effective sector backup

Backup of the only effective sectors of a hard disk.

ESX, ESXi

Virtualization software offered by VMware, Inc.
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Express5800 Series

Business-oriented workstation server offered by NEC.

Full Sector backup

Backup all sectors of hard disk.

F
File Operation

Function to copy or overwrite the file on the Management Server to the arbitrary
place on the managed machine. Also, you can see the detail information of files and
folders on the managed machine and delete a file.

G
Guest OS

The OS operating on the virtual machine.

H
Host OS

Indicates the OS which is the infrastructure on which virtualization software runs.

Hyper-V

Microsoft virtualization software offered by Microsoft.

I
IIS

Abbreviation for Internet Information Services, software for internet services offered
by Microsoft.

Image Builder

Create packages, and disk duplication data files used by OS installation by disk
duplication, and then registers them to the Management Server.

Image Builder (Remote
Console)

Image Builder used on machine except the Management Server.

Installation media

Indicates the media bundled in DPM product.

L
LAN board

Board used to connect to a LAN (Local Area Network). Also called NIC (Network
Interface Card) or LAN adaptor.

Local restoring

Function to store a backup image file, which is created by DPM, in DVD(CD) media
and restore the image only on the managed machine by using the media.

M
MAC Address

Abbreviation for Media Access Control address, which is a fixed ID number for each
LAN board.
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Managed Machine

Machine which managed by DPM. May be noted as Computer, Client, or Client
Computer.

Management Server

The physical server that DPM Server is installed.

Master Image

Disk image of the machine which is the master of OS installation by disk duplication
source.

Master Machine

The machine which is the master of OS installation by disk duplication source.

O
OS clear Installation

Function that installs Red Hat Enterprise Linux while setting detailed configurations
for the managed machine.

OS installation by disk
duplication

Machine cloning function using Sysprep tools (master image creation tools) and DPM
backup/restore functionality.

P
Package

The combination of patch, application or package application file.
Created by either Image Builder or PackageDescriber.

Package Information
File

File that basic information, execution information, applicable OS information,
dependent information and identification information of a patch or an application are
stored.
Created by either Image Builder or PackageDescriber.

Package Registration

Upload a package created by PackageDescriber to the Package Web Server.
Furthermore, the package needs to be re-uploaded if has been modified by
PackageDescriber to the Package Web Server.

Package Web Server

The web server which stores the packages. The Package Web Server can share
packages for two or more Management Servers. Access must be allowed by HTTP
protocol.

PackageDescriber

DPM component. A tool that creates packages and registers them to the Package
Web Server.

Patch

Windows OS service packs and hotfixes released by Microsoft.

PXE boot (network
boot)

Abbreviation for Preboot eXecution Environment boot.
A boot method that using PXE (network booting standard) by the LAN board to start a
program through the network.
It is used by DPM to detect a managed machine, or to execute backup/restore/disk
configuration check or package distribution.

R
Remote update

Installing service packs, hotfixes, Linux patch files, and applications, and applications

S
Scenario

A configuration used to execute processing such as Distribution of floppy disk image
for BIOS/firmware, OS clear installation, Installing service packs, hotfixes, Linux patch
files, and applications, and backup/restore/disk configuration check.
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SigmaSystemCenter

The management software of IT platforms including virtual environment.
DPM is bundled into SSC software suit.

SQL Server

Relational model database server provided by Microsoft. The data of DPM is stored in
SQL Server.

Sysprep

Windows OS deployment tool provided by Microsoft.

V
Virtual Machine

Indicates the machines virtually run on the virtual machine server.

VLAN

Technology which builds a logical network, and then divides the network into two or more
broadcast domains, unlike physically network configuration.

W
Web Console

Checks the status of a managed machine and executes processing to a managed
machine.

WOL(Wake On LAN)

Function which allows a machine connected to LAN to be turned on the power from
another machine via network.

X
XenServer

Virtualization software provided by Citrix.
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